marvell 88w8335

i downloaded the marvell driver an unzipped it to my home file, but do not seem to be able to cd the file. please advise correct statement to cd the file.

cd /home/dave/WG311v3 V1.0/Driver/Windows XP/
bash: cd: /home/dave/WG311v3: No such file or directory

You cannot cd to a file, only a directory.

give the cmd,
cd /home/dave
and then see if the file or directory you are looking for is shown
it may have extracted to its own subdirectory.

On 12/10/2011 09:36 AM, keellambert wrote:
> You cannot cd to a file, only a directory.
> give the cmd,
> cd /home/dave
> and then see if the file or directory you are looking for is shown
> it may have extracted to its own subdirectory.

Before you try to build a driver, we should find out if you need to. If that
device is PCI, run the command ‘lspci -n’ and post the output. If it is USB,
then post the output of the lsusb command.

dave@linux-vbz4:~> cd /home/dave/

looks dead ended. must be one of those improvements. ok so what do i do now now to cd to the file. i tried in terminal cd /tmp/ then unzipped but that asked questions about each file in the folder, yes no kinda stuff.

dave@linux-vbz4:~> sudo /sbin/lspci -n
root’s password:
00:00.0 0600: 1106:3189 (rev 80)
00:01.0 0604: 1106:b198
00:0a.0 0200: 11ab:1faa (rev 03)
00:0f.0 0104: 1106:3149 (rev 80)
00:0f.1 0101: 1106:0571 (rev 06)
00:10.0 0c03: 1106:3038 (rev 81)
00:10.1 0c03: 1106:3038 (rev 81)
00:10.2 0c03: 1106:3038 (rev 81)
00:10.3 0c03: 1106:3038 (rev 81)
00:10.4 0c03: 1106:3104 (rev 86)
00:11.0 0601: 1106:3227
00:11.5 0401: 1106:3059 (rev 60)
00:12.0 0200: 1106:3065 (rev 78)
01:00.0 0300: 10de:002d (rev 15)

dave@linux-vbz4:~> sudo /sbin//lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge (rev 80)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge
00:0a.0 Ethernet controller: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless (rev 03)

here is what i get when i unzip in tmp. i said yes to all, not knowing any better.

dave@linux-vbz4:~> cd /tmp/
dave@linux-vbz4:/tmp> unzip
replace WG311v3 V1.0/Utility/setup.exe? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: WG311v3 V1.0/Utility/setup.exe
replace WG311v3 V1.0/Driver/Windows XP/WG311v3.INF? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: WG311v3 V1.0/Driver/Windows XP/WG311v3.INF
replace WG311v3 V1.0/Driver/Windows XP/ [y]es, [n]o, [A]ll, [N]one, [r]ename: y
extracting: WG311v3 V1.0/Driver/Windows XP/
replace WG311v3 V1.0/Driver/Windows XP/WG311v3.sys? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: WG311v3 V1.0/Driver/Windows XP/WG311v3.sys
replace WG311v3 V1.0/Driver/Windows XP/WG311v3XP.sys? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: WG311v3 V1.0/Driver/Windows XP/WG311v3XP.sys
replace WG311v3 V1.0/Driver/Windows ME/WG311v3.INF? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: WG311v3 V1.0/Driver/Windows ME/WG311v3.INF
replace WG311v3 V1.0/Driver/Windows ME/WG311v3.sys? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: WG311v3 V1.0/Driver/Windows ME/WG311v3.sys
replace WG311v3 V1.0/Driver/Windows 98/WG311v3.INF? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: WG311v3 V1.0/Driver/Windows 98/WG311v3.INF
replace WG311v3 V1.0/Driver/Windows 98/WG311v3.sys? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: WG311v3 V1.0/Driver/Windows 98/WG311v3.sys
replace WG311v3 V1.0/Driver/Windows 2000/WG311v3.INF? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: WG311v3 V1.0/Driver/Windows 2000/WG311v3.INF
replace WG311v3 V1.0/Driver/Windows 2000/ [y]es, [n]o, [A]ll, [N]one, [r]ename: y
extracting: WG311v3 V1.0/Driver/Windows 2000/
replace WG311v3 V1.0/Driver/Windows 2000/WG311v3.sys? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: WG311v3 V1.0/Driver/Windows 2000/WG311v3.sys
replace WG311v3 V1.0/Driver/Windows 2000/WG311v3XP.sys? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: WG311v3 V1.0/Driver/Windows 2000/WG311v3XP.sys
dave@linux-vbz4:/tmp> sudo /usr/sbin/ndiswrapper -i/WG311v3.INF
root’s password:
install/manage Windows drivers for ndiswrapper

usage: ndiswrapper OPTION
-i inffile install driver described by ‘inffile’
-a devid driver use installed ‘driver’ for ‘devid’ (dangerous)
-r driver remove ‘driver’
-l list installed drivers
-m write configuration for modprobe
-ma write module alias configuration for all devices
-mi write module install configuration for all devices
-v report version information

where ‘devid’ is either PCIID or USBID of the form XXXX:XXXX,
as reported by ‘lspci -n’ or ‘lsusb’ for the card

a few questions before i go any further

1 ) version of opensuse
2 ) desktop environment,e.g. kde,gnome,lxde

ok, here’s the way i install drivers with ndiswrapper

  1. create a folder in your home directory—call it driver ( or something easily remembered )
  2. download zip file to the newly created directory
  3. once downloaded, open your file manager & navigate to the folder
  4. once in this folder, right click the zip file & select extract here
  5. look for a win xp folder and have a look for a cat, sys, and inf file
  6. if these files are present,good,open a terminal
  7. type
 cd   /Home/user_name/driver/winxp

and press enter.where" user_name" is your username
8) su to root
9) type

 ndiswrapper  -i name_of_inf

and press enter
10) type

 ndiswrapper -l 

and press enter. this should display if the driver was installed
11) type

 ndiswrapper  -ma 

and press enter
12) type


this should list wireless in your area

if all has gone well,use network manager to set up a connection

hope this helps

it is 12.4 gnome fallback. i will give your method a try, i tried to use the method in my notes from 10 but it no longer works.

dead ended. i wonder if there is a problem with the net install or gnome fallback?

dave@linux-vbz4:~> cd /Home/dave/driver/winxp
bash: cd: /Home/dave/driver/winxp: No such file or directory
dave@linux-vbz4:~> cd /home/dave/driver/winxp
bash: cd: /home/dave/driver/winxp: No such file or directory

linux is case sensitive, also, did you see a win xp folder ? it could be WINXP,Winxp,WinXp,etc,check the spelling. if you only saw the cat,inf & sys files after extraction you need to modify the command e.g.

 cd /Home/dave/driver 

or try this step by step

  1. download zip file to a new folder ( call it driver or something memorable)
  2. open file manager and navigate to folder
  3. right click and select extract to here
  4. open extracted folder and navigate to Windows XP folder check you have a cat,sys and inf file
  5. copy the Windows xp folder to your home folder,you may have to put an underscore between Windows and XP if there is a space between them,
  6. open a terminal & cd to the windows xp folder,then su to root
  7. type
 ndiswrapper -i WG311v3.inf 

then press enter

  1. type
 ndiswrapper -l 
  then press enter,this should list installed drivers and devices
  1. type
 ndiswrapper -ma 
   then press enter.this will write a module alias for the device
  1. type
 modprobe ndiswrapper 
     then press enter  
  1. type
iwlist scan 
    then press enter.this will list wireless access points in your area
  1. you should now be able to set up wireless connection as normal

i had to move the contents of “Windows XP” to a file called driver. that is the cat, sys and INF.

dave@linux-vbz4:~/Downloads/driver> sudo /usr/sbin/ndiswrapper -i WG311v3.INF
installing wg311v3 …
dave@linux-vbz4:~/Downloads/driver> /user/sbin/ndiswrapper -l
bash: /user/sbin/ndiswrapper: No such file or directory
dave@linux-vbz4:~/Downloads/driver> sudo /usr/sbin/ndiswrapper -l
wg311v3 : driver installed
device (11AB:1FAA) present

ok, got it working. notice the improvement to terminal with gnome, more typing. you need to add /user/ sbin/ before ndiswrapper or iwlist, or no result. for me more typing = more errors!

now one more glitch, seems every time i boot the the machine no wireless. if i go into yast>net settings it asks about modprobe for ndiswrapper, i click yes and exit, then up comes the wireless. anyway to make this permanent?

two methods

  1. YaST > System > /etc/sysconfig-editor
    at the left open System > Kernel > MODULES_LOADED_ON_BOOT
    add ndiswrapper and Finish


2)add the code to /etc/init.d/boot.local

this proving to be a hard nut to crack. i went into yast and put in ndiswrapper and clicked ok, save did not appear. i put in modprobe ndiswrapper and got the save function. reboot and no connection. back into yast and put in ndiswrapper and got the save function. reboot and no connection. so what do i need to add to /etc/init.d/boot.local, ndiswrapper, modprobe ndiswrapper or some other statement?

#! /bin/sh

Copyright (c) 2002 SuSE Linux AG Nuernberg, Germany. All rights reserved.

Author: Werner Fink, 1996

Burchard Steinbild, 1996


script with local commands to be executed from init on system startup

Here you should add things, that should happen directly after booting

before we’re going to the first run level.

it took a while to edit the file, /etc/init.d/boot.local, gksudo gedit and sudo gedit would not open it, finally i found gnomesu gedit which opened the file. i tried both ndiswapper and modprobe ndiswrapper and rebooted after each with no result. sudo /sbin/modprobe ndiswrapper still works to open the wireless. awaiting more good advise…

i am looking at yast>kernel settings>pci id setup, any help there?

Try renaming directory /home/myname/.kde4 to /home/myname/x.kde4 and rebooting.

Note: This will loose you your desktop settings.