Mariadb-errormessages-11.2.3-1.3.noarch.rpm has bad checksum

Trying to zypper dup on my TW/KDE system this morning and got bad checksum

expected ca7d144f801c836a1d61e2a99ee8af55cf19bdb021a954e8cdc1689d71f0fd1f57fe16da39fe6dbd9a76bcdd808d484f244873a661da5cde6242531c62bbf21a
but got 0a4f2afb498e92a7be174ba24bbfd680d0121c8c5b9815d811c37ddab1d1821903e710dd10aabae50ad9723c016dcc665b590693e53c5ae84f8db01c9ef4b451

Tried to re-download but still fails. Tried again 2 hours later but still the same. Retrieving from

https://download.opensuse.org/repositories/server:/database/openSUSE_Tumbleweed/

Does anyone else see this? Who to report it to?

Stuart

@broadstairs why are you using a development repository? 11.2.3 is in Tumbleweed?

1 Like

Default version in repo-oss is 11.2.3-1.1.

@broadstairs Do you really need the dev version of mariadb 11.2.3-1.3?
If not:

  1. Remove the dev repo using zypper lr to list all repos and zypper rr <repo-alias> to remove it
  2. Run zypper ref to refresh repos
  3. And install the package from default repo zypper in mariadb. May require you to pass in some of the expert options if zypper complains: --allow-downgrade --allow-vendor-change

I did not realise it was a development repo, in the mists of time it was added for something I needed and just got left. Removed now and everything switched back to main repo.

Thanks Stuart

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.