Many network issues with Tumbleweed

Hello,

I installed the latest Tumbleweed on my laptop, however I am having network problems:

  • Sudenlly my network will stop working (both wired and wireless), everything timeouts or it simply won’t connect.
  • Networking doesn’t work upon resuming from suspend (the connection simply fails).
  • NetworkManager will randomly crash (I only notice because the network icon is gone).
  • Appears the following stack trace on my dmesg:
 3936.995447] ------------ cut here ]------------

  3936.995456] NETDEV WATCHDOG: enp2s0f2 (r8169): transmit queue 0 timed out
  3936.995533] WARNING: CPU: 2 PID: 25 at net/sched/sch_generic.c:461 dev_watchdog+0x21a/0x220
  3936.995536] Modules linked in: uas usb_storage fuse  ccm cmac rfcomm af_packet bnep vboxpci(O) vboxnetadp(O) vboxnetflt(O)  vboxdrv(O) nls_iso8859_1 nls_cp437 vfat fat msr hid_generic usbhid btusb  btrtl btbcm btintel uvcvideo bluetooth videobuf2_vmalloc  videobuf2_memops videobuf2_v4l2 ecdh_generic videodev videobuf2_common  intel_rapl arc4 x86_pkg_temp_thermal intel_powerclamp rtl8723be coretemp  dcdbas kvm_intel btcoexist snd_hda_codec_hdmi dell_wmi_descriptor kvm  rtl8723_common asus_nb_wmi rtl_pci irqbypass snd_hda_codec_realtek  rtlwifi snd_hda_codec_generic iTCO_wdt asus_wmi mac80211 snd_hda_intel  sparse_keymap crct10dif_pclmul crc32_pclmul iTCO_vendor_support  crc32c_intel cfg80211 ghash_clmulni_intel snd_hda_codec r8169 pcbc  rfkill snd_hda_core snd_hwdep aesni_intel snd_pcm joydev snd_timer  rtsx_pci_ms

  3936.995622]  memstick mii snd aes_x86_64 wmi  crypto_simd cryptd glue_helper pcspkr battery thermal button ac  soundcore acpi_pad pcc_cpufreq int3400_thermal acpi_thermal_rel  asus_wireless processor_thermal_device int340x_thermal_zone  intel_soc_dts_iosf i2c_i801 lpc_ich mei_me mei intel_pch_thermal i915  rtsx_pci_sdmmc mmc_core i2c_algo_bit sr_mod xhci_pci drm_kms_helper  syscopyarea sysfillrect sysimgblt fb_sys_fops serio_raw xhci_hcd cdrom  drm usbcore rtsx_pci video sg dm_multipath dm_mod scsi_dh_rdac  scsi_dh_emc scsi_dh_alua efivarfs
  3936.995692] CPU: 2 PID: 25 Comm: ksoftirqd/2  Tainted: G           O      4.18.12-1-default #1 openSUSE Tumbleweed  (unreleased)

  3936.995694] Hardware name: ASUSTeK COMPUTER INC. Z450LA/Z450LA, BIOS Z450LA.204 08/12/2015
  3936.995705] RIP: 0010:dev_watchdog+0x21a/0x220
  3936.995706] Code: 49 63 4c 24 e8 eb 8c 4c 89 ef c6  05 a2 97 c2 00 01 e8 1a fe fc ff 89 d9 4c 89 ee 48 c7 c7 10 14 11 8d 48  89 c2 e8 a0 16 98 ff <0f> 0b eb be 66 90 0f 1f 44 00 00 41 57 45  89 cf 41 56 49 89 d6 41 
  3936.995742] RSP: 0018:ffff9aa180d73da8 EFLAGS: 00010296
  3936.995744] RAX: 000000000000003d RBX: 0000000000000000 RCX: 0000000000000006
  3936.995745] RDX: 0000000000000007 RSI: 0000000000000092 RDI: ffff883f8ed16a90
  3936.995746] RBP: ffff883f8300445c R08: 0000000000000001 R09: 0000000000000447
  3936.995746] R10: 0000000000000001 R11: 0000000000000000 R12: ffff883f83004478
  3936.995747] R13: ffff883f83004000 R14: 0000000000000001 R15: ffff883f8059a880
  3936.995749] FS:  0000000000000000(0000) GS:ffff883f8ed00000(0000) knlGS:0000000000000000
  3936.995750] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
  3936.995751] CR2: 00007feac4b6f000 CR3: 00000001bf20a001 CR4: 00000000003606e0
  3936.995752] Call Trace:
  3936.995772]  ? pfifo_fast_dequeue+0x160/0x160
  3936.995781]  call_timer_fn+0x2b/0x150

  3936.995787]  ? pfifo_fast_dequeue+0x160/0x160
  3936.995791]  run_timer_softirq+0x3c7/0x400
  3936.995809]  ? __switch_to_asm+0x40/0x70
  3936.995813]  ? __switch_to_asm+0x34/0x70
  3936.995828]  ? __switch_to_asm+0x40/0x70
  3936.995832]  ? __switch_to+0x93/0x4c0
  3936.995836]  ? _raw_spin_unlock_irq+0x11/0x30
  3936.995839]  ? finish_task_switch+0x75/0x250
  3936.995843]  __do_softirq+0x111/0x370
  3936.995853]  ? sort_range+0x20/0x20
  3936.995861]  run_ksoftirqd+0x30/0x40
  3936.995868]  smpboot_thread_fn+0xf1/0x1e0
  3936.995871]  kthread+0x112/0x130
  3936.995874]  ? kthread_create_worker_on_cpu+0x40/0x40
  3936.995878]  ret_from_fork+0x3a/0x50

  3936.995894] --- end trace 874d28deffda6984 ]---

My networking hardware is:

02:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 06)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

In most cases, if I unload then reload the modules (r8169 and rtl8723be, respectively) the network will be OK again.

Before, I had openSUSE Leap 15.0 in this machine with no issue at all.

What to do?

Hi and welcome to the Forum :slight_smile:
I see you have virtualbox modules installed, these (and maybe some others, eg bluetooth) taint the kernel, unfortunately at a minimum uninstall virtualbox temporarily and see if it reoccurs to try an narrow down a likely cause. Once the kernel is not tainted and can duplicate, then your likely to get traction from the openSUSE Kernel developers on any bug report.

Similar to this thread perhaps?
https://forums.opensuse.org/showthread.php/533405-Network-Manager-showing-duplicate-entries-and-cannot-reconnect?p=2883105#post2883105
The OP found that upgrading NM to an OBS version helped.

This made NM’s segfaults go away, but not the other problems.

As a workaround I created a script to unload and reload the networking modules, which runs whenever I suspend or resume the system. This seems to have worked around the problem.

Put it inside /usr/lib/systemd/system-sleep and give it +x permission.

#!/bin/bash
 "$1" = "post" ] && exec modprobe r8169
 "$1" = "pre" ] && exec rmmod r8169
 "$1" = "post" ] && exec modprobe rtl8723be
 "$1" = "pre" ] && exec rmmod rtl8723be
exit 0

Aside from the NM solution Malcolm suggested,
Are you sure that your entire networking goes down, or perhaps just name resolution?
Whenever your networking goes down, have you tried pinging your default gateway and any other machines by IP address?

TSU

Next time the issue appears, try


sudo netconfig -f update