Many familiar features missing after new 11.1 installation

After a new installation (not update) of 11.1 with KDE 3.5.x, there are several common software and system features missing.

Kontact, konsole, and dolphin are shown in the favorites list of the application launcher, but with “?” icons next to the names, and nothing starts when those launcher entries are clicked.

The desktop is completely blank, without the usual icons for trashbin, Firefox, OpenOffice, Suse Help, etc.

Specific questions:
Is the exclusion of these applications, and the desktop features, by design, or do I have a broken installation?
Is KDE 3.x still subject to full support under 11.1, or is it being abandoned to encourage adoption of KDE 4.x?

I did a clean reinstall of 11.1/KDE 3.x today after deciding to abandon 11.1/4.x. Overall system performance was noticeably slower in comparison to 11.0/3.x, and various software functions appeared buggy - my conclusion was that KDE 4.1 (as implemented under 11.1) is not production-ready or sufficiently stable for my purposes. In the early going, even after dropping back to 3.x, 11.1 appears to be a step backwards for openSUSE. Performance was much more stable and reliable under 11.0.

Any answers to the specific questions, or other ideas for “cleaning up” my installation would be appreciated. Thanks in advance for assistance.

Sounds like something has gone wrong with your installation. KDE 3.5 (with 11.1) is pretty similar to that with 11.0. If anything perhaps a touch faster but that is about all.

KDE 4 is not everyone’s cup of tea (yet) and I still prefer 3.5 personally.

Thanks for your reply.

Any recommendations? Wipe it off and start over? I went mostly with defaults, a couple of software additions only. Wondering if I should do something differently to get a better outcome.

My installation was from a regular installation DVD (not a live CD) on which I verified the download checksum and did an installation media check, both without errors.

I might add - the desktop under the latest install has some features that resemble KDE 4.x, such as the widget operations icon in the upper right corner. Seems strange to me. Checked “system information” - installed IDE is indicated as 3.5.10.

What you descrfibe as what you see in the desktop is of course when you are loged in as a particular user. You say you did a new install, but did you keep your /home? Because in the home directory of that particular user (in /home/<user>/.kde) are all the things that describe what that user has configured in his destop.

Now when you instaled NOT keeping your /home (and thus your .kde), I do not understand what went wrong. But when you kept your /home there may be some misinterpratation between the old and the new KDE3 (however strange this sounds). You could do a test. Change the name of .kde (to e.g. log out the GUI and login again. This would take you to a default desktop (without all the fine tuning you did of course) so you can see if the problems are still there. You can always change back to the old situation by renaming to .kde again.

When you fear you blow up something with the above test, a safer test is creating a new user (with YaST) and log in as that user. See what it looks like. Remove the user afterwards (in YaST you can then check a box saying something like “remove the users files”).

Thanks for the reply, Henk. Good test suggestions.

I started a second session as root, and created a new test user, then started a third session and logged in as the test user (Malcolm Reynolds, username mal ;)). The desktop looked essentially the same, with one exception - there was no icon in the upper right corner (looks sort of like a half-moon, provides widget command options - isn’t that a KDE 4 feature?) This is missing from both the root and test desktops, but present on my primary user desktop. Also, in all three cases, the favorites list in the application launcher menu (lower left corner) includes previously mentioned non-functioning application entries, and the desktop is otherwise empty of common application shortcuts in upper left screen area.

Background on this installation: I did not apply a previous /home directory to the 11.1 installation - I still have a functioning 11.0/3.x installation in a separate partition. The partition for 11.1 was reformatted during installation. I configured user accounts during installation as follows - 1 primary user with login enabled and NOT defined as administrator; separate administrator account password defined.

One problem encountered after installation: On first login, I was not able to log in as that primary user. I was able to log in as root, and checked user settings under Yast and found no user defined, so I added a user (same user data as specified during installation process). Was then able to use my primary user account. By the way, I experienced this same problem during installation of 11.0, went through the same correction procedure, had no further problems.

So, perhaps another clue to determine what went wrong. Since even the root desktop is malformed in this 11.1 install, I’m prepared to reformat and start from scratch with a fresh go, but I’m still wondering what to do differently during the installation to avoid the same problem. Is it likely that another installation following the exact same steps would produce a different result?

Thanks again, and for any further feedback you can provide.

  • John

Yes, a broken installation definitely. Did you perform the online update during install? (Just a shot in the dark but maybe something went wrong there)

Also, if you didn’t, burn the dvd at the slowest speed.

Thanks for your feedback, Miguel.

No, did not do online update during installation; waited until installation was complete to configure wireless and run an update. I was actually thinking I might do the update during installation as a variation of the prior attempt in the hopes that it would resolve the problem. Would you recommend against that?

I left DVD burn speed at default setting, but I ran a media check from the install DVD menu that reported no error. Is that, in combination with a correct MD5 sum for the .iso file, an adequate assurance of a good disk?

  • John

I think that in that case you can trust the DVD. In any case IMHO it woul be strange that a broken DVD would install without going very mad, much more mad then you have.

But I admit it is strange what you see and I am afraid I have no clue at the moment.

BTW, you better NEVER log into the GUI as root. Using YaST from the strange GUI you have, must be possible (When YaST is not in the menu you can always use ‘Execute command’ and type **yast. **Or even go to the real console (CNTRL-ALT-F1), log in as root and call **yast **there (it then uses the CURSES interface).

Thanks to all for your helpful replies.

I reinstalled 11.1/KDE 3.5.x using the same DVD. I simplified the installation parameters to a near minimum:

  • Very simple disk prep (format single, existing partition, mount as root),
  • Eliminated previously specified mount points of other partitions (except did keep suggested “windows/C” and “swap” mount points)
  • Did enable separate root password (exception from installation default)
  • Kept all other installation defaults, including software selections.

With this “plain vanilla” specification, the installation went smoothly, and all previously mentioned problems were eliminated. I now have a smooth-running system. It seems that it was fairly easy to confuse the installation routine - it’s a nicely polished interface, but certain logical inconsistencies remain (like in partitioning logic, a decline from past releases), and it apparently requires further debugging. The check-box to clone the system for AutoYAST did not work on my three installation attempts. And, I always have to go back and fix the broken OS entries in the GRUB menu. I suspect my somewhat involved mount point specifications may have caused some of the earlier problems (I can provide details if someone would find that useful). So, not exactly root problem solved, but problem avoided.

Thanks again for all the quick and helpful assistance.

  • John