Many bad repositories

Trying to use the one-click installs gives me many bad repositories:
The following repositories could not be added

because it cannot determine the repository type.
How do I fix this?

not using 1-clicks…

You also can delete them…

Don’t use 1-click for installation. It’s OK to use software search, but dangerous to install from its 1-clicks unless you are an expert in repo maintenance. Those particular /GA/pool/ repos aren’t actually valid for 15.4, which is why the errors. Whatever packages you wish to install are probably available from standard repos, and can be searched for as follows:

# ls -Gg /usr/local/bin/zypse
-rwxr-xr-x 1 109 Mar  1  2017 /usr/local/bin/zypse
# cat /usr/local/bin/zypse
#!/bin/sh
zypper --no-refresh se -s $*  | egrep -v 'debug|devel|srcp|openSUSE-20' | egrep 'x86|noarch'| sort
# zypse inxi               # example use
  | inxi | package | 3.1.00-bp153.1.14 | noarch | OSS

If you don’t find what you wish with zypper, try installing and using opi:


# which opi
/usr/bin/opi
# rpm -qi opi | grep -A3 Summary
Summary     : OBS Package Installer (CLI)
Description :
OBS Package Installer (CLI)
Distribution: SUSE Linux Enterprise 15

Delete all those SUSE:SLE* repositories. They do not exist and are not needed.

I of course looked first in zypper.
I need to install nautilus-dropbox which is not there. It also depends on nautilus-extensions which is not there.

bor@10:~> zypper se -s /nautilus.*dropbox/
Loading repository data...
Reading installed packages...


S | Name                       | Type    | Version               | Arch   | Repository
--+----------------------------+---------+-----------------------+--------+----------------
  | nautilus-extension-dropbox | package | 2020.03.04-bp154.2.93 | x86_64 | Main Repository
bor@10:~>