Manually modify KDE Plasma keyboard layout. (Maybe even somehow contribute the change)

Hello, I use a very obscure combination of keyboard layouts to write special characters in Czech. One of these layouts (Czech UCW) is missing two (that I know of) capital special characters and I have a way to write them, but it’s annoying to do. Where are the layout files, can I modify them and can I contribute the changes so other users can use them too?

So the characters I’m missing are Ě and Š. I can write š and ě normally, and other capital special characters like ŽĎÉŘČÁŤ work too, but the two symbols mentioned before have to be written by switching CapsLock on and, then writing the letters and switching back. As you can imagine, that’s pretty annoying.

I have found all the files, that define the keyboard layout, characters and keys on the keyboard for XKB. In all of them, the two missing characters are defined correctly. Why am I unable to type them then?

Poke? Does anyone know about something, that could help me?

May require a bug report.

I assume you use the Czech keyboard???

I use the US English layout with CapsSwitch mapped to Czech UCW.
The bug is in the Czech UCW.

I have never filed a bug report, could you please point me to a guide on how to do that?

This is the place: (same username and password as here on the forums),
and this is some explanation:

Which component is this, X11 Applications? What logs/info should I include, if it’s a bug that should be present in all configurations of X11? Is this even an X11 thing?

Also, to reproduce my keyboard configuration use this command:

setxkbmap "us,cz(ucw)" -option grp:caps_switch

The characters that don’t work are Ě and Š when typed by pressing CapsLock+Shift+(S or W), but work when typed by pressing Alt+CapsLock, then CapsLock+(S or W) then Alt+CapsLock again. Other capital letters work both ways.

Here is the bug report, hope I did everything alright!