Manual network configuration during install

Clean install of 42.3 using a USB thumb drive with the ISO.

I need to configure the networking manually during the installation and I cannot see where I can access this, I’m sure in previous versions I had a key combo I could hit to set it up. As is, it doesn’t offer me this, I accept the EULA, set time zone, disk layout, enter username/passwd, then accept the install plan and that it.

I’m behind a proxy and need to set several things up before it has access to the internet.

Use the option ‘Use online repositories’ in the installer, it’ll trigger the network configuration. Or, use a NET install iso.

Thanks I’ll try that.

At the moment the install fails at 95% while displaying the “Performing Installation” page which has the details, and then I get a pop-up saying it "cannot access installation media…at httpd://download…, “Cancel, Abort, Skip, remaing time”, Ive tried "skip’, but it just sits there for around 2mins and then displays the pop-up again,I tired ‘abort’ and it’s still stuck at 95% saving configuration. This doesn’t seem very graceful and I’m stuck in a loop.

Or put your network configuration on the installation kernel cmdline:

I started over and selected 'Use online repositories" and now it’s stuck saying at 50% “downloading list of online repositories” and obviously fails saying “Unable to download list of repos”. So basically I have to sue the net installer. I’m sure I didn’t have to do this for 42.2, but could be wrong.

Several here (including me) found out that earlier there was a check box to not use automatic configuration. That is gone already for some versions.

We also found that removing the cable during the first part of the configuration forces a screen for network configuration. Add the cable and do the configuration as wanted.

Personally I find it a frustrating experience. I always forget to remove the cable until it is too late and I have to start all over again >:(.

One sure way is to unplug the ethernet before you boot the installer. When you get to the network config screen, plug it back in.

ATM, I cannot get the net installer to work, I enter the proxy info and manually configure the networking to be the same as it was with 42.2, it refreshes, I wait about 2 mins and then I blue window appears saying it cannot reach http://downloads

This PC was running 42.2 fine a few hours ago, has been for several years, but I botched upgrade from 42.2 to 42.3 maybe go down the path of a clean install…

Ok, going to try nrickert suggestion.

BTW, just installed another distro on the same hardware with the same network settings and it works, but I prefer OpenSuSE!

That is fine, And while you are waiting on the installation to complete, just try to remember the correct spelling (as it is all over this and other web sites and as the installer shows): openSUSE.:wink:

I did not know most of the previous suggestions. What I generally do is ether:
Disconnect the network and install a working system from a DVD iso, skipping the suggested on-line checks. Then after the system is up an running and I am logged in as root, I reconnect the network and configure with YaST or the “ip” commands.

During the installation – e.g. when confirming the timezone and keyboard/language – I use <ctrl-alt-F2> to access a console with passwordless root access to bash. Then use ifconfig, route etc (or the new-fangled ip equivalents) to configure and test the net connection. Then <ctrl-alt-F7> to return to the graphical installer.

Are you sure it’s not really “openS.u.S.E.”?

rotfl! You should be ashamed :shame:

I think I got SuSE from when it was owned by Novell, way back (I first started SUSE in the late 90, early 2000), so apologies for the mix up!

Ok, pulling the network cable worked, thanks for the help.:slight_smile:

Yes, it is primitive, but it works :disapointed: