MAME sound stopped working

I have mame installed so I can play some arcade classics like Pacman and Robotron and some more,

I have this package set to never update, because sooner or later my roms will stop working if I keep updating MAME.

Today started mame and there is no sound any more. Tried rebooting pc but that did not change anything. (it was working fine before)

I have no idea on how to fix this ?

Tried two games, Pacman and Robotron, both have the same issue, no sound, besides this games seem to work fine.

Something happened, which I like to call progress.

I started MAME from the command line, and guess what i found:

guus@linux-2ls4:~> mame 
Error opening translation file English 
Could not initialize SDL Audio target 'pulse' not available 
Could not initialize SDL Audio target 'pulse' not available 
Average speed: 99.98% (18 seconds) 
Could not initialize SDL Audio target 'pulse' not available

Could this be pipe wire related ?

Yes, this could be pipewire related, see thread: No headphones and attached microphone sound

Today’s update did not fix this. :frowning:

Post:

zypper se -si pulse
zypper se -si pulse 
Loading repository data... 
Reading installed packages... 

S  | Name                        | Type    | Version     | Arch   | Repository 
---+-----------------------------+---------+-------------+--------+-------------------- 
i+ | alsa-plugins-pulse          | package | 1.2.5-1.1   | x86_64 | openSUSE:Tumbleweed 
i+ | alsa-plugins-pulse          | package | 1.2.5-1.1   | x86_64 | openSUSE:Factory 
i+ | alsa-plugins-pulse          | package | 1.2.5-1.1   | x86_64 | repo-oss 
i+ | alsa-plugins-pulse-32bit    | package | 1.2.5-1.1   | x86_64 | openSUSE:Tumbleweed 
i+ | alsa-plugins-pulse-32bit    | package | 1.2.5-1.1   | x86_64 | openSUSE:Factory 
i+ | alsa-plugins-pulse-32bit    | package | 1.2.5-1.1   | x86_64 | repo-oss 
i+ | libKF5PulseAudioQt3         | package | 1.3-1.1     | x86_64 | openSUSE:Tumbleweed 
i+ | libKF5PulseAudioQt3         | package | 1.3-1.1     | x86_64 | openSUSE:Factory 
i+ | libKF5PulseAudioQt3         | package | 1.3-1.1     | x86_64 | repo-oss 
i+ | libpulse-mainloop-glib0     | package | 14.2-8.1    | x86_64 | openSUSE:Tumbleweed 
i+ | libpulse-mainloop-glib0     | package | 14.2-8.1    | x86_64 | openSUSE:Factory 
i+ | libpulse-mainloop-glib0     | package | 14.2-8.1    | x86_64 | repo-oss 
i+ | libpulse0                   | package | 14.2-8.1    | x86_64 | openSUSE:Tumbleweed 
i+ | libpulse0                   | package | 14.2-8.1    | x86_64 | openSUSE:Factory 
i+ | libpulse0                   | package | 14.2-8.1    | x86_64 | repo-oss 
i+ | libpulse0-32bit             | package | 14.2-8.1    | x86_64 | openSUSE:Tumbleweed 
i+ | libpulse0-32bit             | package | 14.2-8.1    | x86_64 | openSUSE:Factory 
i+ | libpulse0-32bit             | package | 14.2-8.1    | x86_64 | repo-oss 
i+ | mpg123-pulse                | package | 1.28.2-58.2 | x86_64 | Dave Plater 
i+ | pulseaudio                  | package | 14.2-8.1    | x86_64 | openSUSE:Tumbleweed 
i+ | pulseaudio                  | package | 14.2-8.1    | x86_64 | openSUSE:Factory 
i+ | pulseaudio                  | package | 14.2-8.1    | x86_64 | repo-oss 
i+ | pulseaudio-bash-completion  | package | 14.2-8.1    | x86_64 | openSUSE:Tumbleweed 
i+ | pulseaudio-bash-completion  | package | 14.2-8.1    | x86_64 | openSUSE:Factory 
i+ | pulseaudio-bash-completion  | package | 14.2-8.1    | x86_64 | repo-oss 
i+ | pulseaudio-lang             | package | 14.2-8.1    | noarch | openSUSE:Tumbleweed 
i+ | pulseaudio-lang             | package | 14.2-8.1    | noarch | openSUSE:Factory 
i+ | pulseaudio-lang             | package | 14.2-8.1    | noarch | repo-oss 
i+ | pulseaudio-module-bluetooth | package | 14.2-8.1    | x86_64 | openSUSE:Tumbleweed 
i+ | pulseaudio-module-bluetooth | package | 14.2-8.1    | x86_64 | openSUSE:Factory 
i+ | pulseaudio-module-bluetooth | package | 14.2-8.1    | x86_64 | repo-oss 
i+ | pulseaudio-module-gconf     | package | 14.2-8.1    | x86_64 | openSUSE:Tumbleweed 
i+ | pulseaudio-module-gconf     | package | 14.2-8.1    | x86_64 | openSUSE:Factory 
i+ | pulseaudio-module-gconf     | package | 14.2-8.1    | x86_64 | repo-oss 
i+ | pulseaudio-module-x11       | package | 14.2-8.1    | x86_64 | openSUSE:Tumbleweed 
i+ | pulseaudio-module-x11       | package | 14.2-8.1    | x86_64 | openSUSE:Factory 
i+ | pulseaudio-module-x11       | package | 14.2-8.1    | x86_64 | repo-oss 
i+ | pulseaudio-module-zeroconf  | package | 14.2-8.1    | x86_64 | openSUSE:Tumbleweed 
i+ | pulseaudio-module-zeroconf  | package | 14.2-8.1    | x86_64 | openSUSE:Factory 
i+ | pulseaudio-module-zeroconf  | package | 14.2-8.1    | x86_64 | repo-oss 
i+ | pulseaudio-utils            | package | 14.2-8.1    | x86_64 | openSUSE:Tumbleweed 
i+ | pulseaudio-utils            | package | 14.2-8.1    | x86_64 | openSUSE:Factory 
i+ | pulseaudio-utils            | package | 14.2-8.1    | x86_64 | repo-oss 
i+ | pulseaudio-utils-32bit      | package | 14.2-8.1    | x86_64 | openSUSE:Tumbleweed 
i+ | pulseaudio-utils-32bit      | package | 14.2-8.1    | x86_64 | openSUSE:Factory 
i+ | pulseaudio-utils-32bit      | package | 14.2-8.1    | x86_64 | repo-oss



Does it work as User with:

SDL_AUDIODRIVER=alsa ./mame

You must be in the directory where the mame bin is installed.

PS:
You have 3 Repos with the same URL, you can delete two of them:

i+ | alsa-plugins-pulse          | package | 1.2.5-1.1   | x86_64 | openSUSE:Tumbleweed 
i+ | alsa-plugins-pulse          | package | 1.2.5-1.1   | x86_64 | openSUSE:Factory 
i+ | alsa-plugins-pulse          | package | 1.2.5-1.1   | x86_64 | repo-oss

But has nothing to do with the problem.

Maybe also Update:
https://forums.opensuse.org/showthread.php/558461-Kdenlive-crashing-sdl2_audio-Failed-to-initialize-SDL-Audio-target-pulse-not-available-quot?p=3060140#post3060140

Thank you but I am a bit confused, on were to execute this command.

I need to find the file mame.bin ?

Does an Update not help?

zypper dup

Did one earlier today but can try again, I saw 4 updates , lib live 555 streaming.

Post:

zypper se -s libSDL_sound

openSUSE:Factory can cause lot of trouble. Try to disable this repo.

openSUSE:Factory can cause lot of trouble. Try to disable this repo.

I think its the factory/standard Repo, which links to the OSS Repo…
Same Versions in 3 Repos…

So as I said:
You can delete 2 of them.

I have removed oss and factory, only still have the tumbleweed repository.

Thank you:

Repository 'Hardware' is out-of-date. You can run 'zypper refresh' as root to update it. 
Repository 'Dave Plater' is out-of-date. You can run 'zypper refresh' as root to update it. 
Loading repository data... 
Reading installed packages... 

S  | Name                               | Type    | Version     | Arch   | Repository 
---+------------------------------------+---------+-------------+--------+-------------------- 
i+ | libSDL_sound-1_0-1                 | package | 1.0.3-94.18 | x86_64 | openSUSE:Tumbleweed 
v  | libSDL_sound-1_0-1                 | package | 1.0.3-94.18 | i586   | openSUSE:Tumbleweed 
   | libSDL_sound-1_0-1-32bit           | package | 1.0.3-94.18 | x86_64 | openSUSE:Tumbleweed 
   | libSDL_sound-1_0-1-32bit-debuginfo | package | 1.0.3-94.18 | x86_64 | repo-debug 
   | libSDL_sound-1_0-1-debuginfo       | package | 1.0.3-94.18 | x86_64 | repo-debug 
   | libSDL_sound-1_0-1-debuginfo       | package | 1.0.3-94.18 | i586   | repo-debug 
   | libSDL_sound-devel                 | package | 1.0.3-94.18 | x86_64 | openSUSE:Tumbleweed 
   | libSDL_sound-devel                 | package | 1.0.3-94.18 | i586   | openSUSE:Tumbleweed 
   | libSDL_sound-devel-32bit           | package | 1.0.3-94.18 | x86_64 | openSUSE:Tumbleweed 
   | libSDL_sound-devel-32bit-debuginfo | package | 1.0.3-94.18 | x86_64 | repo-debug 
   | libSDL_sound-devel-debuginfo       | package | 1.0.3-94.18 | x86_64 | repo-debug 
   | libSDL_sound-devel-debuginfo       | package | 1.0.3-94.18 | i586   | repo-debug



The Dave platter repository has probably to do with LMMS and carla. (music production software)

Problem fixed.

See this topic: https://forums.opensuse.org/showthread.php/558461-Kdenlive-crashing-sdl2_audio-Failed-to-initialize-SDL-Audio-target-pulse-not-available-quot?p=3060560#post3060560

I received the same error (“sdl2_audio: Failed to initialize SDL: Audio target ‘pulse’ not available”) from a different application.

So i edited the file /etc/profile.d/pulseaudio.sh and replaced the line

export SDL_AUDIODRIVER=pulse

with

export SDL_AUDIODRIVER=pulseaudio

and the problem was gone (after a reboot).

Regards

susejunky

That fix did not last long after yesterdays update, again no sound in MAME :frowning:

pulseaudio.sh now looks like this:

alias aumix='padsp aumix'
alias sox='padsp sox'
export SDL_AUDIODRIVER=pulse
alias timidity='timidity -Oe'
export QEMU_AUDIO_DRV=pa
export AUDIODRIVER=pulseaudio

Again the fix was to remove that line.

export SDL_AUDIODRIVER=pulse

This should be fixed in the latest Tumbleweed snapshot.

See also https://bugzilla.opensuse.org/show_bug.cgi?id=1189778 for more information.