Mame doesn't recognize the roms

Hi there and thx for reading and answering this post if you can.

I suppose that my question isn’t new but things must be clarified. The current mame provided with leap 15 doesn’t load ANY game archives I possess whereas they worked before with older version of mame.

Mame doesn’t seem to acknowledge the presence of needed roms within the game package (i.e. even if they are there.

Moreover, qmc2, the mame frontend, crashes when invoked, even if its setup was correct.

Thx again for reading this question.

Can you fire up the program from a terminal, and copy the output, paste it here between CODE tags, the # in the layout ribbon.

./mame64 ~/Downloads/ 
gg1_1b.3p NOT FOUND (tried in galaga galaga)
gg1_2b.3m NOT FOUND (tried in galaga galaga)
gg1_3.2m NOT FOUND (tried in galaga galaga)
gg1_4b.2l NOT FOUND (tried in galaga galaga)
gg1_5b.3f NOT FOUND (tried in galaga galaga)
gg1_7b.2c NOT FOUND (tried in galaga galaga)
gg1_9.4l NOT FOUND (tried in galaga galaga)
gg1_11.4d NOT FOUND (tried in galaga galaga)
gg1_10.4f NOT FOUND (tried in galaga galaga)
prom-5.5n NOT FOUND (tried in galaga galaga)
prom-4.2n NOT FOUND (tried in galaga galaga)
prom-3.1c NOT FOUND (tried in galaga galaga)
prom-1.1d NOT FOUND (tried in galaga galaga)
prom-2.5c NOT FOUND (tried in galaga galaga)
51xx.bin NOT FOUND (tried in galaga namco51)
54xx.bin NOT FOUND (tried in galaga namco54)
Fatal error: Required files are missing, the machine cannot be run.

and if you wish to test with the real archive, get it there:

thx for your help.

I think you need to put your roms in a proper directory. Look for mame.ini file in your home directory (as far as I can remember it should be ~/.mame/mame.ini). In the file there should be a variable called rompath. Put your zip file where the rompath points to or add the location, where you have your roms.

Thx for your tip, but it is already done… in or not in the rompath doesn’t change anything.

I tried it in Leap 42.3, it doesn’t work for me either. All my other games do work.

The problem is that mame doesn’t recognize any roms even when they are within the archive.

In Leap 42.3 I run it like this:

mame -rompath MAMEROMS

Maybe you need the “-rompath” option? I haven’t install mame on Leap 15.0 yet, so I don’t know if there has been a change in how it is run.

Tried, but doesn’t work.

Finally, I got something, but I need to painfully delve into those rom download sites, to find out what I want.

Thx anyway for answering.

I just noticed some of my games don’t work now. Some “roms” work, some don’t, and over the years I’ve found which ones work depends on the version of MAME. And some never worked for me.

I found replacement rom files for my games that didn’t work. They work on my laptop, running Leap 15.0, soon will try on my desktop PC, much bigger screen, running Leap 42.3

here’s the link if it’s of any help: