Making xrandr settings permanent

So I am using a Magnavox 26MF605W/17B TV as a monitor (built a dirt cheap server for home) and for some reason the EDID doesn’t work so it comes up with a resolution of 1024x768 which is the wrong aspect ratio as well as the wrong resolution. The TV actually tells you to set it to 1366x768 when you boot, I also poked around to find the manual from Phillips which kudos to them included the hsync and vsync frequencies.

xrandr --newmode “1368x768_60.00” 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync
xrandr --addmode VGA-0 “1368x768_60.00”
xrandr --output VGA-0 --mode “1368x768_60.00”

So I ran through some instructions to use cvt and xrandr and was able to get the resolution working, the TV looks beautiful. That is until I reboot. I get an error that it can’t set the resolution and it drops back to 1024x768. I then run my script to run the three xrandr commands and it changes dutifully back.

I did try putting the commands in /etc/gdm/Init/Default but this did not work.

So how do I make this configuration permanently a part of my openSuSE 12.1?


For openSUSE 12.1, you could add them to your after.local script, to be run as root. You might run the commands as root, to make sure they work properly before hand. For using the after.local bash script, have a look at my blog on the subject here:

systemd and using the after.local script in openSUSE 12.1 - Blogs - openSUSE Forums

I hesitate to tell you this, but my first LCD monitor was a 19" TV as well, made by Magnavox and it had problems with my video card in being able to determine the correct resolution. In the end, I just purchased a new video card and that worked well. I purchased an nVIDIA 9600 as I recall. But alas, the TV just died on me. It went dark, it was not in warranty and in the end, I had to dispose of it. It was my TV and second monitor for about a year and a half before it stopped working. My replacement was a DYNEX, sold by Best Buy and the one I ended up with was made by LG and has also survived its warranty. We will see if it makes it past the Magnavox.

Thank You,

The advice from James makes good sense.

The xrandr commands can also be added to /etc/X11/xinit/xinitrc in the section of the script near the end

# Add your own lines here...

but be aware if the xorg-X11 package is updated the edited file will be overwritten.

im facing the same problem, i have to manually run xrandr commans to get the ressolution, any ideas? im runnin os 13.1

Have you looked at putting the settings in the /etc/X11/xorg.conf file?

Without more detail about hardware and requirements it is hard to give details

On 2014-05-21 23:16 (GMT) jmbertolotti composed:

> i have to manually run xrandr commans to get
> the ressolution, any ideas? im runnin os 13.1

I prefer using xorg.conf.d/ or xorg.conf rather than xrandr. However due to and I learned to use xrandr
commands in post-12.1 releases. I put them in a(n arbitrarily named) file in
/etc/X11/xinit/xinitrd.d/setup an example of which you can find at loaded with various xrandr commands I’ve ever
used, only one of which I ever use at a time.

“The wise are known for their understanding, and pleasant
words are persuasive.” Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata ***