Makefile using Google's ratproxy

Hello, I’m trying to build google’s ratproxy tool but when I run the Makefile, I get the following errors:

./Makefile: line 22: PROGNAME: command not found
./Makefile: line 23: CFLAGS: command not found
./Makefile: line 24: LDFLAGS: command not found
./Makefile: line 26: all:: command not found

and it complains about PROGNAME a few more times…

Makefiles are not run directly but by running the command “make” in the same directory, which will read the Makefile.

So how would I run it? I did make Makefile and it said “Nothing to be done for ‘Makefile’”

That would mean that the default target is already up to date. If you wanted to build something other than the default target (the first target in the Makefile), you would say

make *target*

You’d have to read the docs that came with the package.

Ah, I see what you;ve done wrong. You don’t say make Makefile. That’s saying to make, I want you to make the Makefile using the rules in the Makefile. You just say make and make implicitly makes the default target.

So either just



make *target*

Usually the first target is called all so this is equivalent:

make all