Make winbind work

Hey fellas,

how can I make winbind work?

My aim is to be able to use the NetBios names in a network including Windows computers.

In Ubuntu it’s actually quite easy:

  • Install winbind (sudo apt-get install winbind)
  • Make an entry “wins” in the /etc/nsswitch.conf
    -> Done!

How do I do this in OpenSuse?

Cheers

I have not found loading winbind as being required to use Samba. To install the winbind service first do this:

YaST / Software / Software Management and Search on samba and find the application called: samba-winbind, then check it to be installed (I would also add in samba-doc if not installed) and allow all other required services to load. Next go to:

YaST / System / System Services (Runlevel) and select the Expert Mode bullet (at the Top), find and select the service called winbind with your mouse from the list towards the bottom, select the Set/Reset button on bottom right and pick Enable the Service, then select the Start/Stop/Refresh button on the bottom left and pick Start Now … If it starts OK, the status will be a 0.

Before you go to this trouble, why not check out by blog on using Samba SWAT and see if does what you want as you can always follow my procedure to turn on winbind later.

Samba S.W.A.T. - Samba Web Administration Tool Setup for openSUSE - Blogs - openSUSE Forums

Thank You,

Alright mate, thanks for your quick reply!

I went to:
YaST / Software / Software Management
to install samba-winbind and all its dependencies.

Then I went to:
YaST / System / System Services (Runlevel)
to activate winbind.

Apparently the service is active, but the result is the same, NetBios does still not work. To give an example, I want to ping my server in the terminal:
ping myserver

The current system response:
ping: unknown host myserver

I kept the runlevel with its default values, currently 3 and 5.

Any idea how to continue? Anything to be worth checking?

My suggestion is to visit my blog and activate Samba SWAT as indicated. samba-winbind is said to only be used with NT Domains where you are trying to use its user listing. Read my blog and give it a try:

Samba S.W.A.T. - Samba Web Administration Tool Setup for openSUSE - Blogs - openSUSE Forums

Thank You,

Hey Daniel!

That was missing part! The firewall had to allow “Samba Client”. After having enabled the traffic it went perfectly well.

Thanks a lot for your help mate and
have some greetings from the old world!

You are very welcome mawwl. You should consider doing an edit to your settings to show which old world part from which you speak. You know you don’t have to put in your address or anything. Anyway, Happy Holidays to you and your family from Austin Texas!

Thank You,