? Make "nomodeset" permanent ?

The new 12.1 installation will not complete the boot process without typing in “nomodeset” on the grub boot loader screen or using failsafe.

I would like to make “nomodeset” permanent. It solves the problems with my nvidea GeForce 6100.

After searching and reading for hours, I find only conflicting and confusing advice. Supposedly it can be done in YAST or by editing the /boot/grub/menu.lst file but I have been unable to find specific instructions. I know from hard experience that just blundering around usually compounds problems until they are so complex as to be unsolvable.

It looks like about half the problems presented here and in the hardware forum could be solved by presenting simple, explicit instructions on how to do this in a sticky file.


step 1: ImageBam - Fast, Free Image Hosting and Photo Sharing

step 2: ImageBam - Fast, Free Image Hosting and Photo Sharing

I wrote this for earlier versions

Currently I don’t have nomodest added to the kernel arguments
Just edited the KMS settings in /etc/Sysconfig-editor

Done! Thank you so much for your prompt, concise, accurate reply.

Do I lose any GNOME 3 features by using nomodeset?

I am going to like openSUSE 12.1 once I learn to use it. There is one drawback that is probably peculiar to me alone: It doesn’t look an feel as much like Windows as 11.3 did. I personally like that. We are moving ahead and defining openSUSE as a leader instead of a Microsoft tag along. But …

I assemble computers from cast off parts and give them to people who cannot afford a computer otherwise. I can’t do this and pay for microsoft licenses, hence the use of OpenSource. 11.3 was enough like Windows that it takes about 30 minutes to get a Windows literate user up and going with it. They catch on pretty quick that Firefox is the new IE, Evolution is the new Outlook, Writer is the new Word, etc. The transition is intuitive and easy. 12.1 is different enough from windows that it will take more time and patience to make the mental transition.

Is there a way to get the look and feel of 11.3 under 12.1?

Yes, I know - thread drift. Ignore or move this question if you want.


In Gnome Tweak tool
You can use a setting to make the Desktop have Icons like Gnome 2
Try it, it adds some of the feel you are after.

So openSUSE continues to march forward, not looking back. The main differences in openSUSE 12.1 are the KDE & GNOME desktop versions now included with openSUSE, the kernel 3.1 and the usage of systemd. Further, I not a big fan of trying to downgrade the new kid openSUSE 12.1 to looking like the old kid. Of course, there are other choices such as this: openSUSE:Evergreen - openSUSE, if you want to go towards an older version. Further, there are other choices like this:

S.L.R.C. - SuSE Local Repository Creator - Version 1.10 - This Example is setup for Packman - Blogs - openSUSE Forums

With SLRC, you can create a local repository, able to upgrade an older version of openSUSE, which might be past its prime from a local repository. The example is for Packman, but imagine you can add in the update or other openSUSE repositories. You can change the support for any presently supported version of openSUSE, saving it for when it might not be supported.

Further, you can install a more recent kernel with this:

S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.50 - Blogs - openSUSE Forums

It works great with openSUSE 11.3 and 11.4. Now, what if the kernel you need is not on the top? You can fetch any stable kernel released back to 2005 with this script file:

S.G.T.B. - SuSE Git Kernel Tarball Creator - Version 1.78 - Blogs - openSUSE Forums

I could go on and on, but you kind of got to find a slot here. Now it sounds like you are doing a good deed with your work and you only need to ask and we will try to help all we can.

As for the nomodeset command, there were several people that tried to get it used as the default to happen, but in the end, those that felt the native high octane video driver usage and its discovery would fall with the use of the nomodeset option who came out victorious even as not using nomodeset seems to have caused more trouble by leaving it out. You get extra points here for extra long sentences by the way.

At least we do our best here to help like caf4926’s great help provides us!

Thank You,

Again, Thank you.

Old computers are harder to come by here in small-town Texas than they were in Houston so I don’t do as much of the rebuild and give away as I once did.

My next step is to go through the manual and learn all the new features in 12.1. That may take some time. I am sure I will have other questions along the way.

This is the finest forum on the internet. Even when I have problems with other open source applications, I usually find the answer here. The moderators do an excellent job of correcting misleading posts so I usually don’t crash and burn by following the advice given here. That isn’t the case on some forums.


Thank you for those considered words

No, but you need compositing and direct rendering. Otherwise Gnome-shell switches to fallback mode (which can look pretty much like Gnome2 after some theming and tweaking). If your GeForce 6100 is on board, it might be a good idea to increase video memory in BIOS.

In general, you’ll have better performance with the nvidia proprietary driver - although, according to certain posts, it’s not always the case with the GeForce family. I already set up a couple systems with GeForce 6150 to use Gnome-shell on Fedora, ArchLinux and Ubuntu (Unity & Gnome-shell). I don’t think the 6100 is a lot different. Those graphics card absolutely need nomodeset to install (any) Linux and run the nouveau driver. As soon as you install the nvidia driver, nomodeset is not required anymore - if it’s permanently disabled, it’s fine too.

Now that I have a bootable installation of openSUSE 12.1 with Gnome3 desktop, I need some pointers to manuals that cover this combination. Most of what I have found relate to 11.4 (or earlier) and Gnome2.

My most immediate problem is that Gnome3 seems to center around the Activities in the upper left corner. The problem? It isn’t there. All that is in the upper left corner is Applications and Places. Where did it go and how do I get it back?

I am more than willing to read documentation if someone will guide me to it. Then I won’t be such a pest here and might even be able to help someone else someday.

Yes - more thread drift.


Here is a good read on openSUSE 12.1 Product highlights, including GNOME 3.2: Product highlights - openSUSE

GNOME Quick Start

Gives a short introduction to the GNOME desktop and some key applications running on it.

[li] HTML versions:[/li]> [LIST]
[li] /usr/share/doc/manual/opensuse-manuals_en/manual/art.gnomequick.html (package: opensuse-manuals_en) [/li]> [li] Novell Doc: Quick Start Manuals - GNOME Quick Start [/li]> [/ul]

[li] PDF versions:[/li]> [ul]
[li] /usr/share/doc/manual/opensuse-gnomequick_en-pdf/opensuse-gnomequick_en.pdf (package: opensuse-gnomequick_en-pdf) [/li]> [li] http://www.novell.com/documentation/opensuse113/pdfdoc/art_gnomequick_113/art_gnomequick_113.pdf [/li]> [/ul]

[li] ePUB version:[/li]> [ul]
[li] http://community.opensuse.org/ebooks/ebooks113/opensuse_11.3-gnomequick.epub [/li]> [/ul]


See if this is helpful to you.

Thank You,

With the exception of Product Highlights, all of the resources you mention (including the ones installed on my computer with 12.1 & Gnome3) are about 11.3-4. They are nothing like what I have with the new 12.1 installation.

The gnome.org libraries do document the new interface. But everything starts with the Activities dash, which I do not have. They say to move the mouse to the upper left or hit the windows key and it will appear. It doesn’t. The Activities dash seems to be the starting point for everything in Gnome3 (like the Computer button at lower left in previous versions) but it just isn’t there.

Surely I am missing something so simple it will embarrass me.


On the wonder of block copies and posting in messages here. Well lets see if this helps:

GNOME 3.2 Release Notes

Eye of GNOME Reference Manual

Thank You,

You’re not in gnome-shell but in fallback mode.
Check the output of:

checkproc gmome-shell && echo gnome3

If it doesn’t say “gnome3”, you’re not in gnome-shell.

I took a nap and woke up with the startling realization that Gnome3 just won’t run normally on my hardware. Duh?

Trying to make it do so is just an exercise in frustration. I am not going to get into the Microsoft/Intel treadmill of buying new hardware every time I upgrade software either. So I wiped the whole thing out with a new openSUSE 12.1 installation, choosing the KDE desktop. So far, so good. At least I am learning something new instead of trying to fix problems.

If I might be so bold as to offer advice to newcomers having problems with Gnome3, it would be to forget it and use KDE instead.

Thank everyone here for their accurate and helpful advice. This is the finest of forums.


Gnome3 requires a high powered video driver. in in most cases a proprietary for NVIDIA or AMD chipsets. What video hardware do you have? Note also KDE is much better with a good driver.

Nvidea GeForce 6100/NForce 430 built into a Gigabyte M61PME-S2P main board and the drivers for it that install with openSUSE 12.1.


It should work. You have the GeForce 6100. I have two machines with a GeForce 6150, one of them beeing a dual monitor that also works with Gnome3 (after I increased the video memory in the BIOS). You have to install the nvidia proprietary driver. Then Gnome3 will probably* work for you. Open a terminal and type:

su -l
zypper ar ftp://download.nvidia.com/opensuse/12.1/ nvidia
zypper refresh nvidia
zypper in x11-video-nvidiaG02

Then reboot and see if you are in Gnome3.

  • I said “probably” because the 6100 is not the 6150 chipset, but there are good chances that it will work.

Need to install the video drivers from NViDIA for best results see


for details

That is why Gnome went into fallback not enough video hoarse power

If Gnome3 hangs - after you performed the steps described in my previous post - increase the video memory in BIOS setup.