make, ndiswrapper and therefore wlan wont install

hi there,
since if read all the forums threads, faqs an tutorials i could find, i hope to find some help here.
i just installed openSuse 11.2, KDE 4.3.1 a fews days ago to see what’s it all about. i don’t have any experience in writing code or anything besides the few little commands i’ve learnd through my research. the system is running on an old laptop (amd64 3000+) with enough RAM and HD.
now i since my wlan-card is detected but won’t work due to missing driver i tried this ndiswrapper-method. i used the ndis-version that was included in the openSuse-dvd with no success, then i de-installed this version to try manually. i downloaded version 1.55 from the ndiswrapper-website, logged into the console as superadmin and followed the install-intructions and for intances this tutorial. now i’m even stuck with the “make”-command as the console tells me “If ‘make’ is not a typo…”…
in earlier attempts while trying to install the wlan-driver through the dvd-given ndiswrapper version i often got the error “makefile:23: kernel tree not found…”
as the welcome-note for this forum demands here’s some output from the console
linux-g6rk:/home/mat/ndis # lspci -nn

02:09.0 Ethernet controller [0200]: Linksys, A Division of Cisco Systems [AirConn] INPROCOMM IPN 2220 Wireless LAN Adapter (rev 01) [17fe:2220]


[0.331220] aer 0000:00:02.0:pcie02: AER service couldn’t init device: no _OSC support
(i guess that’s the line telling me that my wlan-card has no firmware as i found nothing else for that matter)

so i would be very glad, if anyone could help with the command errors and the wlan issue. i know there many threads about this topic but i’ve spend the last two days looking for answers and the stuff i found either didn’t work or was explained so weird that i could make anything out of it.


Even if I’m only a

puzzled penguin
I was searching the same things as you with partial success (at least, I manage to get the WiFi adaptor to be recognized).

So, for the ndiswrapper don’t lose time with old tutorials. The last one is here: Ndiswrapper - openSUSE

You must install the ndiswrapper the latest version from the repository: you go in YaST and add a new program from the official OpenSUSE 11.2 repository. I think you must get the core and the desktop version.
“Make” is for compiling some software. You don’t need it for now, OpenSUSE will compile for you.

You will need “iw” package, too. You’ll install it with YaST and from the OpenSUSE 11.2 repository, too.

After that, you can follow the official tutorial.

Have fun!

hi robertgf,
thanks for the advice and the link. i didn’t discover this one yet. through my former attempts i actually tried the ndsiwrapper-version delivered with the openSuse-dvd already maybe i did something wrong there. i’ll try again and let you know if it worked. :slight_smile:
it’s just weird that the openSuse-website didn’t say anything about becoming half a programmer… guess i’ll need to find a website explaining how the OS actually works and how the user can (or has to) manipulate it. but i’ll do my best recovering from XP :slight_smile:
thanks a lot!!