make/modprobe etc: command not found

Just noticed after I created the topic that I’m probably in the wrong forum - sorry.

Hey guys, as you can see from the thread title I’m struggling with basic problems.
I just installed OpenSUSE 11.0 via Live-CD and almost everything went fine except my wireless card.

With lspci I found out I have an

3:00.0 Ethernet controller: Atheros Communications Inc. AR5212 802.11abg NIC (rev 01)
type of wireless card. So I went through the Atheros madwifi - openSUSE procedure using the YaST method. The installation went well without any problems.

After that I tried the

modprobe ath_pci
I get the error
FATAL: Module ath_pci not found.

I also tried then by getting the .tar.gz myself, extracting it into my folder and compiling the driver myself with the make. Unfortunately that prompted me an error aswell:

bash: make: command not found

Any can help me what basic mistake I’m doing here?

Thank you.

have you added any repositories ? as the livecd is limited when it comes to software,if you have a wired connection,i recommend you add the madwifi repo & install the drivers that way,then go wireless. I always recommend you use the dvd version when it comes to installing.


I haven’t done much more than the above mentioned. So I guess I haven’t added Repositories :confused:
Guess I will buy a DVD then and download the DVD version. Or is there a way to get all the stuff that is on the DVD in kind of 1 package?

add this to your repo’s, i do this all the time in case i forget/lose/damage my dvd. it’s all the packages that come on the dvd


Thanks already for that tip Andy.

I just had a little more time to try before I had to go to work.

So I use YaST to install repositories. So I tried to download the gcc-++ compiler. I marked the file and it automatically marked few more to install (dependancies I assume). After all I need was marked I pressed accept and the download and installation started and when it was done I was asked if I wanted to add/remove more programs. I pressed no and wanted to see if he knew the g++ command now.

I tried to compile my via g++ -o hello and the message I got: command not found.

I checked the repo again and… surprise gcc-++ wasnt marked as installed.

Do you happen to know why?

OK, I installed from the DVD now and all the commands that weren’t available are now ready.

Wireless still not working though.

Kernel is <pae>

I added madwifi and madwifi-kmp-pae in the yast software management.

When I do modprobe ath_pci it just prompts a new command line again. No error but nothing happens either.

once you have done the modprobe, it shouldn’t return anything unless there is a problem. you can now proceed to YaST & do the rest there


YaST > Network Devices > Network Settings tells me in the title of the WLAN Card:

AR5212 802.11abg NIC Not configured

and in the details below:

AR5212 802.11abg NIC (Not connected)
BusID : 0000:03:00.0

Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.

you didn’t install the firmware,


Sorry for being stupid but I’m completely new to this whole Linux thing. Could you give me a hint where to get the firmware and how to install it?

thought they would have come with the rpm. maybe try the rpm’s from here Index of /repositories/home:/schmolle1980/openSUSE_11.0/i586


So if I installed the .rpm from that page it should also intialize the firmware? If so - it didnt work.

Man, I really feel helpless :slight_smile:
When I trieb Ubuntu the wireless worked from the box but the sound wouldnt want to work. And now the sound runs perfectly but no chance with the wireless. I’m cursed!

have a read of this thread,especially harryc’s, Madwifi-kmp issues With 11.0 - openSUSE Forums see if that helps


It’s working now!! :slight_smile: thanks for your help and patience andy.