Make Graphics/Drawing Tablet Update Cursor Location Instantly Instead of Moving?

Basically, if I tap the top-left corner of my tablet with the pen, and then top the bottom-right, the cursor will quickly move itself from the top-left to bottom-right. Back on Windows, it would instead instantly update the new cursor location (so the cursor would teleport from top-left to bottom-right).

I’ve gotten used to the teleporting cursor for a particular game I play (osu!), and just can’t seem to get used to how it acts on Linux (it’s as if there’s a slight delay). Is there any way I could change the cursor movement behavior to match that of Windows?

All help requests must include openSUSE version and Desktop used and we can not help you with out more information.

Thank You,

Are you saying that in Linux the cursor doesn’t teleport to the second location?

I f you slide the pen from the right to the left, pick up the pen, put it back down on the right and slide to the left again the cursor will continue moving to the left, basically it is acting the same as a mouse?

I have that with my Adesso tablet and pretty much there has not been any option to improve that (though I haven’t tried lately). If it is a Wacom tablet look for a wacom package to install.

Either way, more information is needed.

openSUSE 13.1 with KDE; but to be fair, I’m certain this happens on 12.3 as well, and Ubuntu (seems to be non-distro specific default behavior).

It operates in absolute mode, but I’ll try to explain it a bit better with some videos.

Here’s the expected behavior on Windows and my VisTablet PenPad:

The entire cursor (the pink circle) itself teleports to the new location. On Linux however, the cursor will quickly move from its previous location to the next.

However, there is something I just noticed. The tablet I primarily use (which shows the problem) is a VisTablet PenPad (shows up in Linux as a Wacom PL700). My friend’s Wacom Bamboo tablet however actually works as I expect it to (teleports the cursor instead of moving it). Here’s a video to show this: Tablet Cursor Movement Linux - YouTube

When the cursor moves (no pen lifting), it leaves a trail on osu!. When the cursor just teleports (pen lift, then down at a new location), it does not leave a trail. When I tap the left corner, and then right of my tablet, you can see on the VisTablet how it leaves a trail over the osu! window (which shouldn’t happen).

On Windows, the VisTablet PenPad teleports the cursor as-expected, both with the basic tablet driver included with Windows, and VisTablet’s driver. I’m confused as to why the tablet specifically reacts differently in Linux (I originally figured it to occur with all tablets under Linux, but that’s not the case).

Bump. I would really like to see this fixed.

( I noticed earlier however that the VisTablet tablet works fine under SteamOS, which is pretty unexpected. I don’t know if it’s something SteamOS-specific, or maybe it’s Debian (i’ll check from a LiveCD at some point), but whatever the case, it seems this tablet can be made to work.

Bump. There has to be a way to get this tablet working properly…

Guess no one here knows and definitely can’t fix it since we are all users here too. maybe you need to post problem to bugzilla

I haven’t tested this on openSUSE yet, but I managed to fix it under Ubuntu by removing xserver-xorg-input-wacom (and it’s dependency xserver-xorg-input-all).

Over the week I tried my Adesso Tablet in openSUSE 13.1 and am very surprised to find it working!