Make gnome-mplayer recognize commands like "{\a6}" inside srt files on openSUSE 11.3 /GNOME 2.30.2

I use gnome-mplayer 1.0.0 and Totem Movie Player 2.30.2 to view videos
Both read subtitles well from srt files.
But both are not able to read {\a6} command in the srt files.

NOTE:-
{\a6} command serves the purpose of putting the subtitles on top of the screen, making it possible for subbers to display lyrics/additional footnotes on top, while at the same time, having the dialogues to show in their usual position.

Is there are way to force either of them to read the special commands properly?

You do not show what you do (and my imagination isn’t enough). And I do not know where you enter this {\a6} “command”. But when it is part of a bash command, I hope you are aware of the special effects of the \ character there.

i play videos like “abc.avi” with subtitle files “abc.srt”

Sample srt:-


1

00:00:00,000 --> 00:00:01,620

{\a6}This is a sample sub that appears at the top of of the video due to the command in front


2

00:00:00,000 --> 00:00:01,620

Brought to you by WITH 

Players are supposed to detect {\a6} and display subtitles at the top instead of the bottom of video.In the above subs the first one should appear at the top and the next one in the bottom of the screen.But it is not happening.Hence i want to know if we can force the player to recognize the command

Well, I see. It is not in the shell, but inside the file as part of hye metadata.
Sorry, I cann not comment on that because of lack of knowledge. Hope others come to your rescue asap.

This would depend on the player. If there’s not a setting in it’s configuration (like enabling SSA subs - I know you’re using srt but some players use the ssa engine to render srt subs), you may try another player. I do remember seeing this positioning either in smplayer or kaffeine (or possibly both), but kaffeine is a kde app that will bring a lot of kde libraries with it, and smplayer requires qt and mplayer. But it’s worth a try, if you haven’t already. By the way, I’m very happy with smplayer.

@ hcvv-Thanks for replying earlier and sorry for not explaining things clearly
@ brunomcl-Thanks,have tried out SM player,tried turning ON and OFF the “SSA” feature under “Subtitles menu”.No improvement seen.I do see subs but i don’t see the command working in both gnome-mplayer and smplayer :frowning:

http://i116.photobucket.com/albums/o35/vazhavandan/openSUSE/Screenshot-GNOMEMPlayer.png
http://i116.photobucket.com/albums/o35/vazhavandan/openSUSE/Screenshot-SMPlayer.png

Hi,

Here both smplayer and kaffeine put the sub on top, but kaffeine ignores the bottom sub. See pics:

http://thumbnails16.imagebam.com/11473/e0dcff114728460.jpg](http://www.imagebam.com/image/e0dcff114728460) http://thumbnails36.imagebam.com/11473/c63250114728461.jpg](http://www.imagebam.com/image/c63250114728461)

Note the extraneous “” at the start, tha’s ASCII code 5C hex. No idea why it’s there, if you know please tel.

Smplayer version 0.6.9 (SVN r3447) using Qt 4.6.3 from packman x86_64 11.1 repo.
Mplayer version 1.0rc4 also from packman 11.1 x86_64 repo.

Atleast you are better off. smplayer in KDE renders commands properly :slight_smile:

On 2011-01-11 02:36, brunomcl wrote:

> kaffeine (or possibly both), but kaffeine is a kde app that will bring a
> lot of kde libraries with it,

Try xine-ui instead, it is the same engine.

This is probably a question to ask directly of the mplayer / xine people. I
don’t have a sample with that type of subtitles to try, but a year ago with
xine the codes were displayed instead of interpreted.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Looking at MPlayer - The Movie Player Looks like he was working on this code back in June and July. Probably ought to raise this with the author… Unless you feel good about checking the source code yourself

Greyangel