Make commmand error


I am not sure if this is the right area to ask this question, so if it is not I am sorry. First off I am very new to Linux, and thought I would start out with openSuse.

To make a long story short, I am setting up Suse on my macbook pro 5,3. I have it set as a dual boot and everything has gone fine. I am trying to get my wifi card to work, so I am following this guide:
Opensuse 11.2 M8 on Macbook Pro 5,3 - openSUSE Forums

Which has led me to my first task and link:

This is to get the driver setup on my system. However when I get to the step to use Make, I get the following error:

make: *** /lib/modules/ No such file or directory. Stop.
make: *** [all] Error 2

Now when i look in that directory listed above, I see a link to s file called build. When I hover over it with my cursor the following is displayed:

build (unknown, Link to /usr/src/linux-

So at this point I am not sure what is wrong, or what is stopping me from using the make command.

Thanks for any help or information you can supply


Have you installed the kernel headers first?

zypper install linux-kernel-headers

Yes I already checked this, ‘linux-kernel-headers’ is already installed.

I also noticed another line which is above the error, which i didnt post above:
when I run make I get the following output

**KBUILD_NOPENDANTIC=1 make -C /lib/modules/uname -r /build M=pwd
** (first line, i forgot to include in above post)
make: *** /lib/modules/ No such file or directory. Stop.
make: *** [all] Error 2

Thank you very much for the speedy reply, any other thoughts as to why make is not working?


Post the output of the following:

uname -r
ls -l /lib/modules/
ls -l /usr/src/linux

uname -r

ls -l /lib/modules/

ls: cannot access /libmodules/ No such file or directory

ls -l /usr/src/linux

lrwxrwxrwx 1 root root 16 2010-01-08 13:32 /usr/src/linux -> linux-

Those are the outputs. Can u explain what you are looking for?

I think you didn’t correctly type the 2nd command.

ls -l /lib/modules/

I think you have some version mismatch.

Instead of the 3rd command, do the following:

ls -l /usr/src

ls -l /usr/src
gave the following

linux-1tn6:/home/axiom # ls -l /usr/src
total 16
lrwxrwxrwx 1 root root 16 2010-01-08 13:32 linux -> linux-
drwxr-xr-x 24 root root 4096 2010-01-08 13:32 linux-
drwxr-xr-x 3 root root 4096 2009-10-21 23:57 linux-
drwxr-xr-x 3 root root 4096 2009-10-21 23:57 linux-obj
drwxr-xr-x 8 root root 4096 2009-11-02 18:46 packages

I just did this install like 2hrs ago? Did maybe mess something up durring the instal? Would it be easier for me to reinstall and start again?

You can see that your kernel version is
(You may have got this through an update after the install)

However, you have installed kernel source and its version is

Update your system and try so that both the versions will be matching.

zypper up

Hmm i did this and it update alot of stuff, but I still get that same error when trying to use make on that makefile. I know the command make itself works as I tried it on another file.

I noticed you are running Suse on a macbook pro as well, did you have a hard time to get the wireless running? Thats really all my goal is. If I can get the wireless running, I can be able to read material and learn more about Linux.

Do you have any suggestions? I am running macbook pro 5,3.

Yes, I did compile the broadcom-wl package for this.

(Later) I found that compiled versions are available at the repositories: (I did not test them).

zypper install broadcom-wl
zypper install broadcom-wl-kmp-desktop