„make“ command problems with installing "Automatic File Distributor (AFD)

Hello everybody,

I just installed openSuse-13.1, and have problems with installing "Automatic File Distributor (AFD) "program. i have extracted the folder and entered
./configure
when trying to enter make command i got the following message

“make: *** No targets specified and no makefile found. Stop”

when i enter ./configure command i got the following message


configure: loading site script /usr/share/site/i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
checking whether make supports nested variables... (cached) yes
checking which init (rc) directory to use... /etc/init.d
checking which sysconfig directory to use... /etc/sysconfig
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for ranlib... ranlib
checking whether C compiler accepts "-fPIC"... yes
checking whether C compiler accepts "-msse4.2"... yes
checking whether the compiler has the __get_cpuid intrinsic... yes
checking whether the compiler has the CRC32 intrinsic... yes
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... 64
checking for sin in -lm... yes
checking for libraries containing socket functions... -lc
checking for X... libraries , headers 
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking whether Motif support is requested... yes
checking whether libXp is available... yes
checking for Motif... libraries /usr/lib, headers (none)
Unable to find Motif.

when i enter ./configure --help command i got the following message


`configure' configures afd 1.4.7-2 to adapt to many kinds of systems.

Usage: ./configure [OPTION]... [VAR=VALUE]...

To assign environment variables (e.g., CC, CFLAGS...), specify them as
VAR=VALUE.  See below for descriptions of some of the useful variables.

Defaults for the options are specified in brackets.

Configuration:
  -h, --help              display this help and exit
      --help=short        display options specific to this package
      --help=recursive    display the short help of all the included packages
  -V, --version           display version information and exit
  -q, --quiet, --silent   do not print `checking ...' messages
      --cache-file=FILE   cache test results in FILE [disabled]
  -C, --config-cache      alias for `--cache-file=config.cache'
  -n, --no-create         do not create output files
      --srcdir=DIR        find the sources in DIR [configure dir or `..']

Installation directories:
  --prefix=PREFIX         install architecture-independent files in PREFIX
                          [/usr/local]
  --exec-prefix=EPREFIX   install architecture-dependent files in EPREFIX
                          [PREFIX]

By default, `make install' will install all the files in
`/usr/local/bin', `/usr/local/lib' etc.  You can specify
an installation prefix other than `/usr/local' using `--prefix',
for instance `--prefix=$HOME'.

For better control, use the options below.

Fine tuning of the installation directories:
  --bindir=DIR            user executables [EPREFIX/bin]
  --sbindir=DIR           system admin executables [EPREFIX/sbin]
  --libexecdir=DIR        program executables [EPREFIX/libexec]
  --sysconfdir=DIR        read-only single-machine data [PREFIX/etc]
  --sharedstatedir=DIR    modifiable architecture-independent data [PREFIX/com]
  --localstatedir=DIR     modifiable single-machine data [PREFIX/var]
  --libdir=DIR            object code libraries [EPREFIX/lib]
  --includedir=DIR        C header files [PREFIX/include]
  --oldincludedir=DIR     C header files for non-gcc [/usr/include]
  --datarootdir=DIR       read-only arch.-independent data root [PREFIX/share]
  --datadir=DIR           read-only architecture-independent data [DATAROOTDIR]
  --infodir=DIR           info documentation [DATAROOTDIR/info]
  --localedir=DIR         locale-dependent data [DATAROOTDIR/locale]
  --mandir=DIR            man documentation [DATAROOTDIR/man]
  --docdir=DIR            documentation root [DATAROOTDIR/doc/afd]
  --htmldir=DIR           html documentation [DOCDIR]
  --dvidir=DIR            dvi documentation [DOCDIR]
  --pdfdir=DIR            pdf documentation [DOCDIR]
  --psdir=DIR             ps documentation [DOCDIR]

Program names:
  --program-prefix=PREFIX            prepend PREFIX to installed program names
  --program-suffix=SUFFIX            append SUFFIX to installed program names
  --program-transform-name=PROGRAM   run sed PROGRAM on installed program names

X features:
  --x-includes=DIR    X include files are in DIR
  --x-libraries=DIR   X library files are in DIR

System types:
  --build=BUILD     configure for building on BUILD [guessed]
  --host=HOST       cross-compile to build programs to run on HOST [BUILD]

Optional Features:
  --disable-option-checking  ignore unrecognized --enable/--with options
  --disable-FEATURE       do not include FEATURE (same as --enable-FEATURE=no)
  --enable-FEATURE=ARG]  include FEATURE [ARG=yes]
  --enable-silent-rules   less verbose build output (undo: "make V=1")
  --disable-silent-rules  verbose build output (undo: "make V=0")
  --enable-dependency-tracking
                          do not reject slow dependency extractors
  --disable-dependency-tracking
                          speeds up one-time build
  --disable-input_log             disable input_log support
  --disable-distribution_log      disable distribution_log support
  --disable-output_log            disable output_log support
  --disable-delete_log            disable delete_log support
  --disable-production_log        disable production_log support
  --enable-maintainer_log         enable maintainer_log support
  --disable-alda_cache_positioning disable ALDA cache positioning support
  --disable-ncurses_ui            disable nCurses support
  --disable-sse42                 disable SSE4.2 optimizations
  --disable-inotify               disable inotify support
  --disable-new_motif_name        when motif is required sets package name to openmotif
  --disable-error_queue           disable error_queue support
  --disable-fifo_rw_support       disable opening fifo for RW
  --disable-wmo_support           disable WMO socket support
  --disable-loc_support           disable support for copying files locally
  --disable-fd_exec_support       disable support for transmitting files via external program
  --disable-ftp_support           disable FTP support
  --disable-scp_support           disable SCP support
  --disable-smtp_support          disable SMTP support
  --disable-http_support          disable HTTP support
  --disable-sftp_support          disable SFTP support
  --enable-ip_database            enable internal IP database
  --enable-onetime_support        enable support for onetime jobs
  --disable-dupcheck_support      disable duplicate check support
  --disable-trans_exec            disable trans_exec support
  --disable-largefile             disable large file support
  --disable-verify_fsa            disable verify_fsa support
  --disable-ignore_duplicate_jobs disable ignoring duplicate job entries
  --enable-with_ctrl_accelerator  use ctrl key as accelerator
  --enable-with_afdbench_settings enables settings for running afdbench
  --disable-auto_create_config    disable automatic creation of configuration
  --disable-afd_ctrl_proc_check   disable afd_ctrl dialog checking for main AFD process
  --enable-report_empty_dir_scan  enable reporting empty dir scans
  --enable-expand_path_in_message enable expanding path in message
  --enable-statistics_in_fifodir  statistics are stored in fifodir
  --enable-setuid_progs           enable setuid flag when installing
  --enable-server_support         enable server support
  --enable-with_unlink_delay      enable delay and retry when unlink fails
  --enable-multi_dir_scans        enable multiple directory scans
  --enable-ftp_reuse_data_port    enable reusing FTP data port
  --enable-ms_error_workaround    enable workaround for MS FTP bug
  --enable-group_can_write        allow group write access
  --enable-lockdebug              enable debug messages of locking
  --enable-show_exec_times        enable show exec times when rereading DIR_CONFIG
  --enable-sendfile_support       enable sendfile support
  --enable-splice_support       enable splice support
  --enable-readyfile              enable readyfile support
  --enable-map_support            enable MAP support
  --enable-passwd_in_msg          enable password in message
  --enable-eumetsat               enable eumetsat header support
  --enable-ssl                    enable TLS/SSL support
  --enable-editres                enable editres support
  --enable-efence                 enable debugging with Electric Fence
  --enable-compile_afd_mon_only   enable compiling of afd_mon only
  --enable-afd_mon                enable afd_mon support
  --enable-compiler-debug         turn on debugging
  --enable-compiler-warn          turn on compiler warnings
  --enable-compiler-optimizations Enable optimization of the binaries
  --enable-compiler-security      Enable compiler security options
  --enable-compiler-profiling     Enable compiler profiling support
  --enable-use_fortify            Enable glibc/gcc fortify option
  --enable-compile-64-bit         Enable compiling 64-bit binaries
  --enable-distro-rpm             Enable distro-style RPMs default=no
  --disable-largefile     omit support for large files
  --disable-nls           do not use Native Language Support
  --disable-rpath         do not hardcode runtime library paths

Optional Packages:
  --with-PACKAGE=ARG]    use PACKAGE [ARG=yes]
  --without-PACKAGE       do not use PACKAGE (same as --with-PACKAGE=no)
  --with-map-libraries=DIR        location where MAP libraries are
  --with-ssl-includes=DIR         location where TLS/SSL includes are
  --with-ssl-libraries=DIR        location where TLS/SSL libraries are
  --with-gui=GUI          Where GUI is either motif (default), gtk or none
  --with-xor-key=KEY      Where KEY can be any ascii string
  --with-max-no-of-parallel-jobs=N
                          max number of parallel transfers per host
                          (default=5)
  --with-default-no-of-parallel-jobs=N
                          default number of parallel transfers per host
                          (default=2)
  --with-default-archive-unit=N
                          default archive unit in seconds (default=86400)
  --with-max-hostname-length=N
                          maximum host alias name length (default=8)
  --with-max-dir-alias-length=N
                          maximum directory alias name length (default=10)
  --with-max-afdname-length=N
                          maximum AFD alias name length (default=12)
  --with-initdir=DIR      directroy for init (rc) scripts ${INITDIR}
  --with-sysconfigdir=DIR directory for afd users initialized by init script ${SYSCONFIGDIR}
  --with-rpm-binary-owner=BINARY_OWNER
                                  BINARY_OWNER who owns the RPM binaries. default=root
  --with-rpm-binary-group=BINARY_GROUP
                                  BINARY_GROUP who owns the RPM binaries. default=BINARY_OWNER
  --with-gcc-arch=<arch>  use architecture <arch> for gcc -march/-mtune,
                          instead of guessing
  --with-x                use the X Window System
  --with-motif-includes=DIR    Motif include files are in DIR
  --with-motif-libraries=DIR   Motif libraries are in DIR
  --without-xpm         do not use Xpm
  --with-xpm-includes=DIR    Xpm include files are in DIR
  --with-xpm-libraries=DIR   Xpm libraries are in DIR
  --with-gnu-ld           assume the C compiler uses GNU ld default=no
  --with-libiconv-prefix=DIR]  search for libiconv in DIR/include and DIR/lib
  --without-libiconv-prefix     don't search for libiconv in includedir and libdir
  --with-libintl-prefix=DIR]  search for libintl in DIR/include and DIR/lib
  --without-libintl-prefix     don't search for libintl in includedir and libdir

Some influential environment variables:
  CC          C compiler command
  CFLAGS      C compiler flags
  LDFLAGS     linker flags, e.g. -L<lib dir> if you have libraries in a
              nonstandard directory <lib dir>
  LIBS        libraries to pass to the linker, e.g. -l<library>
  CPPFLAGS    (Objective) C/C++ preprocessor flags, e.g. -I<include dir> if
              you have headers in a nonstandard directory <include dir>
  CPP         C preprocessor
  XMKMF       Path to xmkmf, Makefile generator for X Window System
  PKG_CONFIG  path to pkg-config utility
  PKG_CONFIG_PATH
              directories to add to pkg-config's search path
  PKG_CONFIG_LIBDIR
              path overriding pkg-config's built-in search path
  AFD_GTK_CFLAGS
              C compiler flags for AFD_GTK, overriding pkg-config
  AFD_GTK_LIBS
              linker flags for AFD_GTK, overriding pkg-config

Use these variables to override the choices made by `configure' or to help
it to find libraries and programs with nonstandard names/locations.

could you please tell me what is wrong?

Regards,

Georgia

When I read this, I would say it needs Motif things and can not find them.

i have done this already at YaST2 in Software Manager. All motif is installed but i have the problem.

You need the development libraries. The run time libs don’t have the header files needed to link.

where can i find the development libraries?

Don’t know maybe in the development repo?? Essentially you need the header files for motif. The runtime library packages don’t include stuff needed to link the libraries.

I am on 13.1, but I guess it is the same on 13.2.

When I use YaST > Software > Software Management and I serach for motif, i alse see devel packages. Don’t you have that?

And because youi said you installed everything motif, my idea was that you then also have the devel packages.

Hi
Just the motif-devel package…

Here you go…

Using the following configuration;


  129s]                           Configuration
  129s] 
  129s]     Source code location             : .
  129s]     Install path bin + sbin          : /usr/bin /usr/sbin
  129s]     Install path doc                 : /usr/share/doc/afd
  129s]     Install path man                 : /usr/share/man
  129s]     AFD Version                      : 1.4.7-2
  129s]     Compiler                         : gcc
  129s]     Compiler flags                   : -fmessage-length=0 -grecord-gcc-switches -fstack-protector -O2 -Wall -D_FORTIFY_SOURCE=2 -funwind-tables -fasynchronous-unwind-tables -DLINUX -D_FORTIFY_SOURCE=2 -fPIC -msse4.2
  129s]     GUI                              : Motif
  129s]     With TLS/SSL support             : yes
  129s]     Logs                             : INPUT DISTRIBUTION OUTPUT DELETE PRODUCTION 
  129s]     Error queue support              : yes
  129s]     With AFD monitor                 : yes
  129s]     With duplicate check support     : yes
  129s]     Protocols supported              : FTP SFTP SMTP HTTP WMO LOC EXEC SCP 
  129s]     With server support              : no
  129s]     With largefile support           : yes
  129s]     With inotify support             : yes
  129s]     With internal IP database        : no
  129s]     Max number of parallel transfers : 5
  129s]     Def number of parallel transfers : 2
  129s]     Maximum host alias name length   : 8
  129s]     Maximum AFD alias name length    : 12
  129s]     Max directory alias name length  : 10
  129s]     Some binaries with setuid flag   : no
  129s]     Automatically create configs     : yes
  129s]     Enable Distro-style RPMs         : no 

I haven’t added an afd user automatically as using YaST /etc/sysconfig editor you can add users as required.

The motif GUI’s look very old… tried using the GTK option but looks like it needs some code tweaks.

Test it out and see how it goes for you. The latest version also includes a systemd service file linking to init scripts.

Hello,

thanks to everyone my problem is solved. I have connected my pc to the internet and
then started the installation new. Now is working.

Best Regards,

Georgia