Major Installation Issues

Hi. This is my first install of openSUSE and I’m having major issues. My computer is an Acer Aspire 5050 (it’s a couple years old now) and I have had no major problems with other distributions in the past.

Installing openSUSE 11.2, everything seems to be going well throughout the installer until after the first reboot and things start getting ugly. The installer comes back up, but this time it is in text only mode because it says my display drivers aren’t found. The installer continues and after some time, the screen goes black and I’m stuck there. At this point, I am unable to boot (it freezes while trying to startup HAL service).

I tried to use the recovery mode of the DVD, and it gets more confusing to me. I get errors saying Ext4 needs to be rebuilt, package database needs to be rebuilt, initrd modules missing, calling mkinitrd failed, and boot loader errors.

I’m at a loss here. Any advice? I’ve checked the media, reinstalled, tried using Ext3. I’m going to try to download the liveCD tonight and see if that helps. Sorry in advance if I forgot something obvious that you need in order to help. Thanks in advance,


Hi and welcome to forums.

Looks like graphic card issue, which graphic card your pc have?
When you start pc, did you see the grub menu?

Did you do this first, before actual install?

My graphics card is an ATI Radeon Xpress 1100. It worked fine earlier today using Mandriva 2009.1, so I assume that physically, my graphics card should be fine.

Yep, I checked the installation media before installing. It had no problems.

No specific solutions, other than to recommend you read post#4 in this thread to get an idea as to what graphic drivers are available for ATI graphic hardware for openSUSE: How Do I Install New (to the computer) video card - openSUSE Forums

ATI Radeon Xpress 1100. It worked fine earlier today using Mandriva 2009.1
Was that just in the Live session or a completed install.?
That’s an older version of Mandriva too isn’t it, than it’s current release?
I’m not sure what the situation is with the ATI you have, but there are big issues out there ATM with ATI - their support has been seriously degraded from what I can make out.

Did you try booting with the Failsafe option?

This problem was on the full DVD. I have just tried the live CD and am having the same problem. Also, I just found another thread, that sounds like my problem. There doesn’t seem to be an easy solution yet. I guess I’ll keep tinkering and see.

OpenSuse 11.2 Black Screen - openSUSE Forums

run, as root:

sax2 -r -m 0=ati

This did the job on a couple of laptops with X1100s.