Major Bug!

I booted into OpenSuse and noticed there was an update, so I installed it. A few minutes after the update had finished (not sure it was anything to do with the update or not) I couldn’t click on things. When I would try, the cursor would change to the four directional errors and all I could do is MOVE the window. I was in TOR trying to click a bookmark but all I could so was drag the window around, same thing in Steam, in Firefox,and the K launcher. I had to boot into Windows to write this post.

I know this isn’t the proper place to report bugs, but I’m hoping someone has a quick fix.

Doesn’t tell us if you booted using a different machine, or not. So, did you try restarting openSUSE?

These forums are about openSUSE, not OpenSuse. Now that might be a minor typo, but not even telling which version of openSUSE you are reporting about makes your story a bit vague to say at the least.

It could also be that you hit a keycombo which triggered a feature.

Which can sometimes be disabled as simply as clicking the ESC key.
I dunno, I’ve seen this “sticky” behavior at times in several OS, but ESC has always worked for me.


I booted into Windows on the same machine yes. I also tried rebooting opensuse, the problem remained.

I didn’t know OpenSUSE and OpenSuse were two different things, that’s just bound to lead to confusion. I don’t which one I have in that case. I’m running 13.1.

I will try pressing ESC, to see if that works.

Did you try rebooting using Recovery mode? Selected via the Advanced alternative entry in the Grub2 menu.

I’m in Recovery Mode now, and the problem is gone. I’m going to boot back into desktop mode (that’s what normal mode is called right?) so I can see if pressing escape works.

Good work, but where in recovery mode are you? You should be describing what you did after rebooting and what you see (e.g in console, are you logged in as normal user?).

I’m logged in as a normal user yes. I see the desktop, that’s all (it has a lower resolution then normal).

Edit: I’m in normal mode now and the problem is gone. Strange.

Just to add to that. Normal mode v. desktop mode? Well, you are either doing a “normal boot” or booting in “recovery mode”. In recovery mode you can login to a desktop, if all goes well, but you may be left in a console at the login prompt if it doesn’t. :slight_smile:

Excellent news, now I see your edit, and better result. The Lower resolution because Recovery mode used the boot code “nomodeset” that results in the use of a lower level graphics driver (no hardware acceleration, no 3D support).