Main Update Repository

I’ve just installed Leap 15.6 and had a look at the repositories in yast and noticed the Main Update Repository (http://download.opensuse.org/update/leap/$releasever/oss) is disabled.

Surely it should be enabled by default? Should I enable it?

Please open a terminal, issue:

zypper lr -d

and copy/paste here between preformatted text tags ( the </> button above editing area ) the complete result including command and trailing prompt.

#  | Alias                           | Name                                  | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                     | Service
---+---------------------------------+---------------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------+---------
 1 | NVIDIA                          | NVIDIA                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.nvidia.com/opensuse/leap/15.6                          | 
 2 | NVIDIA:repo-non-free            | repo-non-free (15.6)                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.nvidia.com/opensuse/leap/15.6                          | NVIDIA
 3 | brave-browser                   | Brave Browser                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://brave-browser-rpm-release.s3.brave.com/x86_64                   | 
 4 | openSUSE:repo-non-oss           | repo-non-oss (15.6)                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://cdn.opensuse.org/distribution/leap/15.6/repo/non-oss             | openSUSE
 5 | openSUSE:repo-non-oss-debug     | repo-non-oss-debug (15.6)             | No      | ----      | ----    |   99     | N/A    | http://cdn.opensuse.org/debug/distribution/leap/15.6/repo/non-oss       | openSUSE
 6 | openSUSE:repo-openh264          | repo-openh264 (15.6)                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://codecs.opensuse.org/openh264/openSUSE_Leap                       | openSUSE
 7 | openSUSE:repo-oss               | repo-oss (15.6)                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://cdn.opensuse.org/distribution/leap/15.6/repo/oss                 | openSUSE
 8 | openSUSE:repo-oss-debug         | repo-oss-debug (15.6)                 | No      | ----      | ----    |   99     | N/A    | http://cdn.opensuse.org/debug/distribution/leap/15.6/repo/oss           | openSUSE
 9 | openSUSE:repo-oss-source        | repo-oss-source (15.6)                | No      | ----      | ----    |   99     | N/A    | http://cdn.opensuse.org/source/distribution/leap/15.6/repo/oss          | openSUSE
10 | openSUSE:update-backports       | update-backports (15.6)               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://cdn.opensuse.org/update/leap/15.6/backports                      | openSUSE
11 | openSUSE:update-backports-debug | update-backports-debug (15.6)         | No      | ----      | ----    |   99     | N/A    | http://cdn.opensuse.org/update/leap/15.6/backports_debug                | openSUSE
12 | openSUSE:update-non-oss         | update-non-oss (15.6)                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://cdn.opensuse.org/update/leap/15.6/non-oss                        | openSUSE
13 | openSUSE:update-non-oss-debug   | update-non-oss-debug (15.6)           | No      | ----      | ----    |   99     | N/A    | http://cdn.opensuse.org/debug/update/leap/15.6/non-oss                  | openSUSE
14 | openSUSE:update-oss             | update-oss (15.6)                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://cdn.opensuse.org/update/leap/15.6/oss                            | openSUSE
15 | openSUSE:update-oss-debug       | update-oss-debug (15.6)               | No      | ----      | ----    |   99     | N/A    | http://cdn.opensuse.org/debug/update/leap/15.6/oss                      | openSUSE
16 | openSUSE:update-sle             | update-sle (15.6)                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://cdn.opensuse.org/update/leap/15.6/sle                            | openSUSE
17 | openSUSE:update-sle-debug       | update-sle-debug (15.6)               | No      | ----      | ----    |   99     | N/A    | http://cdn.opensuse.org/debug/update/leap/15.6/sle                      | openSUSE
18 | repo-backports-debug-update     | Update repository with updates for -> | No      | ----      | ----    |   99     | N/A    | http://download.opensuse.org/update/leap/15.6/backports_debug/          | 
19 | repo-backports-update           | Update repository of openSUSE Backp-> | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.6/backports/                | 
20 | repo-debug                      | Debug Repository                      | No      | ----      | ----    |   99     | N/A    | http://download.opensuse.org/debug/distribution/leap/15.6/repo/oss/     | 
21 | repo-debug-non-oss              | Debug Repository (Non-OSS)            | No      | ----      | ----    |   99     | N/A    | http://download.opensuse.org/debug/distribution/leap/15.6/repo/non-oss/ | 
22 | repo-debug-update               | Update Repository (Debug)             | No      | ----      | ----    |   99     | N/A    | http://download.opensuse.org/debug/update/leap/15.6/oss/                | 
23 | repo-debug-update-non-oss       | Update Repository (Debug, Non-OSS)    | No      | ----      | ----    |   99     | N/A    | http://download.opensuse.org/debug/update/leap/15.6/non-oss/            | 
24 | repo-non-oss                    | Non-OSS Repository                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.6/repo/non-oss/       | 
25 | repo-openh264                   | Open H.264 Codec (openSUSE Leap)      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://codecs.opensuse.org/openh264/openSUSE_Leap/                      | 
26 | repo-oss                        | Main Repository                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.6/repo/oss/           | 
27 | repo-sle-debug-update           | Update repository with debuginfo fo-> | No      | ----      | ----    |   99     | N/A    | http://download.opensuse.org/debug/update/leap/15.6/sle/                | 
28 | repo-sle-update                 | Update repository with updates from-> | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.6/sle/                      | 
29 | repo-source                     | Source Repository                     | No      | ----      | ----    |   99     | N/A    | http://download.opensuse.org/source/distribution/leap/15.6/repo/oss/    | 
30 | repo-update                     | Main Update Repository                | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/update/leap/15.6/oss                       | 
31 | repo-update-non-oss             | Update Repository (Non-Oss)           | No      | ----      | ----    |   99     | N/A    | http://download.opensuse.org/update/leap/15.6/non-oss/                  | 

Since you have #14 (the cdn update repo) enabled it is OK to have #30 (the download update repo) disabled since they have the same content.
The same should be true also for #24, #26,#28, but I see them enabled on a fresh test install so seems a bug in the installer and/or the openSUSE service.
More analysis required, I think they can be disabled without trouble but if you leave them as is the only drawback is a longer refresh download, no conflict since the content should be identical to their cdn counterparts.

Edit: #1 and #2 are duplicates too, only one is needed (I think #2 is part of the standard install, maybe you added #1 yourself?)

BTW, was that a fresh install from scratch or a distribution upgrade from, for instance, a previous Leap 15.5?

Thank you for the clarification.

Yeah, I think I did add the second repo accidentally.

It was a fresh install using the offline image. I usually use the net image but it refused to work - something related to not finding repositories. All I have done so far is install brave, nvidia, protonmail/pass and vscode… I was surprised by the list of repos!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.