Main Update Repository is Invalid

When I run

zypper up

from Konsole, I get the following:

**#** zypper up 
Retrieving repository 'Packman Alternative Mirror' metadata .............................................................................................................................................................................................................[done] 
Building repository 'Packman Alternative Mirror' cache ..................................................................................................................................................................................................................[done] 
Retrieving repository 'Main Update Repository' metadata ................................................................................................................................................................................................................[error] 
Repository 'Main Update Repository' is invalid.
[repo-update|http://download.opensuse.org/update/leap/15.2/oss/] Valid metadata not found at specified URL
History:
 - Timeout exceeded when accessing 'http://download.opensuse.org/update/leap/15.2/oss/repodata/230996795ae536a4e7671a37004b846d3127910dfdfbd174d029abc6849fe104-primary.xml.gz'.
 - Can't provide ./repodata/230996795ae536a4e7671a37004b846d3127910dfdfbd174d029abc6849fe104-primary.xml.gz

Please check if the URIs defined for this repository are pointing to a valid repository. 
Warning: Skipping repository 'Main Update Repository' because of the above error. 
Some of the repositories have not been refreshed because of an error.
Loading repository data... 
Reading installed packages... 

The following 4 package updates will NOT be installed:
  MozillaFirefox-branding-openSUSE MozillaThunderbird kmozillahelper mozilla-nss-certs 
Nothing to do.

The URL mentioned in the message seems to be pointing to a valid repository because I can get to it with Firefox.

This has been going on since yesterday, so I do not think that it is an openSUSE server problem. Am I wrong? What do I need to do in order to solve this problem?

Hm, I see that file with Firefox (like you seem to do).

It looks okay from here.


# zypper lp
Retrieving repository 'packman' metadata .................................[done]
Building repository 'packman' cache ......................................[done]
Retrieving repository 'Main Update Repository' metadata ..................[done]
Building repository 'Main Update Repository' cache .......................[done]
Loading repository data...
Reading installed packages...

Repository             | Name              | Category | Severity  | Interactive | Status | Since | Summary
-----------------------+-------------------+----------+-----------+-------------+--------+-------+---------------------------------------
Main Update Repository | openSUSE-2021-386 | security | important | ---         | needed | -     | Security update for bind
Main Update Repository | openSUSE-2021-387 | security | important | ---         | needed | -     | Security update for MozillaThunderbird
Main Update Repository | openSUSE-2021-390 | security | moderate  | ---         | needed | -     | Security update for gnome-autoar

Found 3 applicable patches:
3 patches needed (3 security patches)

You are probably being redirected to a mirror that is not fully in synch.

Unless it is urgent, I would wait a day or two and then try again.

I seem to have solved the issue by switching to a different openSUSE download mirror.
I picked the one for the University of Maryland, College Park, from this list:
https://mirrors.opensuse.org/list/15.2.html

Is there a way to mark the thread as solved?

No, we read your answer (and thanks for reporting back) and know you consider it solved.