mailto links

one of the very few problems I have struck since installing 12.2 KDE 64

mailto links don’t work for me - in either chrom or firefox

I have tried with both kmail and thunderbird

in config desktop I set the default application and checking preferences in firefox can see that it respects those settings

but clicking a mailto link produces absolutely nothing - zilch.

anybody able to point me in the right direction?

Do you have a default email set in kde settings

Yes, I have tried setting both kmail and thunderbird to the default.

when I change the default setting and then check in Firefox properties I can see that it has recognised my change - yet clicking a mailto link in both firefox and chrome results in absolutely nothing (whether the mail app is already running or not).

I’ll check back later - have to go out

Just tried it out in Konqueror and that launches mailto links without problem.

Seems like there is something suppressing these links in both chrome and firefox.

Interestingly, I tried changing firefox preferences to use gmail with mailto links - which should launch gmail in a browser window - yet this also did not work.

Go to FF prefs > Applications

type: mail
in the filter
Customise as required

sadly, I have long ago visited this (as explained in my prev posts) and it has had not effect (and would not explain the same behaviour in chrome) :’(

Test a new user login…

Yes, in a new user account the mailto links work.
However, I only installed 12.2 yesterday and spent approx six hours getting the current user account set up as I like so I’d be extreeeeemely disappointed if I had to move to a new user account just to get mailto links working. :frowning:

Are you saying /home was formatted? During that install and setup…

Yes. I usually like to start with a completely clean slate on a new OS install. Extra work with backups and whatnot but usually gives me fewer headaches (usually) :slight_smile:

You could test a new .kde4
Pretty drastic too…

Do you know how to do it and easily revert back if it doesn’t solve the issue?

actually, I am most of the way through migrating to a new profile.
However, while mailto links work in Firefox - they still do not work in Chrome.



It’s not something I’m up on
I never use them anyway

Thanks anyway.
I think I’ve managed to put together a bit of a tidier profile this time round - and in reality, I don’t really use mailto links that often anyway.