Mad Catz Rat 3 Gaming mouse not working properly


My mouse broke and as an new one i bought the “MadCatz Rat 3 Gaming mouse”.
She works perfectly fine in windows, but is making troubles on opensuse.
The movements will work (but very slow) but i am not able to click certain buttons.

This are the approaches I tried already:
Result: no change at all
Result: opensuse wont start anymore, I had to undo the changes to be able to boot.

I know those approaches are for Ubuntu not Opensuse, maybe there are some details I have to do different?

I am using Opensuse 13.1 with KDE.

And by the way you can`t find any linux-drivers online for that mouse.

Glad for any help

nobody any idea?

I found another approach to solve this:

Sadly didnt do anything either :frowning:

So I just solved it :smiley:
Finally my MadCatz RAT 3 Gaming mouse is working in Opensuse 13.1

Thats what I added to the xorg.conf

Section "InputClass"
Identifier "Mouse Remap"
MatchProduct "Madcatz Mad Catz R.A.T.3 Mouse"
MatchDevicePath "/dev/input/event*"
Option "ButtonMapping" "1 2 3 4 5 6 7 8 9 0 0 0 0 0 0 0 0 0"

also check this thread for further information: