Macbook sound not working correctly

Hi :slight_smile:

i spent hours of googling and searching and i still dont have any solution :confused:

I have a Macbook from January with this soundcard:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

I Managed to install openSUSE 11 with kde 4.1 and everything works, even wifi. Just sound makes problems…

if i plug in my amp and turn the the volume there up to 100% i gat really quiet music… so it IS working, but it is WAY to quiet… i tried everything from editing x config files, turning the volume up with kmix/alsamixer and i ran alsaconfig several times… nothing did help :frowning:

There have to be a zillion different sound cards that give 82801H ICH8 family. It would really help if you could narrow it down some more.

Try working your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

In particular, for low volume, go to YAST > HARDWARE > SOUND > OTHER > VOLUME and move slider bar(s) to about 75% or so.

If you are stumped by the audio troubleshooting guide, then to help we need more info on your hardware and software. Please, with your Macbook connected to the internet, copy and paste the following diagnostic script into a konsole:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

when asked for a password, enter your root password. It will give you a URL. Please post that URL here.

Also, in addition to the above, to provide more information please copy and paste the following one line at a time into a konsole, executing each line, and paste the output here:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q | libasound2
uname -a
cat /etc/modprobe.d/sound

In particular, for low volume, go to YAST > HARDWARE > SOUND > OTHER > VOLUME and move slider bar(s) to about 75% or so.

i turned ALL volume sliders i could find up to 100% (and the are unmuted :wink: )

the script returned: tsalsa.txt - nopaste.com (beta)

summel@Prometheus:~> rpm -qa | grep alsa
alsa-1.0.16-39.1
alsa-devel-1.0.16-39.1
alsa-tools-1.0.16-47.1
alsa-utils-1.0.16-35.1
alsa-tools-gui-1.0.16-47.1
alsa-firmware-1.0.16-24.1
alsa-oss-1.0.15-48.1
alsa-plugins-1.0.16-57.1

summel@Prometheus:~> rpm -qa | grep pulse
libpulse0-0.9.10-26.3

summel@Prometheus:~> rpm -q | libasound2
bash: libasound2: command not found

(did you mean -qa and grep?)

summel@Prometheus:~> rpm -qa | grep libasound2
libasound2-1.0.16-39.1

summel@Prometheus:~> uname -a
Linux Prometheus 2.6.25.11-0.1-default #1 SMP 2008-07-13 20:48:28 +0200 i686 i686 i386 GNU/Linux

summel@Prometheus:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel
# u1Nb.ZGRm3ZltRU8:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

Thanks. I see openSUSE-11.0 with 2.6.25.11-default kernel (32-bit) and 1.0.16 of alsa, with an ALC889A hardware audio codec.

I’m bad! I meant:
rpm -q libasound2

Thanks! that works too!

OK, we may need to edit this /etc/modprobe.d/sound file.

I did a search on alsa for the ALC889, and obtained this:
Search results for ALC889 - AlsaProject
it appears support was introduced in 1.0.16 of alsa for the ALC889 (and you have 1.0.16 of alsa). But there is no mention of the ALC889A in 1.0.16 of ALSA-Configuration.txt file (nor in 1.0.17 for that matter).

A search for ALC889A yields this:
Search results for ALC889A - AlsaProject
which suggests an update to 1.0.17 of alsa might help.

So lets try that! I think you can use nominal i586 rpms in your macbook ? So assuming that is the case, please open a konsole, type “su” to get root permissions (enter root password), and then copy and paste the following in sequence (while your mac is connected to the internet):

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ multimedia
zypper install alsa alsa-devel alsa-plugins alsa-oss alsa-utils alsa-tools alsa-tools-gui alsa-firmware libasound2
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.0_Update/ multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

If your repos are not setup properly, you may need to insert your installation cd/dvd during the above. After installation is complete, please restart your mac in order to unload the old alsa kernel modules and load the new kernel modules.

Then test your sound.

My reference for the above zypper commands is here: Alsa-update - openSUSE

If that doesn’t work, we could try an edit to your /etc/modprobe.d/sound file, but I’m not too optimistic there, as the ALSA-Configuration.txt file gives no guidance for the ALC889 (but it does give guidance for the ALC882/885 for the macbook).

Thanks, that did it :slight_smile:

I had to kill a process first (because only one process can access libzyppr at a tim blah) which was a bit hard to find because i didnt had lsof oO (do you know in which package it is? i couldn’t find it :/) but then it worked :slight_smile: now i have sound :slight_smile:

Congratulations on getting sound working!

lsof is in its own package:
Webpin - search for lsof

Perhaps you could do me a favour? Could you take a look at this openSUSE wiki HCL for the Apple, and identify and update your Apple info for openSUSE-11.0?
HCL/Laptops/Apple - openSUSE

If your Apple is not one of the rows in that table, please just add a new row. If the wiki syntax is simply too foreign, no worries, perhaps you could post the info here (or PM me) on your Apple’s success with openSUSE with video, audio, ethernet, wireless, bluetooth, power-management and I can update the wiki based on your experience? Thanks!

done and thanks for the lsof :slight_smile: didnt found it earlier oO

yast is still kinda strange :smiley:

ok, i still have some issues with the sound…

  1. i can only have sound in one application, which means if i want to watch a youtube video with sound i first have to quit amarok, juk or anything else currently running and making sound, then reload the youtube page.

also if i listen to music in juk sometimes sound goes away and a little message pops up where it tells me that the audiodevice intel_blah does not work and it is switching to intel_blah. i then have to restart alsa to make it work again for at least a short time.

and everytime i restart alsa i get a really loud noise (i dont know the english word, in german it is called “rückkopplung”) which comes from the microfon and that the volume is up to 100%. i have to quickly cover the mic and then mute it. Why is this? on windows/mac os the mic is only turned on when i need it and normally i cant hear myself throuh the mic so there is nearly never a “rückkopplung”…

oh and another issue… i use pommed so the volume and the brightness keys work, but when i turn the brightness down to 0% (e.g. turn the screen off) after a few minutes/seconds it comes back on…

In the past, only the alsa API provided the capability to play multiple audio at the same time. Other intermediary sound API’s do not. But many desktops and many applications do NOT interface to the alsa API, but rather they interface to a the other intermediary API, such as gstreamer, esd, arts, … etc … In my case, I like to point my applications to alsa to provide the capability you like. So IMHO you need to check your audio players to see if they are using alsa or using gstreamer, or using esd, or using arts, … if they are using xine, then you need to check to see what xine is using.

In the case of openSUSE-11.0 pulse audio and phonon are involved, and I do not have a good handle (yet) as to the complications that those applications bring (especially wrt the practical problems that users face).

I have tried to document more on this on the openSUSE sound concepts page, but I have thus far I have failed totally and failed completely to get any sound guru’s to review that page:
Sound-concepts - openSUSE

sorry, but you have to be more specific for me to have any chance at all of providing help here. I do not have your hardware, nor do I use the same sound module, and I use KDE-3.5.9 and NOT KDE-4.1, and hence there is simply NOTHING I can do, without specifics. Even with specifics its quite likely I can not help as this could be 4.1. specific. You may need another macbook user running 4.1 to chime in.

Everyone’s hardware is different, as is everyone’s software. Why not simply go into your mixer and mute your mic when it is not in use. Then when you want to use it, go into your mixer and unmute it.

You should start a new thread on brightness. A thread reading “Macbook sound not working correctly” is unlikely to garner attention from a macbook user who has sorted this brightness issue (as the “sound not working correctly” title appears to have scared away EVERY openSUSE macbook user who may have read the title).

hmm ok… phonon is configured to use xine as far as i can see…

i installed xine-ui and i think i correctly switched it to alsa (was on auto before) but i still have the same problem… but i managed to take a screenshot of the message

http://img399.imageshack.us/img399/6563/52104522yk0.th.jpg](http://img399.imageshack.us/my.php?image=52104522yk0.jpg)

do i have to restart the xine engine somehow?

Lets not mix your problems.

Having all players use “alsa” so that you can play sound from multiple players is ONE problem. Obtaining that error message I believe is a SECOND problem (unless that happens only when you try to play audio from two different players at the same time).

Why remove xine-ui? Thats just a “user interface” (ie “ui”) to xine. ie its a separate player. What you want to do is ensure xine is pointed to alsa, and not to arts.

This just states it can not access your analog Front audio, so it is switching to your digital.

Why restart alsa for this? Did you check if you can simply go into your mixer and change it from digital back to analog audio?

xine is an application that provides an API that can bypass the alsa API and interface direct to the alsa sound drivers. ie while xine uses the ALSA kernel hardware drivers, it has its own application programming interface (API).

As opposed to trying to “restart xine” (and I do not know what you mean by that, as it is only “started” when called on a case by case basis, it does not run permanently to my knowledge) you should look at your mixer.

Yes, but i didn’t know how to configure xine from the command line so i installed xine-ui and edited the options there.

This just states it can not access your analog Front audio, so it is switching to your digital.

Why restart alsa for this? Did you check if you can simply go into your mixer and change it from digital back to analog audio?

I can’t find anything to switch… is that in kmix or in yast?

xine is an application that provides an API that can bypass the alsa API and interface direct to the alsa sound drivers. ie while xine uses the ALSA kernel hardware drivers, it has its own application programming interface (API).

As opposed to trying to “restart xine” (and I do not know what you mean by that, as it is only “started” when called on a case by case basis, it does not run permanently to my knowledge) you should look at your mixer.

i currently try installing the gstreamer backend for phonon… i never had any problems with xine before though…

New to this forum.
Please let me know how to post a new thread.
Thanks in advance.
Dave

Lets say you have a hardware question. Go to:
Hardware - openSUSE Forums

After loading that page, look on the left side of your page, 1/3 to 1/2 way down the page. You should see a big “button” called “New Thread” with a pix of a pencil and notepad in the button. Click on that. The rest is intuitively obvious.

But if it is not hardware specific, then you should look at other areas to start a new thread. Please look here:
http://forums.opensuse.org/
… you should see all sorts of topics that you can select, to start a new thread.

If you are an NNTP user, I can’t help (as I am rusty on NNTP use), but I speculate it should be as easy as starting a new message with NNTP, and in the “to address” select the correct “conference/sub-forum” as an address.

ok… gstreamer doesnt makes any sound at all oO

Well, whose gstreamer are you using? Note the gstreamer packaged by Novell/SuSE-GmbH is crippled for proprietary codecs. You may need to replace it with gstreamer packaged by Packman.

Also note that mixing Packman packaged rpms with Videolan packaged rpms is a bad idea. The videolan rpms are not always compatible with the Packman packaged rpms. I prefer sticking with Packman myself, as their repository is significantly larger than videolans.

I always recommend users stick with only the following repositories: OSS, NON-OSS, Update and Packman.

Good luck!

i installed gstreamer with gstreamer plugins-bad -ugly -base and -good from the packman repository

OK, then when testing your sound with that application (and gstreamer) what audio codec were you basing your results on? A .wav file? A .mp3 file? My apologies for being “difficult” on this, but with my having supported (or my having attempted to support) users for a couple of years now on various forums, I’m a bit (maybe far too) cynical. Many times I’ve seen a user complain sound doesn’t work, when in fact its only a specific codec in a specific application, and sometimes its a file they themselves created which doesn’t work in any player, but they promptly complain no sound works with a given audio daemon, or with a specific audio/video player or even their entire system. :rolleyes:

So again, my apologies for asking for more detail, but did you try more than one type of audio file with gstreamer? Again, I’m not a macbook user, and I need to be “hand led” in order for me to understand the details of the various problems you encounter.

Good luck.

hmm yes i tried several mp3 files and some .ogg files… i just switched back to xine and now everything works as it should :smiley:

(that is playback with crossfading and playing multiple sounds at once)

Glad to read its working.

I find doing a test with a .wav file tends to be a better test. Its quite common for apps not to have mp3 support properly in place, and its also reasonably common (it should not be, but it is) to not have ogg support properly in place. For some reason, reading .wav files appears to work in almost all audio applications without a hiccup. (That is assuming the wav file is properly put together - I had one user complain they could not play any .wav files, only to find out after over 1/2 dozen posts that the .wav file that they insisted to use to test, had been custom made by themselves, that their assessment that it was good was wrong (based on a faulty recollection), and that .wav file broke practically every .wav guideline in the book. :slight_smile: ).