MacBook Pro 8.2 (2011)

I have tryed a few times to install opensuse 12.3 on my MacBook Pro but after the install suss fails to boot. I have all but given up on his I’m a total GNU/Linux noob. Any one able to give me a clear cut how to set up and install Suse in efi mode. And then install the ati drivers. It has to be clear cut noob friendly help as I have no clue
The only things In my MacBook that is not default is the 16gb ram and a 120 gb ssd. I want to keep osx as I use lightwave but I also want to try running modo 701 under Suse. I ofc when setting up my portions need a large swap disk. I also have messiah studio 6 that only runs on windows or Linux via wine and would like that running in 64bit due to requiring more than 2gb ram. I chose Suse as I love how clean and tidy the themes are it looks like a unified os. I would like kde desktop over gnome. I don’t want to use efiind or what ever that app is boot Manger is called. I’m not too bothered if I can’t get graphics switching working as long as I get the ati card going. I have tried and failed fallowing blogs and forum posts about how to do this. But I know it can be done so any help pointers, links or general info would really help me out. So to recap on what I need to set up.

dual boot with osx
how to set up and configure correct partitions with a large swap disk
install with efi
and install ati drivers


Right i used tumbleweed (13.1, mile stone 3) and the install dvd burnt and installed just fine as far as i can tell did a media check before install. now opensuse does not want to boot it stalls at crating udev and goes no further. but when i use the advance option and select recovery mode it boots up fine. how can i get opensuse to boot up without running in recovery mode and how can i find out the reason for this failing.

also when i am typing now in opensuse the cursor jumps all over place so far it seems to jump to the mouse pointer and starts typing there. this is a major pain in the backside please help if you can.

so far i have
osx working
opensuse booting from recovery only
large swoop disk to match my 16gb ram

wont i dont have is
grub2-efi cant start OSX
ATI drivers need to be installed
a working keyboard that does not make cursor jump all over the place
all in all this is further than i have ever got with opensuse 12.3 that had to use a text install and still failed to boot.
more help required pease and thats for the link so far.

I’ve not had good success using grub2-efi on my MacBook Air and instead use rEFIt - An EFI Boot Menu and Toolkit which allow easy booting of OSX and Linux (and USB devices, etc.) There is a fork of this that looks interesting as well, though I’ve not tried it: The rEFInd Boot Manager (Note there is a wealth of info on his site about the nuances of OSX booting and hybrid MBR partition tables, etc.)

As for why Suse boots in recovery mode, but not normal node, you might try removing the recovery mode kernel options one at a time until you find the one which prevents it from booting, that may shed some more light on the issue.

It is not tumbleweed, it is development version of next openSUSE distro.

now opensuse does not want to boot it stalls at crating udev and goes no further. but when i use the advance option and select recovery mode it boots up fine.

Recently someone reported similar symptom on similar hardware in this forum. Looks like problem with graphic driver. Booting in recovery mode effectively turns it off. Similar e.g. to I do not know what can be done except turning off kernel modesetting which may result in slow video.

grub2-efi cant start OSX

Yes, I have observed this as well and there are other reports. Default loader for OS X used by GRUB is apparently outdated and incompatible with current OS X version. If you really care, I’d suggest open bug report on (post number here). You can use the same account as on this forums.