Macbook Pro 7.1 with NVIDIA graphic cards ... Does not shut down with opensuse 12.1

I have a Macbook Pro 7.1 with an intel chip and nvidia graphic card and NVIDIA drivers installed. I use KDE. With opensuse 11.4 also I had shutdown issues (such as the screen flickering several times before shutting down). I could not fix that issue although I googled a lot and tried several things and hence had ignored it. Please note that, there is no hardware issue as such as it works fine when I run MAC. Now, after upgrading from 11.4 to 12.1, I see that the laptop simply does not shutdown. It flickers continuosly for minutes and does not shut down. I had added Nvidia respos while upgrading the system. When I try a command line option “shutdown -r now” then it works smoothly, without any flickering it shuts down swiftly.

Can someone help me resolve this bugging and critical issue?

Thanks in advance.

I do not know the solution for the ‘flickering’ screen but you can make an adjustment to shut down.
Go into the personal settings (configure desktop), then go to ‘Login’ then the ‘shutdown’ tab and change the ‘Halt’ box to read ‘poweroff’ (instead of halt). This might be the answer.


I tried it after reading your post. That did not help either.