Macbook Headphone Jack Not Working 12.1

Hey guys, I can’t get the headphone jack in my Macbook to work with openSUSE 12.1. I’ve looked through these threads:
http://forums.opensuse.org/hardware/laptop/425650-macbook-core-duo-opensuse-11-2-no-sound-headphone-port.html
http://forums.opensuse.org/english/get-technical-help-here/multimedia/457628-headphone-jack-internal-mic-not-working.html

and I did everything recommended by oldcpu in the welcome to multimedia sub-thread area:
http://forums.opensuse.org/english/get-technical-help-here/multimedia/309430-welcome-multimedia-sub-area.html

I also looked through the audio troobleshooting page:
SDB:Audio troubleshooting - openSUSE

No dice. I have gone into my /etc/modprobe.d/50-sound.conf file and added a first line to the file which set the mode to each of the following settings:

intel-mac-v1 Intel Mac Type 1
intel-mac-v2 Intel Mac Type 2
intel-mac-v3 Intel Mac Type 3
intel-mac-v4 Intel Mac Type 4
intel-mac-v5 Intel Mac Type 5
intel-mac-auto Intel Mac (detect type according to subsystem id)
macmini Intel Mac Mini (equivalent with type 3)
macbook Intel Mac Book (eq. type 5)

None of these settings work. In fact, upon restarting my sound driver after setting each mode (using the command: su -c ‘rcalsasound restart’), the only change was that I lost sound from both my speakers and my headphones. So, I’ve given up on solving this alone. Below is the output requested by the “welcome to multimedia sub-thread area” page.

Here is the result of /usr/sbin/alsa-info.sh :
http://www.alsa-project.org/db/?f=34dd43605bea270e9cb7817a48db6be95903d50c

Here is the result of rpm -qa ‘alsa’:

alsa-oss-1.0.17-37.1.2.i586
alsa-utils-1.0.24.2-12.8.1.i586
alsa-driver-kmp-default-1.0.24.20111214_k3.1.0_1.2-1.1.i586
alsa-1.0.24.1-23.1.2.i586
alsa-tools-gui-1.0.24.1-12.1.2.i586
alsa-devel-1.0.24.1-23.1.2.i586
pyalsa-1.0.22-9.1.2.i586
alsa-plugins-jack-1.0.24-18.1.2.i586
alsa-plugins-1.0.24-18.1.2.i586
alsa-firmware-1.0.24.1-7.1.1.noarch
alsa-tools-1.0.24.1-12.1.2.i586
alsa-docs-1.0.24.1-23.1.2.noarch
alsamixergui-0.9.0rc1-755.1.2.i586
alsa-plugins-pulse-1.0.24-18.1.2.i586

Here is the result of rpm -qa ‘pulse’:

pulseaudio-module-bluetooth-1.1-1.2.i586
libxine1-pulse-1.1.20-59.4.i586
pulseaudio-module-zeroconf-1.1-1.2.i586
pulseaudio-module-jack-1.1-1.2.i586
pulseaudio-1.1-1.2.i586
pulseaudio-utils-1.1-1.2.i586
pulseaudio-module-x11-1.1-1.2.i586
libpulse0-1.1-1.2.i586
vlc-aout-pulse-1.1.12-4.7.i586
pulseaudio-module-lirc-1.1-1.2.i586
alsa-plugins-pulse-1.0.24-18.1.2.i586
libpulse-mainloop-glib0-1.1-1.2.i586

Here is the result of rpm -q libasound2:

libasound2-1.0.24.1-23.1.2.i586

Here is the result of uname -a:

Linux linux-zbhl.site 3.1.0-1.2-default #1 SMP Thu Nov 3 14:45:45 UTC 2011 (187dde0) i686 i686 i386 GNU/Linux

Here is the result of cat /etc/modprobe.d/50-sound.conf:

options snd slots=snd-hda-intel
# u1Nb.FM5qfmnQDA7:82801G (ICH7 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel

Just for clarification, right now I have set everything back to where it orginally was, and the speakers work, but the headphones do not.

First, let me say well done in testing as far as you did. I do note that you did not test far enough, IF I read your post correctly (apologies in advance if I read it wrong).

According to the diagnostic script output, your MacBook-1.1 has a 32-bit openSUSE-12.1 with the cutting edge SuSE-GmbH packager’s packaged development versions of Driver versions of alsa-.0.24-git20111214. Your MacBook as a STAC9221. But you did not follow the guide and update the remainder of your alsa apps, which the guide warns you need to do carefully, ie you did not update:

alsa-oss-1.0.17-37.1.2.i586
alsa-utils-1.0.24.2-12.8.1.i586
alsa-1.0.24.1-23.1.2.i586
alsa-tools-gui-1.0.24.1-12.1.2.i586
alsa-devel-1.0.24.1-23.1.2.i586
pyalsa-1.0.22-9.1.2.i586
alsa-plugins-jack-1.0.24-18.1.2.i586
alsa-plugins-1.0.24-18.1.2.i586
alsa-firmware-1.0.24.1-7.1.1.noarch
alsa-tools-1.0.24.1-12.1.2.i586
alsa-docs-1.0.24.1-23.1.2.noarch
alsa-plugins-pulse-1.0.24-18.1.2.i586
libasound2-1.0.24.1-23.1.2.i586

all of those have versions that were NOT updated :frowning: The guide recommends to update them.

Now that may not be the problem, but care is needed here when updating.

wrt the options you tried,

intel-mac-v1 Intel Mac Type 1
intel-mac-v2 Intel Mac Type 2
intel-mac-v3 Intel Mac Type 3
intel-mac-v4 Intel Mac Type 4
intel-mac-v5 Intel Mac Type 5
intel-mac-auto Intel Mac (detect type according to subsystem id)
macmini Intel Mac Mini (equivalent with type 3)
macbook Intel Mac Book (eq. type 5)

Those are only a subset of the possible options that can be tried, where the complete list is:


STAC9220/9221
=============
  ref		Reference board
  3stack	D945 3stack
  5stack	D945 5stack + SPDIF
  intel-mac-v1	Intel Mac Type 1
  intel-mac-v2	Intel Mac Type 2
  intel-mac-v3	Intel Mac Type 3
  intel-mac-v4	Intel Mac Type 4
  intel-mac-v5	Intel Mac Type 5
  intel-mac-auto Intel Mac (detect type according to subsystem id)
  macmini	Intel Mac Mini (equivalent with type 3)
  macbook	Intel Mac Book (eq. type 5)
  macbook-pro-v1 Intel Mac Book Pro 1st generation (eq. type 3)
  macbook-pro	Intel Mac Book Pro 2nd generation (eq. type 3)
  imac-intel	Intel iMac (eq. type 2)
  imac-intel-20	Intel iMac (newer version) (eq. type 3)
  ecs202	ECS/PC chips
  dell-d81	Dell (unknown)
  dell-d82	Dell (unknown)
  dell-m81	Dell (unknown)
  dell-m82	Dell XPS M1210
  auto		BIOS setup (default)

Just because ‘mac’ is not listed in the description does not mean it should not be attempted. Also, where did you add the line to the 50-sound.conf and what syntax did you use?

But even more important is your mixer … Your mixer could be configured wrong. I note:


Simple mixer control 'Speaker',1
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [0.00dB] **[off]**
  Front Right: Playback 64 [100%] [0.00dB] **[off]**

why is that OFF ? Try unmuting that FIRST before trying anything else.

I recall a post by a Macbook user on our forum (post#12 in quoted thread), where they stated the fix was to unmute speaker1.

Good luck with your efforts.

oldcpu,

Thanks for the reply! Sorry I’m so late getting back to this, but holiday madness has kept me busy.

The good news: the problem is solved! I spent some more time messing with amixer, unmuted those two channels, and everything works! For posterity’s sake, the command I used was:


sudo amixer -c 0 sset 'Speaker',1 unmute

Also, just let me say: you’re 100% right about my updates. I’ve gone back and updated my various alsa apps as per your guide (sorry that I wasn’t more thorough the first time through–its a great guide, and deserved better ;).

But even in the wake of this glorious victory, something bothers me. Why wasn’t I able to see these muted channels and take care of them in alsamixer? According to alsamixer, I have 2 channels: Master and Capture (here is what I am looking at: http://i.imgur.com/HNyTR.png). Is there something wrong with my mixer configuration? Do I simply no know how to use alsamixer to its fullest extent? It seems silly that I have to re-read the amixer documentation every time I want to make a change to any of the other channels.

Well done! Congratulations on sorting this with the amixer command. The syntax of that is not easy and I cringe everytime I need to recommend how to use that command as I struggle with its syntax.

Good question. I don’t know the answer to that.

Its things like that which create a mountain for new GNU/Linux users and threatens to drive them away. :frowning: