MacBook Air Keyboard Issue

I am a learner of OpenSUSE, Recently on my MacBook Air Mid 2013 Model i completely removed OSX and installed OpenSUSE using rEFInd.
On my keyboard some keys not working such as ‘s’ , right arrow etc, and when i press kkkkkkkkkk button once it i continuously typing.
Your kind help is greatly appreciated.

Thankks in advance.

This sounds like there was an issue before the installation of openSUSE, to be honest. If not you could search the logs for any hints (/var/log/messages if installed, journalctl, dmesg).

You are precisely correct I had issue even before installing opensuse but with cataline osx I fixed the problem once with help of Google but next time I was tried but not very successful and I don’t want to work on osx so completely removed osx and installed opensuse considering this will permanently resolve issue. But unfortunately here issue remained same.
I have a strong opinion that this is a software issue not hardware related.
I am not a software engineer, therefore I request some one to guide me to reinstall drivers or kernel related thing of keyboard to try fully.


Can you recall what you did to resolve the issue prior to the reinstallation? Could you take a look into the logs I mentioned and share anything suspicious here? Don’t forget to mask any sensitive information.

Dear Sir,

Before installation in OSX for similar problem as far as i remember some blogs from google suggest to make some changes in settings such as keyboard and mouse touch pad to change sensitivity or repeatable speed some thing like that, after following that keyboard was normal.
Please let me know how i can transfer or attache log file it is too big and could not able to copy here.


Try this:

So I guess you already tried to adjust keyboard settings in the system settings of openSUSE?

Dear Sir,
As advised please find the link pasted with dmseg out put.

No Sir, NOt yet i could fix anything, kindly help me please, i dont want to revert ot OS again.