mac book pro 7,1, opensuse 11.3 and the internal mic

Hi All,

cutting a long story short… I have a mac book pro 7,1 13.3 and the internal mic is not working… I tried all the things that I knew… even some that I did not and still no luck, just lack of mic.

here is what I did Alin Marin Elena » the mac book pro 7,1, opensuse 11.3 and I: A front line log and here is my alsa-info.sh
http://www.alsa-project.org/db/?f=ad6aa2b1cf31c6eb27d43bd553ea0e26f28aa3b5

some ubuntu users claim that works for them but the volume is pathological low, if I get them correctly… https://help.ubuntu.com/community/MacBookPro7-1/Lucid#Microphone

Any help will be much appreciated.

Alin

Thanks.

The alsa script tells me the hardware codec in your 64-bit openSUSE-11.3 install (with the 2.6.34.7 kernel) is a Cirrus Logic CS4206.

Your web page tells me this for the /etc/modprobe.d/50-sound.conf:

options snd-hda-intel model=mbp55
options snd slots=snd-hda-intel
# RE4e._ECyo4j5hZB:nVidia Corporation
alias snd-card-0 snd-hda-intel

I know from alsa documentation, that the mpb55 model option is associated with the Cirrus Logic CS4206/4207. Other options associated with that (from the HD-Audio-Models.txt files are:

Cirrus Logic CS4206/4207
========================
  mbp55		MacBook Pro 5,5
  imac27	IMac 27 Inch
  auto		BIOS setup (default)

But the script tells me this:

snd-hda-intel: model=auto

that contradicts the blog(?) web site you quoted, where it states wrt mbp55, and hence I think you ran the script on a different occasion from when you had mbp55 in your /etc/modprobe.d/50-sound.conf file. That makes the script output NOT HELPFUL to me. Sorry, I’m not bright enough to speculate the impact of running the script at the wrong time.

The script also tells me this:

!!ALSA Version
!!------------

Driver version:     1.0.23-git20101007
Library version:    1.0.23
Utilities version:  1.0.23

I note the driver 1.0.23-git20101007 is NOT the driver that comes with openSUSE. So you updated that driver. What else did you update with that driver? Please provide the output of:

rpm -qa '*alsa*'
rpm -qa '*pulse*'
rpm -q libasound2

and so I can confirm the content of your /etc/modprobe.d/50-sound.conf file has not changed, provide the output of:

cat /etc/modprobe.d/50-sound.conf

and also run the script again and provide the output URL:

/usr/sbin/alsa-info.sh

I’m not smart enough to provide a recommendation without that information, please can you provide ALL of that?

Hi oldcpu,

you are right my info is a little bit inconsistent… played so much in order to get the mic working that I managed to confuse even myself…

Here is the good alsa-info.sh http://www.alsa-project.org/db/?f=24953dcd18c0b99f499ef1539df38b19a2ba1e68


abbaton:/home/alin # cat /etc/modprobe.d/50-sound.conf

options snd-hda-intel model=mbp55
options snd slots=snd-hda-intel
# RE4e._ECyo4j5hZB:nVidia Corporation
alias snd-card-0 snd-hda-intel

I just added the new drivers to be sure that the problem is not there.
Here are the packages


abbaton:/home/alin # rpm -qa '*alsa*'
alsa-plugins-32bit-1.0.23-1.9.x86_64
pyalsa-1.0.22-1.8.x86_64
alsa-firmware-1.0.23-1.2.noarch
alsa-driver-unstable-kmp-desktop-1.0.23.20100906_k2.6.34.7_0.3-50.1.x86_64
alsa-devel-1.0.23-2.12.x86_64
alsa-plugins-1.0.23-1.9.x86_64
alsa-oss-1.0.17-29.2.x86_64
alsa-1.0.23-2.12.x86_64
alsamixergui-0.9.0rc1-746.1.x86_64
alsa-tools-1.0.23-1.8.x86_64
alsa-tools-gui-1.0.23-1.8.x86_64
alsa-driver-kmp-desktop-1.0.23.20101007_k2.6.34.7_0.3-1.1.x86_64
alsa-utils-1.0.23-1.8.x86_64

abbaton:/home/alin # rpm -qa '*pulse*'
libpulse-mainloop-glib0-0.9.21-10.1.1.x86_64
libpulse0-0.9.21-10.1.1.x86_64

abbaton:/home/alin # rpm -q libasound2
libasound2-1.0.23-2.12.x86_64



Thanks, that script looks ok, but there are problems with the alsa rpms you installed.

You have 2 versions installed of the alsa-driver with alsa-driver-kmp-desktop and alsa-driver-unstable-kmp-desktop. Thats a BIG mistake. You should only have one, which is alsa-driver-kmp-desktop. It is a bit tricky to recover from this. You need to remove BOTH alsa-driver-kmp-desktop and alsa-driver-unstable-kmp-desktop and then re-install alsa-driver-kmp-desktop.

Next, I can see some problems with the versions you installed. It appears to me that you did not check to see if the version you had before, was updated after you thought you updated. I highlighted in RED versions that never updated. If you want to a consistent alsa set of packages with the updated alsa GIT driver, you NEED to update those.

There is a guide here explaining this: SDB:Alsa-update - openSUSE

If you have a problem following the guide, please advise.

Thank you oldcpu!

I hope I solved all the problems concerning consistency now.
here is my new alsa-info.sh http://www.alsa-project.org/db/?f=16725025a2fa508111ba911b13f866192815da90

no change for modprobe

and here are the new rpms


abbaton:/home/alin # rpm -qa '*alsa*'
alsa-oss-1.0.17-53.1.x86_64
alsa-tools-1.0.23-9.1.x86_64
alsa-driver-kmp-desktop-1.0.23.20101007_k2.6.34.7_0.3-1.1.x86_64
alsa-plugins-32bit-1.0.23-33.1.x86_64
alsamixergui-0.9.0rc1-746.1.x86_64
alsa-plugins-1.0.23-33.1.x86_64
alsa-tools-gui-1.0.23-9.1.x86_64
alsa-1.0.23-69.1.x86_64
pyalsa-1.0.22-4.1.x86_64
alsa-utils-1.0.23-25.1.x86_64
alsa-firmware-1.0.23-8.1.noarch
alsa-devel-1.0.23-69.1.x86_64
abbaton:/home/alin # rpm -qa '*pulse*'
libpulse-mainloop-glib0-0.9.21-70.1.x86_64
libpulse0-0.9.21-70.1.x86_64
abbaton:/home/alin # rpm -q libasound2
libasound2-1.0.23-69.1.x86_64

I have checked and still no mic…

Alin

Thanks for updating. I assume you REMOVED both the alsa-driver-kmp-desktop AND the alsa-driver-unstable-kmp-desktop and THEN RE-INSTALLED the alsa-driver-kmp-desktop like I asked. Just removing the alsa-driver-unstable-kmp-desktop is insufficient and while the final rpms would look correct, the installed files would be wrong. Don’t forget to reboot after having installed all the appropriate rpms so that the kernel modules are properly reloaded.

Now assuming you did all that, going back to your original post:

The Ubuntu users installed an application called ‘paman’ so they could better tune the mic … I’ve never used that application, and from what a quick surf indicated, it is a pulse audio application. If you are using Gnome, then it uses pulse audio and you probably should install that.

My guess, based on your list of pulse audio applications, is you are using KDE and hence I don’t think that should be necessary (and hence I think you should NOT install “paman” on KDE).

Please, what are you using to test your internal Mic ? For testing a mic, I recommend you use a terminal with this command:

  arecord -vv -fdat foo.wav

“foo.wav” is an arbitrary name I made up. Instead you could call it whatapain.wav or whichwaythewindblows.wav or anything …

Also, does this Mac book pro have an integrated web cam ? Sometimes on laptops the internal mic is integrated with the webcam’s functionality, and one needs the webcam driver installed for the mic to work. So if there is an integrated webcam, I also recommend you install that driver.

Also, does an EXTERNAL mic work?

Now assuming you removed and re-installed the driver rpms like I asked, and assuming your integrated webcam (if any) is setup, and assuming you are using arecord for your test, and assuming an EXTERNAL mic works and an INTERNAL does not work, then this should be working.

In that case you need to write a bug report on openSUSE-11.3 so as to get the attention of the SuSE-GmbH sound packager, who is also a developer of the alsa sound driver. They will then come up with a fix to the driver and have you test the fix. Once the fix is in place they will send the fix upstream to the alsa development site, where it will be packaged and sent downstream so that all Linux users will benefit.

There is guidance here for raising a bug report (raise it on openSUSE-11.3 component “sound”): openSUSE:Submitting bug reports - openSUSE

Attach to the bug report the file “/tmp/alsa-info.txt” which comes from running the script (with the noted arguments):

/usr/sbin/alsa-info.sh --no-upload

Note the openSUSE packager will NOT read a blog, nor a forum thread, so the bug report must contain ALL salient information within the bug report. After raising the bug report, keep tracking it (visit every other day) looking for a reply from the SuSE-GmbH sound packager.

Good luck.

Thank you for you help oldcpu!
Your assumptions were right… I correctly removed the kmp modules and I kde.

I do not have an external mic, at least I do not remember where I have one. I tested only the internal
with

 
arecord -d 10 foo.wav

and just noise
using your command for arecord it works…

At least now I know the beast is working… However we skype does not seem to work… I tried to manually specify the input from the list that skype offers and still no luck.

I will look to fill a bug to bnc… Funny enough my first bug fixed their many years ago was sound related too…

Alin

oldcpu a little bit more progress…

skype still refuses to work…
However arecord and audacity record sound… which seems to be mono but still fine for the moment.

Alin

Thats good to read some progress.

I recommend you start a new thread asking for help specific with “Skype”, with “Skype” in the thread title. I never use that software so I can not help with it.

I opened a bug report in bnc.
The skype mic not working is just a side effect of a misconfigured mic. Takashi is giving me some instructions to make it work…
Up to know I have huge amounts of noise but at least is consistent in all the programs I tested… audacity, arecord and skype.

I will keep you posted with the conclusions.

I think this is the bug report: https://bugzilla.novell.com/show_bug.cgi?id=645351 ?

OK, please do.

Also, after you reply to Takashi test requests, please remove the status from “NEED INFO” . You can do that by checking in the “Additional Comments” box, at the bottom of the box, where it says: This comment provides the needed information. Remove the status of NEEDINFO from this bug.

If you do not do that, Takashi will not know you have replied. So please do that ASAP.

Thank you for your contribution to help fix this for all Mac Book Pro 7.1 users.

Takashi from novell almost solved the problem…
The issue is that the mic records only on the right channel by default and skype catches only the left channel. Takasahi showed me this workaround. I did not formalise it in something permanent as a proper solution should follow soon.


alin@abbaton:~> cat imic.sh 
rcalsasound stop
rcalsasound start
# ox12 activates left channel of the internal mic, 0x0c activates the right channel
echo 0x12 0x03a15030 > /sys/class/sound/hwC0D0/user_pin_configs
echo 1 > /sys/class/sound/hwC0D0/reconfig 

Thats an interesting thread, but all that pin swapping is well above my limited technical understanding. I think we are very fortunate that SuSE-GmbH/Novell have Takasahi (an alsa sound driver developer) supporting the sound packaging for openSUSE.

I heard for recording IMCapture for Skype ( IMCapture for Skype (formerly SkypeCap) - Start saving video and audio conversation from Skype! ) is a good app. anybody use it?

cefm, that is an MS-Windows and a MAC-OS app, but not a Linux app.

I note this is your 3rd post, and your previous two posts only stated “this is interesting”.

Welcome to our forum, and welcome to openSUSE, but please be advised we take a very dim and very strong reaction to any post that is considered spam. Typically users who post spam are banned, and typically their posts deleted.

Since there is no reference to Linux on that URL (for recording Skype conversations) and since the user is discussing Linux on their MacPro, I would prefer if you do NOT reference Mac applications here.

If I am wrong, and if this app does work in Linux, please correct me.

Thankyou!