[Ma-config]delete ma-config


I have installed ma-config software but yast alert me of a Package Conflicts I tried to delete it but I can’t. I can’t use yast package manager anymore because of that.


this is the details about the error when I tried to uninstalled it

  Subprocess failed. Error: RPM failed: /usr/bin/ma-config/maconfigagent: /lib64/libcrypto.so.1.0.0: no version information available (required by /usr/bin/ma-config/maconfigagent)
 /usr/bin/ma-config/maconfigagent: /lib64/libssl.so.1.0.0: no version information available (required by /usr/bin/ma-config/maconfigagent)

 sudo: maconfigagent: command not found
 sudo: update-rc.d: command not found

 error: %preun(Ma-Config.com- scriptlet failed, exit status 1
 error: Ma-Config.com- erase failed

Try to run “sudo rpm -e --noscripts ma-config” (or whatever the package is called) to remove it.

Thanks for Reply. The problem is that I don’t know the real name of the package.

And how did you try to uninstall it the first time then?

YaST should show you the name, use the search function if necessary.
Or try something like:

rpm -qf /usr/bin/ma-config

what does zypper se ma-config say?
as far as I can tell that is a 3rd party system information application, it probobly wasn’t compiled for opensuse and has missing dependencies, did you install it from an rpm if so try rpm -e path_to_that.rpm

Took a brief look at it.
I <know> I have the libssl package installed but saw that error.
Likely a faulty configuration by the developers, typical error is that the path to the library file on a Fedora/CentOS is hardcoded so can’t find on openSUSE.


Hello everyone,

Thanks for you answer this is the error I get when I try your solution.


Can I restore my system before the installation of this package?

Thanks guys

it looks like your internet is down?
are you using wired or wireless, are you using network monitor or wicked?

It could also be packman.inode.at being down, I cannot reach it either at the moment…

Try to enter ‘i’ (for ‘Ignore’) when you get that error message.

And the package is apparently called “Ma-Config.com”, so run this to uninstall it:

sudo rpm -e --noscripts Ma-Config.com

Note the upper and lower case characters, rpm is case-sensitive.