M7 the Good and the Bad

The Good:
It installed ok and the video looked great. First time the default video did not offset my display to the right by a 1/4 inch. The font was crisp and clear and it recognized my nVidia 7300LE card.
Also seemed to be stable.

The Bad:
Couldn’t mount and read my VMware DVD unless I was in root. Matter of fact I couldn’t mount any DVD’s or CD’s. Also the USB connector icon is missing down on the task bar.
I finally got the VMware software installed but could not run it. It needs to compile some modules and it needs the Linux Headers. When it tried to compile, the claim was that the Headers did not match the running kernel. Had this same problem with the 11.2 milestones and I had to wait for a “Released” version so everything was the same.:frowning:
Sound? None. I will check into further and reply back.

Post here and I can try help with sound. If you have 2 sound devices, it may have chosen the wrong device. …

Please note the guidance we give in our multimedia stickie for helping with sound problems: Welcome to multimedia sub-area - openSUSE Forums

Reference the display NOT being offset by 1/4 " on the monitor . … thats good news. I find that very useful when using a KVM to go back and forth between computers.

At the risk of my stating something obvious, I assume that you know most monitors have a button one can press which will automatically bring the display position into alignment on the monitor.

Interesting-I had the same issue when trying to install the downloaded proprietary nVidia driver…

In KDE, the device notifier is missing from the panel. When I plug a usb in, it is picked up in the KDE menu>Computer (removable storage section), and you can safely remove from there. Same with CD/DVD, to be found in same menu tab.

When you find the icon for the usb/cd, click on it to mount properly and display content, or you won’t be able to eject/remove safely.


Interesting-I had the same issue when trying to install the downloaded proprietary nVidia driver…[/QUOTE]I had no problem building from the .run file on an older system. I did black list nouveau driver (I don’t know if that is necessary) and of course to start X window I had to use a special argument : " startx --ignoreABI "

Hi oldcpu, Sorry for the long delay in replying. Anyway, I do believe that the sound problem is the same one that I had in 11.1. The sound is an Integrated Audio, Realtek ALC882.

Well, I looked on the Web and found that another person had problems with sound. It was a review on SuSE 10.2 by Clement Lefebvre. He had problems with his hardware getting setup. In the Hardware section of YAST, it detected my sound chip but did not set it up. I had to edit it and select 'automatic configuration'.  Also had to do this for 11.2 -but- did not remember till I looked at my WebPage notes. ([TRComputing - PC tutoring or repair in your home.](http://www.trcompu.com))

As for the VMware section, yes I can get it to work on an older system too. Just can't get it to work on 11.3 because of the compilation failure because of the headers not matching the running kernel.  I experienced this same thing in the 11.2 kernel.  Prior to that actual release I could NOT get a good compile of the kernel.  It appears that pre-releases now-a-days have a working kernel that does not match the sources -until- the final release. So, I can not test the VMware capabilities of this latest SuSE ... and I do want those capabilities.  It is fun to run Linux, Win2K, Vista and Win7 -all- at the same time.  I don't do it consistently but it impresses the friends (and myself). I have a "Preliminary Dual Core"(Intel PentiumD 940 (P)) machine with 4 GB of RAM and (2)300GB hard drives.  More power than I ever had, or dreamed of, when I was actually working (I'm semi-retired).  Really would like to have had this machine then.

Anyway, I started with VMware back in 98 or 99 and have been plating with it ever since.  I've threatened (mostly mentally) to leave SuSE many times cause VMware didn't work. -But- we found fixes.  I'm sure there will be one for this ... as long as I'm patient.  If one doesn't come up here, I will search the Web and do my own investigation trials till one is found.  I like the SuSE community and want to stay attached. So, IF anyone has this working already, please reply with how and it would be greatly appreciated.

Take care,

I don’t think so. I built a driver with 11.3 M7 with no problem. The working kernel HAD to match the source for this to work, and it DID work. So the working kernel DOES match the sources and it does match NOW in the M7 snapshot. And it did in M4, in M5, and in M6 as I successfully built drivers in EACH.

The cause for the unfortunate problem you encountered likely lies elsewhere, … or perhaps you did NOT stick with a snapshot kernel, but rather started installing every new build updated kernel in 11.3 factory, which IMHO is NOT a good idea for one who struggles with such problems.

Good luck with your VMWARE efforts.

Nope. I grabbed the M7 release the day or day after it was released. Downloaded it and installed it. Have the sources installed and in the default path. Load up VMware and then start it. As always it, VMware, claims that it needs to compile and install some modules. Then it complains that the headers do not match the running kernel. Believe me, I did not change the kernel in any way from the download. There are some things that will possibly have to be changed later but for now the both should work out of the box … or so I thought. Because of the troubles I had trying to, and almost did, get VMware version 5.9 to work I broke down and purchased VMware version 7. It is supposed to work smoothly … and did in SuSE version 11.2. I either am not holding my tongue on the correct side, or, I somehow downloaded a mismatched set. I have a triple boot system, WinXP, openSuSE 11.2 and openSuSE 11.3. It was a clean install – not an upgrade or update. Thanks for your time anyway.

June 08, 2010 I brought down a fresh copy of M7. The version I had downloaded before was from the download page that ‘said’ it was M6 but when you clicked on the download it was openSUSE-DVD-Build0625-i586.iso, which is 11.3 M7. The download page now has all the proper markings for M7 and I have gotten a copy from it. Hopefully this will get a matching kernel and source headers.

Well, after this new installation my sound works. However, still do not have the USB notification in the Task Bar. And I placed the VMware disc in one of my optical drives. Opened 'MyComputer' and saw it listed. Clicked on it and got the following message:

There is no application installed that can open the type block device (inode/blockdevice).
Do you want to try to install one?
Had three choices: Checkbox ‘Do not ask again’ or ‘Install’ or ‘No’. I chose Install… It then looked for the software to install and could not find it. I was then instructed to See http://help.opensuse.org/ksuseinstall for details and asked if I wanted to configure my repositories. Hmmmmm… this is normally done on the initial install. Ok let’s say yes.

Allllrighty. It makes me sign on as root, then opens Yast2 to the configured Repos. Ok, I cheated and used zypper to get the same list I was shown in Yast2 so I could list them here. They are:

| Alias | Name | Enabled | Refresh

1 | Updates for openSUSE 11.3 11.3-1.59 | Updates for openSUSE 11.3 11.3-1.59 | Yes | Yes
2 | openSUSE-11.3 11.3-1.59 | openSUSE-11.3 11.3-1.59 | Yes | No
3 | repo-debug | openSUSE-11.3-Debug | No | Yes
4 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes
5 | repo-oss | openSUSE-11.3-Oss | Yes | Yes
6 | repo-source | openSUSE-11.3-Source | No | Yes

Now according to what I know and have learned, the code needed should be in one of the above repos. Ok, let’s get out of my area and into root to see if we can then read the disc … like it was on the previous load.

In root Alllrighty! Another good point. File manager is back on the task bar. And in using it I find ‘nothing’ in media or mnt point. Once again we click on ‘My Computer’ and find that there is something in the DVD drive. It is: VMware-Workstation-Full-7.0.0-20. Hovering over it shows: **/dev/sr0 block device **Clicking on it and once again it asks if I want to install the block device.

Can’t remember how I got it to even read the disc in my previous attempt -but- shouldn’t be that much of a problem. Yes, yes I know this is beta but it really should be able to read a DVD. Guess I’ll have to wait till June 17th.