M7 and asus laptops (a7k esp.)

Hi all,

I’ve upgraded from M6 to M7 successfully and am slowly configuring everything. Audio didn’t work “out of the box”, but it didn’t in 11.1 either. Any other asus users get their laptop audio working? I’m starting to trouble shoot, but wanted to see if I needed to do the bug fix using the fix identified at the end of 11.1(using hda_verb)

Hi
Sound, webcam, bluetooth, wireless etc all working fine here. Do have
issues with the time when rebooting and requiring an fsck :frowning:

Gnome/Compiz DE going fine as well.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 Milestone 7 (i586) Kernel 2.6.31-rc9-7-desktop
up 12:01, 2 users, load average: 0.09, 0.05, 0.07
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

… which can (at least here) easily be solved by

  • syncing clock (via ntp)

  • syncing hwclock (systohc)

  • rebooting to init=/bin/sh

and then running fsck once.

After that no more clock related issues for me.

… or not?

After that procedure it worked fine, did several reboots.

Then I shut down the machine, and after starting it up a few minutes ago, everything boots up fine, but I got curious.

Although “date” showed the correct time now, “tune2fs -l” showed the last mount of “/” to be 2 hours in the future.

On reboot this caused the machine on initial routine fsck to mount / read-only again.

This is odd in two ways:

  1. Date gets set correctly but on mounting “/” the clock must have been 2 hours in the future, which could be explained that the time got corrected later during boot. Still there is the question, what set the time back to the wrong value on shutting down?

  2. Why does fsck on startup not automatically correct this error, I am very sure that this was standard behavior before, normally the default fsck on startup automatically tried to correct such errors unless they were really critical (this error is not one of that sort).

Although fixing is easy (even booting in RL1 seems to work) it is pretty annoying.

Hi
Well I had thought I had it fixed as it appears /etc/init.s/boot.clock
is buggy. What I did was change in timezone to set to --localtime.

I tried your way (although always run ntp) but when at init/bin/sh
shows a -5 hour error :frowning:

On shutdown I see the correct time is set, yet bootup borks and have to
fsck.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
up 7 days 19:58, 2 users, load average: 0.00, 0.03, 0.06
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

There’s the problem.

On reboot everything is fine.

After shutting down the machine and then starting it again, clock and consequently last mount time are 2 hours in the future again.


 date
Di 15. Sep 21:50:34 CEST 2009

# tune2fs /dev/sda2 -l|grep Last
Last mounted on:          <not available>
Last mount time:          Tue Sep 15 21:45:54 2009
Last write time:          Tue Sep 15 21:45:54 2009
Last checked:             Tue Sep 15 19:23:31 2009

… while the correct time is 19.45 here.

If I will correct the time (sync with ntp, I explicitely booted the machine to RL1 this time, so there was no automatic sync without network connection) and reboot the machine, I already know, what’s going to happen.

Clock is set to UTC, /etc/sysconfig/clock looks like this:


cat /etc/sysconfig/clock 
## Path:                System/Environment/Clock
## Description:         Information about your timezone and time
## Type:                string(-u,--utc,--localtime)
## ServiceRestart:      boot.clock
#
# Set to "-u" if your system clock is set to UTC, and to "--localtime"
# if your clock runs that way.
#
HWCLOCK="-u"
## Description: Write back system time to the hardware clock
## Type:                yesno
## Default:             yes
#
# Is set to "yes" write back the system time to the hardware
# clock at reboot or shutdown. Useful if hardware clock is
# much more inaccurate than system clock.  Set to "no" if
# system time does it wrong due e.g. missed timer interrupts.
# If set to "no" the hardware clock adjust feature is also
# skipped because it is rather useless without writing back
# the system time to the hardware clock.
#
SYSTOHC="yes"

## Type:                string(Europe/Berlin,Europe/London,Europe/Paris)
## ServiceRestart:      boot.clock
#
# Timezone (e.g. CET)
# (this will set /usr/lib/zoneinfo/localtime)
#
TIMEZONE="Europe/Berlin"
DEFAULT_TIMEZONE="Europe/Berlin"

Now the problem in my case, these are virtual machines (VBox), so I can’t be sure, if this is a problem related to the vboxadd-timesync service or any other “VM-related” issue, so I am not the one who could write a useful bugreport.

If anyone has the same problem with 11.2 M7 actually installed on “real” hardware, try to reproduce the behavior, check the outputs on your machine and write a bug report!

Hi
Ok, so after fluffing around and various shutdowns and booting into
init=/bin/sh and rebooting, I got side tracked with searching the yast2
sysconfig and had noticed it complaining about a module not found
(ata_piix?).

So I did two things, enable the interactive boot
(in /etc/sysconfig/boot) and then removed the module from
initrd_modules in YaST. This of course kicked in mkinitrd. So now I
rebooted and the error had disappered, but low and behold the system
booted fine. Turned off the interactive boot, and have shutdown and
restarted numerous times and all is well.

So fire up vmware workstation with a suspended 11.2 M7 (x86_64) session
now and reboot, all was fine with this, it did show that it was
carrying out a fsck but continued on. So once it booted su to root and
ran /sbin/mkinitrd and it’s all working fine on check on reboots or
shutdown/restart.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
up 8 days 3:12, 2 users, load average: 0.45, 0.38, 0.36
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Please read and contribute to this bug report, especially the people running their M7 on “real” hardware.

https://bugzilla.novell.com/show_bug.cgi?id=534816

Hi
Comment and votes added :wink:


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
up 14:49, 2 users, load average: 0.68, 0.74, 0.36
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Thx.

So I will try the whole stuff with “localtime” now (which is AFAIK normally what you should use if you have a dualboot Win/linux) and see what happens.

The most puzzling thing for me is still this “reboot == fine” but “halt == trouble”.

Yup, using “localtime” instead of UTC and rebuilding initrd (don’t really know if this is necessary, at least with UTC it did not work) works around this problem.

Even after several reboots and halt/restart cycles (feels like using Win98 lol) no problems what so ever.

But now, here’s the kicker:

Switched back to UTC after that and was not able to reproduce the error.

After running “mkinitrd” with clock set to UTC the problem reocuered immidiately.

WTF?

World Tildlife Fund?
Wo Tastatur Fehlt?

:wink:

Hi all.

I have an asus a7k laptop. (forgot to mention it before). comes with ATI 2500 Radeon card and Realtek 660VD audio.

I don’t have any of the timezone issues described above I believe. At least I can verify for sure that the clock on KDE desktop bar doesn’t change with each successive reboot or shutdown.

I have had problems where I try to reboot and it hangs, so I’ve had to do a hard shutdown (i.e. the power switch). Can’t trace it to anything in particular.

I havent’ managed to get the sound working yet. I’ll need to ask the developer (tawai?)whether HDA verb is needed before I submit a bug. Is there an AlsaConfig.txt for v1.0.20? I couldnt’ find it and am curious if there are useful values to use on my modprobe.d/sound.

Haven’t manage to get the ati driver working either (followed instructions posted for M6 and Compiling ati drivers). Haven’t spent too much time on that, but I’ll start a separate post on that later.

On your sound: you might have to compile the alsa kernel module yourself. Don’t get scared it’s not that hard. You need the Linux Kernel Development PATTERN to be installed for it.
Please read on: Main Page - AlsaProject

Before that, please search the forums. Oldcpu is the sound professor here. You might find posts of his regarding your audio device.

alsa is now up to 1.0.21 (at least it was 8 days ago when I left on vacation). Still on vacation now, back in a few days, . … to get the latest alsa-configuration.txt file, the easiest way is to download the alsa tarball and read the documentation. Although the model options are no longer in the alsa-configuration.txt file for many hardware types, but rather in the HD-Audio-Models.txt file.

… in the mean time, some general suggestions …

The general advice I give for sound problems is to start trying to work your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE .

Do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is “kmix” (the small speaker in right hand corner). In Gnome your mixer is “alsamixer”.

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole

/usr/sbin/alsa-info.sh

Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation.

Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.