M-Audio Audiophile 2496 No Sound

I have an M-Audio Audiophile 2496 that uses the ice1712 alsa module. This card has always worked flawlessly in every previous version of opensuse. Now in opensuse 11.2, I’m having problems.

KDE System Notifications sound comes out fine. But I can’t get any sound from Flash videos or from Amarok. This is with a clean installation of opensuse 11.2 using the 64bit DVD. No matter what I try, I can’t get sound to play through this card, except the System Notifications. When I click on “Test” in the “Multimedia” section of KDE’s “Configure Desktop”, sound comes out fine. The backend currently in use with Phonon is “Xine”. I also tried “Gstreamer”, with no success.

If I use my motherboard’s onboard sound (ALC889 chipset, using the hda ALSA module), then everything works fine. Sound is present everywhere and everything functions as intended.

I tried disabling the motherboard’s onboard sound altogether in the BIOS, but that did not fix the problems with my M-Audio card. I need my M-Audio card for audio capture, among other things. Does anyone have any insight into the problem?

From what I can see, your basic sound functions, and you are searching for the solution in the wrong place.

It reads to me your problem is likely NOT having the right codecs, and possibly forgetting to move PCM volume up when playing media.

I recommend you setup your openSUSE-11.2 with 4 and ONLY 4 repositories. Those 4 are OSS, Non-OSS, Update and Packman. There is guidance here: Repositories/11.2 - openSUSE-Community The 1st 3 (OSS, Non-OSS, Update) should already be enabled, so you just need to add packman. Just those 4. No others None. If you added others, disable them. Give packman a higher priority (say 90) than the others (which are 99). Again ONLY the 4 repos that I recommend.

Then go to YaST > Software > Software Management if you know how, select to view by repositories, and then select the Packman repository, and tell openSUSE-11.2 to replace every Novell/SuSE-GmbH packaged app with their Packman equivalent. If you do not know how to do that, no worries, but if you can, it WILL make your openSUSE experience better.

Note that you can tell packman packaged versions of software with the “pm” in the rpm version number.

Also go to YaST > Software > Software Management > and change the “filter” to “search” and select for and install the Packman (pm) packaged versions of smplayer, vlc, libxine1, ffmpeg/libffmpeg0, libquicktime0, libxvidcore4.

You can also replace any Novell/SuSE-GmbH packaged gstreamer versions with Packman (pm) packaged versions.

That should get you started.

p.s. Did I tell you to ONLY select OSS, non-OSS, Update and Packman and no others?

Thanks, I already do all of that.

I’ll re-iterate: everything works with my motherboard’s onboard sound. Only KDE System Notifications work with my M-Audio card. This is not indicative of a codec issue. It is a driver issue.

Here are some scenarios I’ve gone through:

First scenario;

  • M-Audio card installed, onboard sound disabled in BIOS
  • Install opensuse 11.2 from the DVD
  • Sound works only in KDE System Notifications, does not work anywhere else (this includes Amarok, which I understand uses the same backend that KDE System Notifications do)

Second scenario;

  • M-Audio card removed, onboard sound enabled in BIOS
  • Install opensuse 11.2 from the DVD, exact same config as above
  • Sound works everywhere as expected

As I mentioned, my M-Audio card has always worked perfectly in every prior version of SUSE/opensuse. This is the first time this hardware does not work as expected.

I would appreciate a procedure for diagnosing this problem so I can file a proper bug report if needed.

Did you check what outputs are defined in the Advanced Options under Configure Desktop / Multimedia? As you can see, there are output devices for each type of sound, Notifications, Music, Video etc.

You prolly did but just to make sure :slight_smile:

Thanks, yes I did. They’re all set properly.

I’ve figured out the problem, and it is in fact a driver issue, although I was able to resolve it.

I’m actually working with 3 sound chips. The motherboard’s onboard sound, my M-Audio card… and the video card’s sound chip for HDMI output, which I always ignore and forget about. The problem arises in the order that opensuse configures those cards.

The order seems to be:

  1. any on-board sound chipset
  2. any chipset in a PCI Express slot (my video card)
  3. any chipset in a PCI slot (my M-Audio card)

The KDE Phonon backend allows me to choose which device to use first, but many applications do not obey this order. They just go by the card number as determined in the ALSA configuration. For some reason, Flash always seems to use card 0. In a weird twist, Amarok 2.1 also seems to ignore my Phonon preferences, even though it’s supposed to be a native KDE4 application.

So when my on-board chipset is enabled, everything works because it’s card 0. But when I disable it, the ATI HDMI sound chip ends up being card 0, where I have nothing hooked up. So anything that ignores my Phonon preferences will essentially output to nothing. That’s why sound works in some places (like KDE System Notifications) but not in others (like Flash).

I fixed this problem by “deleting” my sound cards in YAST and then manually setting them up in the preferred order (with the M-Audio card first). Now everything works as intended.

I think this is a pretty annoying bug, but I’m not sure where to file it. Amarok definitely needs to be fixed. But who’s fault is it that Flash and other applications ignore Phonon preferences? They’re not KDE4 apps, so there’s no reason why they should. I’ve noticed that SDL apps also output to card 0 by default. Anyone who has a discreet sound card and a video card with a sound chip (most current ATI cards) will probably come across this problem.

I disagree that this is driver problem. But it could be a misconfiguration.

Now if you wish to purse this being a driver problem, I won’t waste your time with suggestions you do not want to hear.

If you wish to explore possible mis-configurations in non driver areas, post and maybe we can try some things.

For diagnosing, no matter what the problem, you can start by providing the output of running the diagnostic script, with your PC connected to the internet, and your mixer setup EXACTLY the way you believe it should be setup for sound to work, where this is the script:
/usr/sbin/alsa-info.sh
select UPLOAD/SHARE and post here the URL it provides. Just the URL.

Also, when testing your sound, use the 3 sound tests from here (2 speaker tests and the sound test on the alsa site): SDB:AudioTroubleshooting - openSUSE

It may also help if you provide the output of:
cat /etc/modprobe.d/50-sound.conf

Hmmm … 1st, I am glad you sorted the problem.

But IMHO its not a problem with the driver, … but rather its a problem with how the driver was configured. Possibly semantics …

Anyway, glad to read you found a solution.

agreed, it would be more accurate to say it’s a configuration issue.

But it’s still annoying, and it could affect anyone else. I’m only guessing about the order that opensuse configures sound chipsets. Anyone complaining about “no sound” might just have their video card’s audio chipset taking precedence, and that’s not easy to diagnose for most people. I can see a lot of new users getting discouraged right away when sound doesn’t work, and then abandoning opensuse or Linux altogether as a result. This wasn’t such a big deal when most computers only had one sound chipset, but with the advent of video cards with an HDMI sound chip, more and more computers have multiple sound chipsets without the user realizing it.

I’m seeing a lot of posts about “no sound” recently, and I have to wonder how many of those are caused by chipset configuration order.

And by the way, I don’t see any mention of sound card order at this page:

SDB:AudioTroubleshooting - openSUSE

Its always been a pet peeve of mine that users left Linux too soon, as their sound did not work. I recall when I first installed Red Hat on my Compaq LTE5200 laptop (back in 1998) the two most important things on my agenda were to get internet functioning and get sound working. Increasing the resolution of X was actually the 3rd item on my list of things to do.

Hence in part to address this pet peeve of mine, over the years I have focused more and more on trying to help users with basic sound issues.

Actually, the number of requests for sound help on 11.2 are SIGNIFICANTLY less than for any other SuSE/openSUSE release since … well possibly since 8.2 ? … Certainly the least I have seen since 9.3 when I started being active in the community to help users with their sound. I would venture with 11.2 we are seeing possibly 1/10th the requests for help we normally get for sound. OpenSUSE-11.2 with 2.6.31 kernel, which has alsa-1.0.21 in the kernel, has the best hardware detection of any openSUSE to date, and in the case of KDE, pulse audio is disabled by default.

Thats because I wrote that wiki page, and I have only one sound device, and do not know enough to write about more than one sound card.

I raised the possibility to my wife last weekend, of buying a second sound card for one of my 3 PCs that are under my desk, and my wife looked at me like I was coming from Mars !! :open_mouth: … then she dug into our old PC part storage, and thru a 10 year old serial PCI card at me, where that serial card also has some sort of sound device on it. She said, try that on for size.

< sigh >

So I now have an extra sound card. Darned if I know what it is, nor do I know if it works. Maybe I’ll plug it in and see if I can get it to work, and then learn a few things.

… OR …

… alternatively you could update the wiki with a multiple sound card section. :slight_smile:

Agreed, this is a pain in the behind that new users should not be plagued with. Things have improved drastically over the years since I used SUSE 7.2, but the fact that I just stumbled on such a problem again means it hasn’t been resolved completely.

I wasn’t aware of that, I don’t usually keep track of issues posted on the forum, I usually have a trouble-free experience when upgrading openSUSE (or at least I can solve my problems on my own). I just happened to notice a lot of current posts on sound issues when I did a search before writing my original post.

It’s too bad you live in Europe. If you lived in NA, I could easily have sent you one of my spare M-Audio cards :slight_smile: They just gather dust, but I know they’re well-supported under Linux.

ugh, you mean I actually have to put EFFORT into it? Bleh! rotfl!

Fine, I did. I added a Step 9 to your Audio Troubleshooting page: SDB:AudioTroubleshooting - openSUSE

Many thanks!

I’ll test it out when I finally get around to putting that old PCI serial/sound card (that my wife thru at me) in one of my PCs. :slight_smile:

“Step 9” to the “Audio Troubleshooting” page fixed my same exact problem with the M-Audio Audiophile 2496, thanks :slight_smile: .

Sweet! My contribution helped someone. I feel all tingly inside… :open_mouth:

I finally got around to installing this ancient sound PCI (not PCI-e) card (that my wife dug up) into my Sandbox PC which is a 9-year old 32-bit AMD Athlon-1100 w/1GB RAM (on a MSI KT3 Ultra motherboard) w/AGP nVidia GeForce FX5200 graphics and a VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (with a Realtek ALC650D hardware audio codec). This PC is running a 32-bit openSUSE-11.2 with KDE-4.3.4 and pulse audio disabled.

After installing the card I went to YaST to configure it. The additional ancient PCI card was identified by YaST as a soundblaster 128 !! (is that old or what ?? ) … and the diagnostic script as an Ensoniq AudioPCI ENS1371 with a mixer name SigmaTel STAC9721,23. The test sound under YaST worked.

I note the diagnostic script output here:
http://www.alsa-project.org/db/?f=43ab971d2cd062d8906dc49549701c8606ede9c3

The /etc/modprobe.d/50-sound.conf file looks like this:

options snd slots=snd-via82xx,snd-ens1371
# Ssy1.64FfyKPAr1A:VT8233/A/8235/8237 AC97 Audio Controller
alias snd-card-0 snd-via82xx
# H0_h.F2uWXyTiEa3:Creative Sound Blaster AudioPCI128
alias snd-card-1 snd-ens1371 

Where snd-card-0 is my motherboard sound, and snd-card-1 is the recently added ancient sound blaster.

Here is what YaST shows for my mother board card:
http://thumbnails3.imagebam.com/6060/d3329f60590135.gif](ImageBam)
and its mixer settings in kmix:
http://thumbnails7.imagebam.com/6060/b3954c60590130.gif](ImageBam)

and here is what YaST shows for my second card:
http://thumbnails23.imagebam.com/6060/355c1b60590121.gif](ImageBam)
and its mixer settings in kmix. Clearly I’ll have to add some more controls.
http://thumbnails10.imagebam.com/6060/da21fe60590143.gif](ImageBam)

… continued …

… continued from above …

Since my motherboard sound device (the Realtek ALC650D) is still supplying sound to all my applications I thought I would check out what is involved in my using my secod PC card to play some apps. So I then went to smplayer and noted this setting:
http://thumbnails24.imagebam.com/6060/8139b060590148.gif](ImageBam)
so I selcted the “Ensoniq Audio PCI” (which is the Sound Blaster PCI 128) and sound came out of the speakers connected to this PCI card. I then launched vlc and played a song, and had sound come out of my motherboard speakers with vlc at the same time as sound coming out of my PCI card with smplayer.

Pretty neat.

This is no where as difficult as I had believed based on reading some of the user troubles. But I confess I have not tried anything difficult yet. Next I’ll try making my PCI card the primary audio device, so as to get sound from firefox … etc … coming out of that card as opposed to out of my PC’s motherboard.

Your post was most helpful and it helped give me confidence in my testing.

For NNTP users, I had those links backward, and had to edit them. The are correct as quoted above.

Wow, that’s really old. Over 10 years old! I had one of those back in '99 and it wasn’t new then. It’s technically not even a real Sound Blaster, it was Ensoniq’s old **** after Creative Labs bought them. Terrible for professional audio work, but it was dirt cheap compared to a Sound Blaster Live! (which I also owned at the time and still have today).

Indeed, it is a very old card. I can not recall if we obtained it from an old dead PC of some friends, or from the first PC I purchased when I moved to Europe in the 1999/2000 timeframe.

Following puregore’s guide, this turned out to be very easy. I went to YasT, deleted the mother board sound device, which deconfigured it - which automatically moved the SoundBlaster (Ensoniq card) up to snd-card-0. I then selected edit on the now unconfigured motherboard sound device and it was re-assigned as snd-card-1.

I note the /etc/modprobe.d/50-sound.conf file now looks like this:

options snd slots=snd-ens1371,snd-via82xx
# H0_h.F2uWXyTiEa3:Creative Sound Blaster AudioPCI128
alias snd-card-0 snd-ens1371
# Ssy1.64FfyKPAr1A:VT8233/A/8235/8237 AC97 Audio Controller
alias snd-card-1 snd-via82xx

where I note snd-card-0 and 1 are now swapped from the previous occasion when I looked at this file. It makes me think I could probably just do a hand edit to the file to create this change and then restart the sound system to obtain the same effect as YaST.

Anyway, in my test my applications now use the PCI sound card, and firefox now uses the PCI sound card (and not motherboard sound device).

Its very straight forward.

Editing the configuration file would definitely work. But someone who knows about editing configuration files would probably not have had any issues to begin with :slight_smile: Years ago, I always edited configuration files. But openSUSE has slowly broken me away from that habit and now I rarely even think about it.

What’s unfortunate is that there are a bunch of places to edit sound card preferences, but none of them do everything. Changing Phonon preferences in KDE4 is very convenient and flexible, but it only affects KDE4 apps. Changing sound card preferences in YaST (or editing configuration files) works for everything, but is far less flexible than Phonon. I haven’t used Gnome in a while, but I assume it has its own PulseAudio-related configuration which only works with PulseAudio enabled apps. I can see a newbie who picked KDE4 as his DE going into “Configure Desktop” and trying unsuccessfully to get his sound working.

None of this is a very big deal when a user only has a single sound source, but as I mentioned in previous posts, many video cards today include a sound chip for HDMI output, so more and more systems have multiple sound chips without the user realizing it. And for me, the HDMI sound output was given precedence over my PCI sound card, which made things even more confusing.

It’s not necessarily an openSUSE deficiency, it’s a problem with Linux and DE’s as a whole. But it’s still unfortunate and frustrating for new users (and even not-so-new ones like me).

I also have a separate openSUSE-11.2 gnome / and /home partition on this test PC. I need to boot to it, and play with its audio next (with these two sound devices). I’ll give that a try later this week.