m.2 ssd disappears from Asus bios after opensuse install

TLDR: Want to install OpenSuse on separate m.2 NVME SSD and choose my boot disk at bios (f8) instead of duel boot. After installing Opensuse to m.2 NVME, the m.2 NVME SSD no longer appears in my bios. Like it has been uninstalled. Disk Management in Windows 10 can see it. If I completely format the drive in windows 10 using command line, the drive shows back up in bios.

I have been searching online for hours and am a bit frazzled but it seems like I am missing a setting somewhere or my bios is jack-balled.

What I have
Asus M5A97 r2 latest bios installed - https://www.asus.com/us/Motherboards/M5A97_R20/

My current setup:
Windows 10 on Samsung SSD

Samsung SSD 500GB via SATA port 1
Toshiba 3TB via SATA port 2
WD MyBook via USB3.0 (external)

What I want to do.
Purchased Samsung Evo 500GB M.2 NVME and pluged it in using an adapter ( https://www.newegg.com/Product/Product.aspx?Item=N82E16815124167) to a PCI-E slot on my motherboard.

I have wanted to install suse for a while, I used to use it a few years ago, but I have a lot of work related stuff on my windows 10 hard drive. I read somewhere where a guy installed a linux distro on a seperate harddrive installing GRUB on the new drive and then let his windows install stay default through his bios settings, then using the bios shortcut key to to select the boot drive when he wanted to go into the linux install. That sounds like a perfect setup for me as I have had many issues with duel boot in the past, and would like to keep Windows 10 chugging along.

I install the new ssd, windows 10 and my bios see it. I have not changed any bios settings. I make a usb boot drive for opensuse. It sees all my drives and I install everything to the NVME drive with grub being installed on that drive as well.

When its done I reboot and now the bios simply does not see the new NVME drive. I turn secure boot to off but that has no effect. I then have to use the bios to override boot into my windows 10 drive. There sits the NVME drive, with the partitions OpenSuse made, but bios does not see it. I have read online time and time again with people having issues with installs but could not find anything like my setup. I found a couple of Opensuse examples with similar setups (normal SSD) and tried to follow them but the **** drive disappears every time.

I only have a few settings dealing with UEFI boot settings and I am not sure how to tell if windows is installed using UEFI or legacy bios. It was a Windows 7 uprade to Win10.
When loading the OpenSuse iso to Rufus I have used the default setting (MBR partition scheme for BIOS and UEFI) and tried GPT partition scheme for UEFI. But maybe I should try MBR scheme but I am not sure.

I feel I am stuck at this point and not sure where to go. I am not super tech savvy so maybe this is over my head a bit.


Despite your efforts to being detailed,
You’re not clear how you determined your BIOS can’t see your openSUSE after the install and reboot… Did you boot directly into the BIOS (if in legacy MBR mode or did you reboot into UEFI “advanced setup” mode) or are you saying this because of something else?

If this is truly something related to the BIOS not seeing the drive (IMO unlikely) then your Q might best be posed to ASUS.

Have you considered creating a separate boot partition on your primary drive (with Windows on it) which then points to either OS? Perhaps your system is setup to look for bootable partitions only on the primary drive.

And, frankly I see little difference between a multi-boot and what your BIOS may or may not support… The only diff to me is whether you have a chain-loader in front of your two OS or not.

If you want to avoid multi-boot altogether, I’d recommend you take a look at virtualization. There are some slight differences between running a virtualized OS vs installed directly on physical hardware(Primarily apps that require direct hardware access for performance like FPS games or pen testing) but for most uses there is no difference. In other words nearly all the benefits with zero problems related to multi-booting.