lxqt from tumbleweed does not start

I installed following packages from tumbleweed -


I have been using plasma 5 session which works. I can see the lxqt session in the DM login screen. When I select lxqt session, desktop does not start, I cannot see any messages. Screen blinks and returns to DM login screen. DM is KDM.

And what distribution are you using?
If you use Tumbleweed you’d better have posted to the Tumbleweed forum.

If not, this is probably a qt5 version conflict, i.e. the packages are built against Qt5 from Tumbleweed and you likely have a different version installed.

I also have openbox installed, which also appears in the DM login screen. I can log in to openbox itself but cannot do anything because KB doesn’t work and pointer clicks do not work so I have to ctrl-alt-backspace out. The mouse pointer stays on the windec and so all I can do is move the first window I open.

started with base of 13.2, switched to tumbleweed. Only repo is tumbleweed oss and packman. So Qt5 and lxqt are both from same repo.

I’d appreciate if someone can move this thread to another forum as applicable.

Well, try to run some lxqt application (lxqt-panel maybe?) in an xterm in a different X session. Do you get an error?

Or even try to start lxqt itself in a minimal X session (IceWM, twm), via “startlxqt”. You hopefully should see what the problem is then.

I started openbox session, opened xterm and ran lxqt-config and lxqt-panel. Both worked fine ( they also work from KDE). startlxqt gave segmentation fault.

In openbox, if I open kconsole and happen to move the cursor anywhere on to the decoration, the cursor remains trapped there and I cannot do anything except kill the session with CAB. This doesn’t happen with xterm.

more info -

I decided to debug the script startlxqt with ‘bash -x’ and found the following -

It segfaults at the last line namely, “exec lxqt-session” .
So I ran lxqt-session from xterm without any issues, it even displays the suse welcome screen.
Next, I ran exec lxqt-session from the xterm and it still worked fine.
when I run startlxqt, I get segfault again.

So apparently something else the script does before running lxqt-session (like setting some environment variable) causes the crash.

I would comment out the other lines one by one to see which one it is.
This might get us closer to the actual issue…

Or try to run lxqt-session in gdb (inside the script, instead of “exec”) to find out why it crashes (“bt” should show where exactly the crash happens).

I tried lxqt myself now in my Tumbleweed VM, and my first suspicion was actually true… :wink:
It is indeed a Qt5 version conflict:
The lxqt platform plugin for Qt5 (package lxqt-qtplugin) is still built against Qt5 5.3.2 (build date 15th of November), while Qt5 has been upgraded to 5.4.0 in Tumbleweed already.

Uninstall lxqt-qtplugin (or comment out/remove the line ‘export QT_QPA_PLATFORMTHEME=lxqt’ in /usr/bin/startlxqt) and it should work.
When the package is rebuilt/updated the next time, the problem should be gone.

true, that fixed it. I actually like lxqt - it is fast, functional and even KDE apps start up faster from lxqt than from KDE. I can switch to it full time if it had a networkmanager applet- that is the only missing item that is a showstopper. Also, I am unable to create desktop icons- nothing happens after I try to create them. Of course, that is not a showstopper as the menu and terminal are available to launch apps.

Well, you should be able to run “nm-applet” I think.

For the record:
lxqt-qtplugin has been updated meanwhile (a week ago already actually), and lxqt indeed works now also when it is installed.