LXDE on openSUSE 11.1


I have a problem installing LXDE on my machine, I tried to install it from the repositories zypper ar Index of /repositories/X11:/lxde/openSUSE_11.1 X11_lxde then from console zypper in -t pattern LXDE, the output was:

Do you want to reject the key, trust temporarily, or trust always? [R/t/a/?]: a
Building repository 'X11_lxde' cache [done]                                    
Retrieving repository 'devel:languages:perl' metadata [done]                   
Building repository 'devel:languages:perl' cache [done]                        
Loading repository data...                                                     
Reading installed packages...                                                  
'LXDE' not found.                                                              
Resolving package dependencies...                                              
Nothing to do.                  

Then I tried to install the package with yast and received this error message:

nothing provides lxdm needed by lxdm-conf-0.2.0+svn727-20.1.noarch

After that I went to software.opensuse.org: Search Results and installed “lxde-common-branding-openSUSE” and “lxde-common” everithing went fine, after that I tried to install the “LXDE [Software collection]” package and received the same error:

nothing provides lxdm needed by lxdm-conf-0.2.0+svn727-20.1.noarch

I googled for this problem but I did not found anything.

Thank you in advance.

lxdm won’t work on 11.1 anyway…
Install it without lxdm-conf.

I don’t think that lxdm-conf should be with 11.1…I’ll check that.

It`s on the official opensuse web page LXDE - openSUSE, for openSUSE 11.1/ 11.2/ 11.3

Oh boy, there seems many info been lost in the wiki transfer.
See LXDE/Applications/lxdm - openSUSE

LXDM won’t work without having patched /etc/init.d/xdm

I don’t know if for that reason LXDM is not included in the 11.1 repo and lxdm-conf unintentionally was kept. I just wrote to the packager…

But if you look at https://build.opensuse.org/package/show?package=lxdm&project=X11%3Alxde it’s definitely disabled. Do lxdm-conf should be too.
You can either install LXDE without lxdm-conf now or wait a little bit before either LXDM has been republished or LXDM been disabled, too (then the insstallation should work 100% automatically again ;))

Thank you very much for this quick response, I will wait until it`s fixed.

Danke schon! :slight_smile:

You’re welcome (gern geschehen ;))
But this might take a day or so. I don’t know how busy the packager is.
If there’s any news, I’ll let you know.

I think this should be “fixed” now.

It working fine now, thank you for your help!!