lxde - no menu bar :(

I installed the lxde desktop throught yast and managed to get it started, but there is no menu bar or system tray.

There must be something missing, anyone know what?

Thanks :).

repo X11:lxde or home:anubisg1:LXDE ??

what about if you run "lxpanel " form terminal

I used the X11 repo.

When I run lxpanel, it says that a copy is already running, although I see nothing but desktop icons and the LXDE wallpaper on the screen!

Right click on the desktop does nothing, left click does nothing either.

I can run the icons from the desktop, but they all open without window borders.

You could be using the other repo. I’m using anubisg1 and so far so good.

I want to switch to anubis’ repo. I searched the other thread but can’t seem to find the repo information.

Can you supply the repo information please?

I should also maybe add that I start lxde with startx, I don’t use a login/display manager because this is to run on my server as a lightweight desktop if/when I need to use one.

I start lxde by creating a ~/.xinitrc file with these contents -

exec ck-launch-session startlxde

…if that makes any difference :).

I found anubis’ repo, added that, removed the other version of all lxde stuff and installed the anubis version.

I then deleted all the relevent lxde stuff in ~/.config/ and started lxde.

I got my right click menu back again, but still lxde is not being used properly.

Still no menu bar, and I still get the “lxpanel already in use” message when trying to start it from an xterm.

There are still no window borders, so I can’t move anything around the screen.

But the background pic is pretty :).

Not very familiar with lxde. I just started using it for a week or two, but as a guess it looks like a WM issue. try running “openbox” command and see what it does.

Thanks conram, I installed openbox and that now gives me the WM stuff (window borders, right click menu, and logout control), that just leaves the main menu bar and taskbar to get working :).

There were updates to lxde, and after doing those and installing a few other things I thought might be related, it has now started working properly.

I have no idea if it was the updates or the extra stuff I installed though.

sorry for late i wasn’t at pc.

yes, you must have openbox in order to run LXDE :slight_smile:

btw, to install ALL dependencies, you may want to check 1-click available here:


Thanks for that anubis, I’ll use that in the future :).

Might I suggest to solve the dependency problem by creating a “meta package”? It would be an empty rpm, with maybe a simple text file in it, but calling all other needed rpms as a dependency?

Not sure how to do that myself, and not sure that the .rpm format can handle that either, but it would be a neat idea to solve all the dependency issues.

That’s one thing that is sadly missing from openSUSE, something that Debian seems to have over us, they can simply create a “Meta Package” which does all the work and saves hours of messing with dependencies.

But anyway, LXDE is a great desktop, thanks for all the work you put into it, I certainly appreciate it :).