LXDE factory upgraded rpm failures on 11.2

Having successfully installed LXDE by pattern from repo Index of /repositories/X11:/lxde/openSUSE_11.2 onto a default 64bit Gnome system and updated, I added the following LXDE Factory repo:Index of /repositories/X11:/lxde/openSUSE_Factory.

Installed LXDE packages were upgraded to factory releases, but those that threw up dependency errors were avoided. On reboot, I was unable to get past the LXDE login screen, although my userid and password were accepted. I rebooted and logged in to a Gnome desktop which behaved normally, and downgraded all LXDE factory packages that I suspected may be at fault. The problem was cleared, so I re-installed those factory packages one by one, each time downgrading the failing package and testing that the problem was removed. These are the x86_64 packages that failed:

lxsession 0.4.4-22.2 Caused the system to appear to hang at the login screen. Reboot required.

lxpanel 0.5.5-24.2 Could login to LXDE, but without a panel on the desktop. Opened a console with Ctrl-Alt-F1 where I found the following error message:

Error accessing systemtap module preloadtrace: Operation not permitted.

libmenu-cache1 0.3.2-17.2 Could login to LXDE, but with unpopulated start menu, except for “Run” and “Logout”. There was no message on the console. The problem could only be cleared by also downgrading the package: menu-cache 0.3.2-17.2, although it didn’t give a problem when upgraded alone i.e. without libmenu-cache1.

I hope this may assist any user upgrading 11.2 LXDE from Factory, and indeed the openSUSE LXDE developer. BTW I did not have these problems upgrading 11.3 M4 LXDE from the same factory repo. :wink:


let see, 1 step at time.

i guess you moved from here http://download.opensuse.org/repositories/X11:/lxde/openSUSE_11.2 to http://download.opensuse.org/repositories/X11:/lxde/openSUSE_Factory because you moved from suse 11.2 to suse factory (next 11.3) or everything will be INVALID because packages in http://download.opensuse.org/repositories/X11:/lxde/openSUSE_11.2 ar built against factory, that means opensuse 11.3 miulestone 5.

menu-cache issue… i really believe there was something wrong with files…

i noticed sometimes that when i upgraded some rpms the files was deleted and not replaced, never understood the reason…

i guess that if you re-install the packages you should solve, if not do the following:

check the files exist:

(rpm -ql rpm_name)

than in case of library please compare ldd of the libraries from new and from the old rpm.

about lxpanel i really have NO idea at all… looking on google it looks not to be “our” problem, but something related to kernel (preload package) or Xorg itsealf…

about lxsession i cannot debug without more informations… like .xsession-errors content or shell output or a gdb backtrace… sorry

on fresh installations i never had those issues any way…

Hi anubisg1. Thank you for finding time to respond. Normally I don’t upgrade installed releases from Factory. In this case as it was a relatively small number of packages, I decided to experiment.

Yes, I only upgraded those installed packages that were originally sourced from the first repo (openSUSE_11.2), and the upgrades were sourced from the second repo (openSUSE_Factory). About 3 to 4 packages (lxde factory) threw up dependency errors so I didn’t upgrade those. The rest upgraded without issue, and I rebooted. The reboot failed on LXDE login. Through “trial and error” testing, I was able to isolate the 3/4 upgraded packages that gave problems with the desktop. I did successfully reinstall (downgrade) the 11.2 versions of those four packages and the system then worked ok.

I expected more problems than I actually experienced. So yes I am running a mixture of lxde 11.2 and 11.3 packages, and the results are generally good. On a separate partition, I have LXDE M4 with lxde packages subsequently upgraded from the above Factory repo, with no issues or dependency problems.

Thanks for your comments and suggestions, from which I learn more and will try to provide more useful info where needed. :slight_smile:

according on what you wrote that “bug” can be closed as “INVALID” because you will of course have more and more problems… let me explain

  1. there is NO lxde-factory

    the repositories provides the SAME packages built on different suse versions (11.0, 11.1, 11.2, Factory (actually 11.3) )

  2. you can NOT install packages built on different versions of the distro, without expect those kind of problems. let me explain the reason

on linux we build on 99.99999% of times with “shared” libraries, and binaries are than linked to libraries (and such libraries are NOT into the binary)

you can check how a binary is linked using “ldd”

anubis@suse-netbook:~/Dropbox/esonero> ldd /usr/lib/menu-cached 
	linux-gate.so.1 =>  (0xffffe000)
	libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xb7802000)
	libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb77bf000)
	libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb76f8000)
	libc.so.6 => /lib/libc.so.6 (0xb7598000)
	libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb7592000)
	libresolv.so.2 => /lib/libresolv.so.2 (0xb757c000)
	libselinux.so.1 => /lib/libselinux.so.1 (0xb755e000)
	libpcre.so.0 => /lib/libpcre.so.0 (0xb752f000)
	/lib/ld-linux.so.2 (0xb78c9000)
	libdl.so.2 => /lib/libdl.so.2 (0xb752a000)

different versions of a distro provides usually different version on libraries (usually newer as newer is the distro version)

because of that you have several problems if the library is not found or simply provides different simbols…


the repo

Index of /repositories/X11:/lxde/openSUSE_Factory


if you are using openSUSE_Factory (that again, now is openSUSE 11.3 Milestone5)

in the same way, the repo

Index of /repositories/X11:/lxde/openSUSE_11.2

MUST BE USED ONLY with openSUSE_11.2

your problems will not be fixed (and CAN NOT be fixed).

please use the proper repositories according to your distro version…


The repository mixup may be due to some bad advice I gave consused. Mea Culpa, and my apologies.

Normally, I understand what the repositories provide for each openSUSE release. However I was mistaken in thinking that LXDE was an exception. Thats my fault and nobody else’s as I should have checked. :shame:

As I said previously, I did expect more problems from using a factory repo anyway. I CAN, but perhaps I SHOULD NOT. :wink:

Andrea, thanks for the explanation on libraries and the tip with ldd.

I understand the points you are making about packages and repos, However, I wasn’t expecting those problems to be fixed. Sometimes we post information so that other users may avoid the issues, or just to share the information. I assume real lxde “bugs” should be reported in the normal way. Sorry if you were inconvenienced.

That’s decent of you, but my mistake as I should have double-checked. :slight_smile:

Actually, I now realize that the mistake I made was to assume the repo Index of /repositories/X11:/lxde/openSUSE_11.2 to be static, rather like distribution repos “oss” and “non-oss”. Although knowingly risky, I added the factory repo for some application updates, since that Gnome/LXDE partition is for testing only.

However while using Yast to downgrade from the factory rpm’s, I now noticed new update(s) in the lxde-11.2 repo. Well, Gnome’s version of Yast presented it as Update. :wink:

I’m running LXDE now on 11.3 M5 - its nice. There are hiccups (installation of M5 was painful) but thus far the hiccups appear to be 11.3 M5 system, as opposed to LXDE specific.

I have a lot more testing to do.

Just tying off loose ends here. Have been looking at how released Gnome and LXDE co-exist on same 11.2 install (64bit), since I never tried 11.2 Gnome. As far as 11.3 LXDE goes, I will be testing more of that, and will post in your own LXDE thread (or in newer ones).