LXDE changes qinternet display on different monitors

Hello list, moderators,
The following describes odd behavior in my opinion, but I’m not sure where this question belongs. How can a monitor affect the loading of application SW? Can I get some help to fix the following problem here?

I installed lxde on a P3 with a Gem 17" CRT monitor. LXDE runs on top of opensuse 11.4. On a P4 box I installed kde with 11.4, both from the same DVD. The P4 OS was installed using Vivitron 1776 17" CRT monitor.

Both boxes use qinternet for connection to DSL. Qinternet is set to autostart and its icon displays in the taskbar system tray.

I bought a ViewSonic E70 17" CRT monitor for the P4 and put the Vivitron on the P3.

Now the P3 displays the qinternet icon in a small terminal instead of loading it into the system tray as before. Of the three 17" CRT monitors I have, only with the Gem will the P3 (LXDE) system display qinternet in the system tray.

The P4 system (KDE4) can run any of the monitors and still put the qinternet icon into the system.

Qinternet is a binary file, but if i “less” it, I can see references to kinternet, so I think it’s KDE4 SW. LXDE may be the culprit, or maybe the behavior will involve xorg. Your responses please! Heboland

The easiest thing to try would be create a new user on P3 and see if the icon is displayed properly there. If it is then You have LXDE configuration problem. If it’s not than the problem must be something else.

Best regards,

Thanks for the response, Greg,
Your advice was good. It helped expose the problem, but in my opinion, the problem was not environmental. What I found was a race condition.

Rather than making the other monitors work, the new user made the Gem monitor fail! This was because as previously a single user system, I used direct login to my account. I left that in place after creating the new user.

To get to the new user account, I had to logout of my account then login as the new user. Qinternet fails to dock into the system tray if it starts too early in the login process. To make qinternet dock on the P4 with direct login, I had prevously started it with a script that monitored smpppd.

Logging in after smpppd was already started allowed qinternet to be invoked too early. The solution was to modify the script to delay if smpppd was already running. Sleep 10 seems to work OK.

Now getting back to the other monitors that failed when the Gem worked. The bootup time using different monitors is different. A longer bootup time caused the LXDE to load after smpppd was running. Then the script invoked qinternet without a delay.

With the script mod, there is a delay executed if smpppd is already running, so qinternet docks.

One question I have is what condition to poll in a script that will gurarntee LXDE is loaded?

For example my script polls for the existence of /var/run/smpppd/control to tell if smpppd is running. Is there something similar that changes state when the desktop is loaded?

With or without an answer to my question, I think the original question is solved. Thanks, Heboland.

I honestly don’t know. You might try asking in some LXDE mailing list or report a bug on the original problem You’ve found in the openSUSE bugzilla.

Best regards,