(LXDE) Can't get auto-hibernation to work

Laptop is a Compaq N1000c but I don’t think the model is a factor.

Hibernation after inactivity does work OK in KDE4 using powerdevil.

In LXDE, neither gnome-power-manager nor xfce4-power-manager work, although both appear in the system tray? properly and can be opened normally.

Xfce4-power-manager refuses to save its settings – i.e. I can select various settings and then minimize back to the tray, then immediately open again and it is as if I had never changed the settings

Gnome-power-manager saves the settings OK does nothing when the time to hibernate arrives (after 30 minutes of inactivity or whatever).

I have switched back and forth between these numerous times. Don’t know how to run powerdevil under LXDE if it is possible.

N.B. Hibernate DOES WORK if I manually select it from the ‘logout’ icon in the tray. So the mechanism itself does work.

Anyone been able to get hibernate after inactivity to work on LXDE? I am loving LXDE – like a bolt of lightning on the old Pentium 4 after KDE.

BTW, cpu frequency control does work and everything else I can see other than hibernate-after-inactivity.

2.6.34.7-0.5-default