LXDE and xrdp cannot connect

opensuse 13.2 LXDE
Installed xrdp and tigervnc.
I cannot connect with rdp keep getting error:
VNC error – problem connecting

How to easy setup rdp with LXDE


make sure you have xorg-x11-Xvnc and if that package exists please restart the xrdp once.

openSuse 13.2 LXDE

x11vnc was installed I have now also installed xorg-x11-xvnc from https://software.opensuse.org/package/xorg-x11-Xvnc?search_term=xorg-x11-xvnc
restarted xrdp : linux-z3uw:~ # service xrdp restart
Same error vnc error-problem connecting

Have you installed xrdp from repo or Source


Installed one click with yast X11:RemoteDesktop

Most of them have posted that installing xrdp from that particular repo does not work. So I suggest you to completely remove xrdp along with config files and try installing xrdp either from ltsp repo or source.

If you want I can post the procedure here.


Removed xrdp and config files then installed xrdp-0.9.0git.1420692256-16.1.x86_64.rpm from

Same problem connecting with rdp

vnc error connecting
some problem

Did not know it should be that hard to get rdp working for LXDE why??.

Did you check the firewall?

Firewall is disabled.

could you please post the output of

rpm -qa | grep -i vnc 
linux-z3uw:~ # systemctl start xrdp
linux-z3uw:~ # rpm -qa | grep -i vnc
linux-z3uw:~ # 

Remove tightvnc and restart the xrdp service.

Removed tightvnc :

linux-z3uw:~ # rpm -qa | grep -i vnc

restarted xrdp
Unfortunately same error when trying to connect by rdp

vnc error connecting
some problem

I have tested it in a VM and it’s working for me. I don’t know what went wrong in your case.

Thanks for the support. VNC is working maybe I have to reinstall opensuse 13.2 LXDE and start all over.

If you are doing it in a newly installed machine please add ltsp and install xrdp. It works in my case. No need to install any other packages.


Did a fresh new opensuse 13.2 LXDE install.
Also installed xrdp from ltsp .
Then tried to start xrdp :

linux-utdl:/home/node3# service xrdp start
service: no such service xrdp

RDP still no working.

Are you using LXDE ?

Yes I have tested it with LXDE.

start xrdp with following command.

#sudo /etc/xrdp/xrdp.sh start