lvm2 update problem

Got the following error when trying to apply update:

Subprocess failed. Error: RPM failed: error: package lvm2-2.02.33-28.1.i586 is not installed

Here is a little more information:

there is a box that tell:
Could not remove a protected system package
Removing a protected system package is not alloed.

This is in trying to install an automatic update.