lvm snapshot UUID issue after fresh 12.3 install and old home

I created LVM snapshots of the root partition and home partition on 12.1. After that, I “installed” 12.3 over “formatted” root and not formatted home. Result (which I didn’t figure out right away) is that after I boot the system correct root is mounted and written in fstab, but incorrect home partition is mounted (there is some kind of error message during boot process). For some awkward reason, snapshot (“backup” of the home) and the origin (home) have both same UUID. When mounting, OpenSUSE is using snapshot, instead of the main (origin) drive.

I see Ubuntu folks had the same issue, but didn’t “resolve” it yet. In the meantime if you try the same, be warned (!!!), or change manually UUID of the originals (I don’t see you can do it from a boot DVD, though you may be a better luck from live CD)!!! In case you need to rollback, snapshot should have UUID of the previous system state and all references to it will still work (after eventual rollback).

Just to mention that behavior is not consistent and that drives (partitions) with same UUID will be mounted randomly (on one boot you may get one partition mounted and on the second boot other one). You may get same UUIDs for partitions if you are cloning them (with one of the tools) or creating snapshot(s) with the LVM.

Presumably that only happens if you mount by UUID. I suppose the label is also preserved. But if you mount by device-id, then you should not have this randomness problem.

I guess one could have lines for uuid and lines for device-id in “fstab”, but comment out the uuid. Then, for recovery, you would switch back to the uuid version.

UUDI is property of filesystem and origin and snapshot are by default exact copies, so I do not see anything “awkward” here.

IIRC LVM snapshots are writable so you may change UUID on snapshot. Or simply mount using LVM volume name directly.

Awkward is that OpenSUSE is mounting LVM snapshot instead of the original (regardless of the same UUID/label) and even that is not consistent behavior. I would understand if this was a regular partition clone, but not with a LVM snapshots. Also, OpenSUSE 12.3 installer decided to use UUID method of mounting, not me. If you look what others are saying (like OpenSUSE 12.3 upgradation guide – tips, tricks and tight corners) OpenSUSE 12.3 will ask you to change it on the upgrade to UUID method as well. OpenSUSE’s installer was supposed at minimum to warn me that I had two partitions with the same UUID (and thus problem) when I selected partitions during the install process.

Sounds like you should report to bugzilla about this one.

And where exactly is the bug?

Installer not reporting conflicting UUID

I am not sure if this will help you or not, but I had a similar issue I think.

I backup my sda to sdb using g4l every other week, this means that the drives and thus the uuid are 100% identical, once I upgraded to 12.2 which used grub2 I noticed that at random times sdb2 (/root on backup) would be mounted instead of sda2. I would say about 15% of the time it mounted the wrong one.

I filed a bugzilla for that and thanks to Michael Chang who took up the bug report found a simple solution

edit /boot/grub2/grub.cfg and add (of change if its already there):


I also added GRUB_DISABLE_OS_PROBER=true but that is because I have no other OS’s on this system and I did not want it to identify sdb2 as another OS

then run: grub2-mkconfig -o /boot/grub2/grub.cfg

this solved all my issues and I always got the correct sda partition mounted.

do note that fstab is using /dev/disk/by-id/

I solved mine with replacing UUID of the original partition (since rollback would work with old UUID if required for anything). I didn’t have problem with the root partition (since I formatted it during installation and it got new UUID that way). Problem with other method is that device name may not be consistent (less likely, but may happen). As I mentioned awkward is that LVM has information which one is original and which one is a snapshot and that OpeneSUSE installer (I would say even boot loader) should warn you if there are two drives with the same UUID (and UUID is being used).