LVM Luks setup not using whole storage space

I’ve recently installed tumbleweed on an Acer Swift 1 laptop which comes with 64gb of emmc storage. It is running perfectly but I’m not quite sure I’ve setup lvm correctly because it always lists 40gb of total space instead of 56gb. This is the output of lsblk:
mmcblk0 179:0 0 58.2G 0 disk
├─mmcblk0p1 179:1 0 156M 0 part /boot/efi
├─mmcblk0p2 179:2 0 408M 0 part /boot
├─mmcblk0p3 179:3 0 56.1G 0 part
│ └─cr_mmc-CJNB4R_0x53074dbc-part3 254:0 0 56.1G 0 crypt
│ ├─system-swap 254:1 0 2G 0 lvm [SWAP]
│ └─system-root 254:2 0 40G 0 lvm /var/opt
└─mmcblk0p4 179:4 0 1.6G 0 part
└─cr_mmc-CJNB4R_0x53074dbc-part4 254:3 0 1.6G 0 crypt
mmcblk0boot0 179:8 0 4M 1 disk
mmcblk0boot1 179:16 0 4M 1 disk
mmcblk0rpmb 179:24 0 4M 0 disk

In the installer I didn’t set up two separate root and home partitions, but it seems that root is only using 40gb and the other 13Gb are nowhere to be found. In gparted it lists a partition of 56.1Gb with 42gb of used space and 14gb of unused space.

You did not create a separate system-home volume (which is fine) but you forgot to tell the installer to assign all available space to system-root. So you got the default 40G and the rest unassigned. Go to yast partitioner and change the size of the system-root volume to max available. If the filesystem supports growing, then this is a matter of a few seconds.

Your mountpoints seem strange, though

Well thanks, that made it work but now it only boots in read-only mode. I can’t even connect to the internet.
I’m trying to chroot from a live media and my steps are:

  1. cryptsetup luksOpen /dev/mmcblk0p3 system-root
  2. lvscan: which shows my root partition as inactive
  3. vgchange -a -y system, “device-mapper: create ioctl on system-root-LVM-… failed: device or resource busy”

That’s how far I can get, apparently I should have used btrfs filesystem resize max /

Nevermind I fixed it. It was because I did a snapper rollback and apparently I had to do an mkinitrd afterwards.
Problem solved