LVM drive not showing up in clean 11.4 install

Hi everyone. First off, I’m new to LVM so excuse me if I don’t use the correct terminology, but what I have are two USB external hard drives joined into one drive using LVM.

I originally set this up using 11.2 and then used it for months on a system with 11.1. The LVM drive would show up in the file system as /dev/mapper/Media-Media.

I then upgraded that system from 11.1 to 11.4 using a clean install and a “minimal server” selection. Now, the LVM doesn’t show up anywhere. In the YaST disk partitioner, it shows a “/dev/Media” as being of the type LVM2 Media with no logical volumes.

What can I do to fix this?

Hmm don’t think I ever saw USB set up with LVM. Maybe the order that the devices are discovered may have some effect. How are you mounting them. Let’s see the /etc/fstab.

Back when it was working, I had the same concern regarding the order and I tried powering them on in the two different orders to see what would happen - it worked both ways.

They aren’t in /etc/fstab, but the drives are showing up as /dev/sdb1 and /dev/sdc1. Here is the output of “vgdisplay -v”:

Server:~ # vgdisplay -v
    Finding all volume groups
    Finding volume group "Media"
  --- Volume group ---
  VG Name               Media
  System ID             
  Format                lvm2
  Metadata Areas        2
  Metadata Sequence No  2
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                1
  Open LV               0
  Max PV                0
  Cur PV                2
  Act PV                2
  VG Size               3.64 TiB
  PE Size               4.00 MiB
  Total PE              953862
  Alloc PE / Size       953858 / 3.64 TiB
  Free  PE / Size       4 / 16.00 MiB
  VG UUID               6zL5KI-gOP3-iQzP-ZLe1-htcd-zNFQ-Vm1nAj
  --- Logical volume ---
  LV Name                /dev/Media/Media
  VG Name                Media
  LV UUID                Fq3Uey-VHu3-lnRK-3GRZ-9DMx-T5g2-eotqH8
  LV Write Access        read/write
  LV Status              NOT available
  LV Size                3.64 TiB
  Current LE             953858
  Segments               2
  Allocation             inherit
  Read ahead sectors     auto
  --- Physical volumes ---                                                                                                                                                                                                                                                     
  PV Name               /dev/sdb1                                                                                                                                                                                                                                              
  PV UUID               1RJSW7-Ngtu-oKyv-xThj-3nHq-fIsB-aodo6a                                                                                                                                                                                                                 
  PV Status             allocatable                                                                                                                                                                                                                                            
  Total PE / Free PE    476931 / 0                                                                                                                                                                                                                                             
  PV Name               /dev/sdc1                                                                                                                                                                                                                                              
  PV UUID               P3Q9cN-gqXx-gO2J-4Iw6-ud8s-52YJ-5wK0fH                                                                                                                                                                                                                 
  PV Status             allocatable                                                                                                                                                                                                                                            
  Total PE / Free PE    476931 / 4  

I found the solution. In “yast runlevel”, in expert mode, there is a service, “boot.lvm” that must be enabled at boot time.