luckybackup doesn't start from the widget but start from konsole

on my Laptop=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz: OS=leap15.0 DE=plasma 5.12.5 KDE frameworks=5.45.0, KDE applications=17.12.3, Kernel=4.12.14-lp150.12.13-default, no nvidia drivers
and same laptop with OS=leap 15.0, DE=plasma 5.13.4, KDE frameworks 5.48.0, KDE applications 18.07.80, Kernel 4.12.14-lp150.12.13-default, no nvidia drivers.
if I launch luckybackup (superuser) from the widget in the panel and in the lizard I can insert root password but it doesn’t start
if I put in konsole the same command taken from the widget properties it start but gives these errors:

pla@pla-3-ST:~> xdg-su -c luckybackup
libGL error: unable to load driver:
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau

what I can do to start luckybackup (superuser) from the widget??

A laptop with both Intel and NVIDIA GPUs is call Optimus and requires Bumblebee. Not sure why Luckybackup is insisting on the NVIDIA driver though:\

my laptop has only nvidia board, no intel board, before to upgrade to 15.0 I had nvidia drivers installed, now not yet, may be this?? luckybackup remember the old configuration?

just about all Intel consumer processor today have a built in GPU. Show lspci | grep VGA

BTW does it work if you just run it with user permissions?

pla@pla-3-TW:~> lspci | grep VGA
lspci: command not found

this CPU=i7 Q 720 is more close to yesterday than today :slight_smile:

yes, luckybackup with user permission works clicking on the widget

You must be root to run lspci

maybe sudo lspci | grep VGA

pla-3-TW:~ # lspci | grep VGA 
01:00.0 VGA compatible controller: NVIDIA Corporation GT218M [NVS 3100M] (rev a2)
pla-3-TW:~ # 

Well look like that is an older system I believe that the current NVIDIA driver would not work with that chip set either.

In any case if Lucky backup runs ok as user I’d guess it is not a graphic problem. You mention running from a “widget” Not sure what you mean by that?? ie is that a menu? or an icon or something else???

Is this an upgrade or a new install?

For what it is worth it runs fine here as root but I’m still on 42.3. Also I only normally run it as user since I don’t believe in backing up OS’s just data

…nvidia driver worked until 42.3 with version G03

is the icon that you find clicking on application menu and in the search space insert “lucky”, appear two icons one is luckybackup the other is luckybackup (super user) and right clicking on it you can “add to panel”, both don’t works

upgrade from 42.3

…me too started to use as user and only for data, but, it didn’t worked well, I don’t remember well but it was related at it didn’t save and remove all the files, I also asked to the mantainer and after some try superuser was the only way that it works fine