LTSP and 13.1 has anyone been successful?

Installed LTSP, via, and it did install. It doesn’t work that well, like trying to build a client. The directions also leave a lot to be desired. with that said, has anyone been successful?

I’m looking at a solution using this and raspberry pi’s via the raspi-ltsp project (which is going to force me to spin up an Ubuntu VM sick)

Does anyone have any experience? The clients would be connecting over the internet and not via the local lan.

I’m curious about how this works and I will try to play with it over the weekend and let you know if i’m successful and then we’ll go from there.

The SDB is very old… It’s last contribution was a year ago, and the text references openSUSE 12.3. At least it appears that the LTSP project is actively maintained, although there aren’t many, there are several code contributions this year (2014).
Until/Unless someone else posts, recommend you try the official LTSP documentation
Note also that the SDB references another page to setup networking. Skimming the following page, the instructions look reasonable and likely still relevant with current versions of YAST and openSUSE.

If you run into some specific issue, someone can recommend a suggestion.


Raspberry Pi does not use distributions LTSP images as they are x86 or x86_64 and R-Pi is ARM. Use BerryTerminal to set up R-pi as LTSP client.

Follow this to set up LTSP server openSUSE:

Apologies for dropping out… after the project became too difficult i just installed openvpn on suse 13.1 using ddwrt (netgear hw) clients. This solution works ok and I am even sending SIP through it (because ISPS like installing SIP ALG’s and the only way around it is to VPN).

However, I think more than ever now a true Middle client (not truly thin and not truly thick) could be a very useful endeavor. Similar to the chrome book model… but bypassing google’s lord of all mentality and being self hosted. I installed and tried many many projects. Opensuse Kiwi-LTSP was actually working, without any effort from my self. a PXE boot revealed this as I was surprisingly presented a login screen for Kiwi-LTSP after mistakenly booting via PXE on a laptop. However i have, what i think, is an older version of LXDE being presented. I’m also missing the kiwi menu from easy-ltsp and could find very little reason as to why (yes I have installed the kiwi prebuilt images).

All in all I think there is an opportunity there to build an opensource project with a wider scope than teachers in a classroom.

Well, I tried to run LTSP on 13.2. Man, nearly went nuts. I tried the Education Li-v-e DVD. No dice. Tried from scratch. No dice. I was able to make several working systems at other work places with older distros. Too bad, I don’t have access to those places now. Now, I’m getting ready to try Leap 42.1. Gaaaack! Need beer, more beer…I wonder if the Leap 42.1 will work. Any old lizards out there have any idea if LTSP is still operational? I want to do something big for a school…

Master Rod

FWIW the openSUSE repos for LTSP were updated very recently (within a couple months as of this writing) supporting 13.1, 13.2, 42.1 and TW, and it looks like builds exist for both 32-bit and 64-bit.

To add

zypper ar -f LTSP:_13.2 

LEAP 42.1

zypper ar -f LTSP:_LEAP

Then, install (You can search and browse the repo)
You will find not only packages for ltsp itself but packages containing ltsp documentation.

Good Luck,