LTE modem on Dell Precision 3510

HI,

i’m new to Suse and managed at last to install it on my Dell.

Other stuff is working, but DW5811 (wwan0) is present but not usable. any help, how can i use this connection? any GUI to use it?

i found settings on “Gnome Nettool” but it wont let me start this service. I know this might be just a stupid thing from my side, i have used debian before, but Suse is new to me…

Kari

Welcome to OpenSUSE and to the Forums! Since you reference Leap 42.TWO, please be aware that this version is currently in Alpha3 test, so if you found a bug please file a bugreport.
Apparently you are using Gnome? Check with System Settings (click on the upper right corner, select button with tools), select Network, you should see all recognized peripherals.
If your DW5811 has an odd switching mechanism, it might need special commands to expose the modem.
Maybe that Snapdragon chipset is not yet supported. Please confirm your OpenSUSE version and Desktop Environment meanwhile.

Can you please confirm if you really are using Leap 42.2 (as opposed to 42.1)?

Some of these embedded 4G devices are connected to the usb subsystem, so this might confirm chipset and driver for us

usb-devices
  • Just the output block pertaining to your LTE device please.

You mentioned that wwan0 device node exists, so that is a good sign that it is supported by the kernel (assuming that I understood your initial staement correctly). You can confirm with

/sbin/ifconfig

Have you tried configuring with NetworkManager? That is how I used to manage my 3G connectivity in a previous HP laptop I had with device inbuilt device. (Very useful for field work.)

You are right - it is 42.1, my mistake.

usb-devices

T: Bus=02 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#= 2 Spd=5000 MxCh= 0
D: Ver= 3.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 9 #Cfgs= 1
P: Vendor=413c ProdID=81b6 Rev=00.06
S: Manufacturer=Sierra Wireless, Incorporated
S: Product=DW5811e Snapdragon™ X7 LTE
S: SerialNumber=LF61251160011013
C: #Ifs= 5 Cfg#= 1 Atr=a0 MxPwr=504mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
/usr/bin/usb-devices: rivi 79: printf: c: virheellinen luku
I: If#= 0 Alt= 0 #EPs= 1 Cls=02(commc) Sub=0e Prot=00 Driver=cdc_mbim
/usr/bin/usb-devices: rivi 79: printf: d: virheellinen luku
I: If#= 0 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=02 Driver=cdc_mbim
I: If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
I: If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)

/sbin/ifconfig or Network Manager wont see it.

Gnome nettool says it’s unknown device and YaST2 let’s me configure it when i change to Wicked-service instead of the Network manager. Modul (Kernel?) is cdc_mbim.

Thanks for any help…

Kari

Yes, that confirms that a supporting driver is loaded. (It appears as an ethernet device to Linux.) You mention that no device node is reported by ‘/sbin/ifconfig’ but that YaST detected the device and you could configure it? The following command will show all available network interfaces (active or not)

/sbin/ifconfig -a

wwan0 Link encap:Ethernet HWaddr 76:35:28:B0:39:3A
BROADCAST NOARP MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

there…

Please use CODE tags enclosing output when replying (refer to the ‘#’ icon in the editor). What happens if you try to activate (as root) using the following?

ifup wwan0

You could watch kernel output before doing the above in a separate terminal window

dmesg --follow

or wicked

journalctl -fu wicked

You mentioned that you had configured the device via YaST. Please show the ‘/etc/sysconfig/network/ifcfg-wwan0’ configuration as well.

It skips this command, as network manager is controlling device.

ifup wwan0
maenkar@WL-FH5DR72:~> sudo ifup wwan0
maenkar: Network is managed by 'NetworkManager.service' -> skipping

dmesg --follow
Nothing… as it’s skipped

wicked
this one says (when used as service instead of Network Manager) “wwan0 setup-in-progress”



"/etc/sysconfig/network/ifcfg-wwan0"

BOOTPROTO='dhcp'
BROADCAST=''
DHCLIENT_SET_DEFAULT_ROUTE='yes'
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NAME='DW5811e Snapdragon™ X7 LTE'
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'




Thread title prefix changed to LEAP 42.1

Right, but I thought you mentioned earlier that you were using wicked. If you’re using NetworkManager, then you need to configure the device via the NetworkManager GUI (front-end) first.

wicked
this one says (when used as service instead of Network Manager) “wwan0 setup-in-progress”

So it never actually completes?

Try changing back to wicked (via YaST), then see if you can activate the interface successfully as per post #7. Examine the output as described there.

I tried that also, it wont do the setup.

Network Manager wont see it at all (GUI), Gnome Nettoool sees it - but changes wont affect it. When changing the service in YaST to Wicked, i can change parameters, but “setup-in-progress” stays as the status for all devices.

i guess it’s something i did wrong earlier, maybe a fresh install will help?

there was also another thing, not network related, vmmon (vmware monitor) is crashing sometimes.

Kari

No, not a configuration mistake or any thing like that. It’s likely that the device requires additional support from ModemManager to be handled correctly I guess. More research/time needed…

there was also another thing, not network related, vmmon (vmware monitor) is crashing sometimes.

Kari

You’ll need to start another thread for that particular issue.

Ok, some searching turned up these bug reports describe the same issue with this hardware

https://bugzilla.opensuse.org/show_bug.cgi?id=975211
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=828820

The Debian bug report linked to this Ubuntu bug report where it looks like some work was done to gain support for some of these LTE broadband devices.

In general,
Anyone who wants to use their phone or other mobile device as their “modem” should first look at the device’s capabilities as a Mobile Hot Spot, most or many Android phones sold after 2012 should have this capability but of course any feature can also be disabled by the phone’s carrier (All carriers modify and customize the Android that’s installed on devices that are designed to run on their systems).

The reason is that a Hotspot configuration is simple and only involves configuring ethernet.
If you try to configure any other connection including serial connections (RS-232 or bluetooth usually), then they <may> involve still running ethernet over serial, or they might be only serial (I haven’t seen that for about 15 years).

If you don’t know how to do that first step, you need to post the exact model name of your phone that’s typically in
Settings > About phone > Model number

With that information and verifying a few features haven’t been disabled, it should be quick and fast to get you set up.
With your phone functional in a known way, it would then be very quick and easy to set up your openSUSE to connect depending on your phone.

TSU

None of that is applicable to this thread. It’s about an internal LTE broadband device that the OP would like to use for mobile connectivity. Unfortunately, the device does not yet appear to be supported.

I missed that in the first post.

This Debian bug discussion suggests that support should be in a yet to come or just released bleeding edge kernel, patch has already been submitted upstream.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=828820

I took a look around and couldn’t find a VendorID:DeviceID for this modem. If such can be found (or contact Dell or Qualcomm for the info), I’d think that it shouldn’t be that difficult to write a udev rule and possibly definition that could get at least basic functionality working (I couldn’t guess if any advanced or unique features would be easily defined. Maybe Dell or Qualcomm would be willing to help… Or, maybe that is all in that upstream patch).

TSU

Hi, just quoting from the release notes of Tumbleweed snapshot 20160825

. sierra-legacy,sierra: the implementation for Sierra modems
is now split into two different plugins: a ‘legacy’ one for
the old PPP and DirectIP based modems and the standard one
for the newer QMI and MBIM based ones.
. dell: new plugin for Dell rebranded devices from Novatel,
Sierra or Ericsson.

Maybe it is worth giving the latest TW LiveDVD a shot…

I took a look around and couldn’t find a VendorID:DeviceID for this modem.

The chipset details were provided by the OP (post #4)

P:  Vendor=413c ProdID=81b6 Rev=00.06

If such can be found (or contact Dell or Qualcomm for the info), I’d think that it shouldn’t be that difficult to write a udev rule and possibly definition that could get at least basic functionality working (I couldn’t guess if any advanced or unique features would be easily defined. Maybe Dell or Qualcomm would be willing to help… Or, maybe that is all in that upstream patch).

TSU[/QUOTE]
Yes, perhaps.